Issue filling on when logged in


I'm having an issue filling on Dropbox. Not on the login page which works fine but when logged in.

The issue happens when changing the security preferences. Dropbox then asks for my password, and I try to fill it with 1Password. But instead of filling the password field, it fills the search box in the background with my email address and leaves the password field blank.

The issue is NOT present when using Dropbox in English, then it works as expected. But it's not working when I'm using Dropbox in Swedish. I tried French, and the issue was present there as well.

1Password Version: 6.8.8
Extension Version: 4.7.0
OS Version: macOS 10.13.4
Sync Type: Dropbox


  • brentybrenty

    Team Member

    @Xe997: Hmm. First of all, thank you for the detailed explanation. I would have been looking in entirely the wrong place without it.

    However, it's possible that I still am, since I can't reproduce this. I'm at this URL:

    And I clicked the "Two-step verification" option, which got me a password prompt. I was able to get 1Password to fill there (though I did still see the Search filed in the background in the upper right, which I think is what you were referring to).

    On the other hand, since I'm running the beta of 1Password 7, I wonder if the changes we've made to the form filling "Brain" there are to "blame" for this working for me and not you. Would you be willing to try that?

  • I'm no stranger to betas, in fact it was the announcement of the 1Password 7 beta that got me in bug reporter mood!

    So I tried with 1Password 7 and its new Safari extension, but same result unfortunately (nice work on the new design btw!) I did re-create the Dropbox item in 1Password 7 and tried to fill that new item but still, no luck.

  • brentybrenty

    Team Member

    @Xe997: Thanks for the kind words! Glad you're enjoying the 1Password 7 beta! I owe you an apology though, as I originally overlooked what I think is the key to all of this: language. Can you tell me how you're changing it? I must be looking in the wrong place in Dropbox. I suspect we have an explicit exclusion for Dropbox's search field. If you can tell me the name of the search field in Swedish and French, that may help, but I think it would be better if we can reproduce it and test against it going forward. Thanks!

  • edited March 2018

    @brenty Sure! I changed it at under Preferences, and the change should have effect immediately.

  • brentybrenty

    Team Member
    edited February 2019

    @Xe997: Ack! I can't believe I missed that. Thank you! I can't believe how easy it was. I'm used to doing defaults write commands in Terminal to change languages.... :lol:

    Anyway, I was able to reproduce this, and have filed an issue. I suspect that avoiding search fields in other languages will help us with more than just Dropbox. Thank you! :chuffed:

    ref: xplatform/filling-issues#152

This discussion has been closed.