Quirk with nested tags / BUG with editing tags

nm1nm1
edited April 2018 in Mac Beta

UPDATED 2018-04-05 19:55 EDT

This isn't a bug so much as a difficulty with 1P7 that arises with the implementation of nested tags and which might cause some people (especially those who use tags heavily and those who have come up with their own workarounds for the absence of nested tags in previous versions) frustration with the initial upgrade.

Intuitive though it is for 1P7 to interpret / (forward slash) as a separator between parent/child tags, the inability to control whether 1P7 interprets / that way has left me with nested tagging structures that I have to manually go back to fix.

In my case, since I have purchased software through 'bundle' offers and want to keep the licenses grouped by bundle in which they were purchased, I have imported the licenses and then tagged all 1P license entries with othercsv-import-$DATE(MM/DD/YYYY) (as in the screenshot).

Even though the tag itself stays intact with the upgrade, the tag list parses the / and I end up with nested tags for each of the / (as in the next screenshot).

Since I happen to have more than one tag that begins with othercsv-import-03, I end up with a child tag for each of the day values [14 and 25], as well as a tag for the year values [2017].

In my case this is relatively easy to fix, but for some people who have 'hacked' a nested tagging structure prior to 1P7, unless they used / as the delimiter and unless they don't use / in any date values that might be in their tags, they will end up with a mess of tags to clean up.

A better way to implement nested tags might be to broaden the delimiter to the character sequence / (that is, [space] on either side of /) or to use something more unique (like Omni Group does in OmniFocus), such as ::. Or better yet -- to allow the delimiter to be set in the 1P preferences menu so that users can adapt the implementation to their use case.

UPDATE: It appears that attempting to edit the tags of existing items in the vault causes a complete crash. At first I thought this might be related to TextExpander and the Finder security that prevents TextExpander from working in 1P; however, after disabling TextExpander from interacting with 1P6 and 1P7, editing tags still causes a complete crash. I will send in the console log in for review.


1Password Version: 1Password 7 Version 7.0.BETA-6 (70000006)
Extension Version: Not Provided
OS Version: OS X 10.12.6
Sync Type: N/A

Comments

  • LarsLars Junior Member

    Team Member

    Thanks for the detailed report, @nm1. This is an issue we've seen already, and we're looking into ways that we can minimize the impact on users who've already incorporated certain characters (mainly the slash) into existing tag ecosystems. I'm not certain we can find a way to deploy nested tags without running the risk of upsetting some existing apple-carts, but we're certainly going to see what we can do in this regard.

    ref: apple-286

  • thightowerthightower T-Dog Agile's Mascot

    +1 as far as going back and trying to remove the / from tags. It causes a crash repeatedly. Multiple crash reports sent.

  • BenBen AWS Team

    Team Member

    We are aware of that crash. Thanks @thightower.

    Ben

  • GuffeeGuffee Junior Member

    Several users, on this page & elsewhere, have posted about troubles with their tags that required editing. Above, a writer warns of a common problem similar to the one I have: people who import data from an earlier version of 1Password which used folders (no tags) and some of those folder names had a forward slash "/" in them, find that those names become "broken up" (parsed) in 1Password 7.

    In my case, that wouldn't be so bad, as there weren't many and I could easily go back and fix each of them; however, I am completely unable to edit an Item's tag. Its field is a bright shiny blue and my curser is inactive in it.

    Yet, in every other case I've seen, in these forums, which require editing of an Item's tag, the writer is able to do so.

    So, how does somebody edit Item tags? I just installed 1PW7 a few days ago; have I failed to set up some permission correctly?

    P.S. — I've never used tags before, in any form or fashion.

  • brentybrenty

    Team Member

    @Guffee: It's something we'd like to improve, but a good workaround is, especially if you want to change a tag for multiple items, select that tag in the sidebar, edit one of them to add a new tag for what you want, and then select all of them to drag to that new tag in the sidebar to add it to all of them simultaneously. You can then right-click the original tag in the sidebar and delete it. :)

    You can edit individual tags by double-clicking them to though. The other method above is just much easier when you want to change a tag for more than one item. Cheers!

  • GuffeeGuffee Junior Member

    Brenty, how do I edit a tag in the sidebar? The only choices I see, gotten by right-clicking on it, are "Rename" and "Delete."

  • GuffeeGuffee Junior Member

    I forgot to mention that, as I first wrote, I really am unable to edit individual tags. Their color is flat until I click, or double-click, (or quadruple-click) on them, then their color changes to a bright shiny blue as if they were ready to be edited, but they don't respond to my cursor.

    If I could edit individual tags, even though it would be a bit of work to straight everything out, I would be very happy :)

  • GuffeeGuffee Junior Member

    Brenty, hold the fort! I can edit individual tags OK now! I thought you couldn't be mistaken about such a simple, basic matter, so I persisted; and of course you were not mistaken. I was such a blockhead I surprised even myself! I'd rather not say what I was doing wrong because it's embarrassing. Thank you, very much.

  • brentybrenty

    Team Member

    @Guffee: Glad to hear it! But sorry, I should have been more descriptive in the first place. I was referring to editing from the item's details to modify the tag(s). I agree that it's not completely obvious, so hopefully we can improve that in the future as well. Thank you for the update, and your patience and feedback on this! :)

  • GuffeeGuffee Junior Member

    Good to hear from you again. I was a little slow, and I was not familiar with tags, but it finally it hit me how to edit the tags (although not how to change a tag for multiple items, even though I tried--but no matter, now) and I've got all (but two sticklers) of my items shipshape. It did take a lot longer than I had anticipated, but I'm well satisfied now. (Before you had convinced me to persevere(!), I had tried editing the item tags repeatedly, but I had failed to double-click the tag field most times, and the times I did double-click (& triple-click & quadruple-click, out of frustration) I must have had the bad luck to have forgotten to have first clicked 'Edit' up above.) Thanks a lot!

  • brentybrenty

    Team Member

    You're very welcome! Hopefully we can make it more intuitive in a future version, but we're here if you need us. :chuffed:

  • My approach to editing "/" issues in dates within object names, including complex tags, is to simply avoid "/" (and ":") altogether.

    Using ISO 8601 format for date in labels (2019-10-20) has two strong advantages:

    • It is editable almost anywhere in any OS.
    • It is sortable by almost any application or OS.
    • It is independent of regional preferences.
    • The ISO format can also include time with the same advantages.

    This is how I have avoided editing and sorting problems with object naming in many diverse environments.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file