New iMac - I have standalone 6 family on old iMac and MBA and iPhone

I've requested the license and downloaded it (1Password 6 for Mac Family License) but the new iMac 1P (from App Store) doesn't accept it. How do I license the new copy - if necessary I don't mind deleting the old versions if I'm only allowed so many copies. I didn't "migrate apps" to new Mac. Thanks.


1Password Version: 1Password Version 6.8.8 (688001) Mac App Store
Extension Version: Not Provided
OS Version: latest
Sync Type: dropbox
Referrer: forum-search:New computer - how do I register 1password ? I have standalone 6 version on old computer (family)

Comments

  • brentybrenty

    Team Member

    @macgabe: Thanks for reaching out. I’m sorry for the confusion! The Mac App Store is owned and operated by Apple, so they won't recognize purchases made elsewhere. And unfortunately 1Password has no way of knowing whether or not you've purchased it unless you register the app with your license information. But the good news is that all you need to do is follow the instructions in the license email you received from your purchase and click the link to automatically install the license in 1Password to register the app and remove the trial restrictions. In that spirit, I've also resent your license information via email. I hope this helps. Be sure to let me know if you have any other questions! :)

  • Thanks - tried this before but couldn't get it to work. Have tried again just now to same effect.

    • When I click on the link in the email it goes to an "Apply Your 1Password License File page" on Agile Bits.
    • When I click on the link "Click Here to Apply Your License", it downloads the license (or something) to downloads and asks "Do you want this page to open 1Password?"
    • When I click Allow, it downloads something then says "Trial Expired" in 1Password "Purchase the license to access all features"
    • I tried "How to add a license" on that same dialogue window and "Add license…" and "Buy Now" but each one takes me on a journey of information and windows and signups for subscriptions and accounts etc which I don't think apply to me, and so here I am again!
  • I should add that I can read my passwords but it's all only Read Only

  • brentybrenty

    Team Member

    @macgabe: Just to confirm, did you remove the Mac App Store version of 1Password? That's the only way you'll see "read only" at all. It sounds like you're trying to apply the AgileBit Store license to that, and that simply cannot work. So if you haven't already, drag it to the Trash (DO NOT use a "cleaner" app!), restart your Mac, and then install the app from our website as indicated in the license email. Then you should be able to apply the license.

    If you're still having trouble, the best thing to do will be to generate a diagnostic report so we can look at the logs to determine exactly what is happening:

    https://support.1password.com/diagnostics/

    Please send it to [email protected] and add the following Support ID (including the square brackets) to the subject of your diagnostics email before sending:

    [#JAN-27497-295]

    If you’re reading this and you are not macgabe, this Support ID is for macgabe only. Please ask us for your own if you also need help.

    This will link your diagnostics to our current discussion. Let me know once you've sent it. Once we see it we should be able to better assist you. Thanks in advance!

    ref: JAN-27497-295

  • Thanks! Sorted with Migration Assistant which I tried not using but looks like there's no way round for some apps. It was the old App Store problem.

    Shame moving computer is still so complicated decades in.

  • brentybrenty

    Team Member

    Ah, gotcha. Thanks for the update! Certainly it's still easier than Windows, but also room for improvement. Cheers! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file