Can't delete item from 1P vault

I have many (275) documents in an error state ("Unable to load document") leftover from the migration from local vaults to my 1P account, and I'm unable to delete these items. When I try to delete through the web interface I get an error "Failed to trash item: Unknown error: The request response is empty".
If I try to delete from the macOS app (v7 beta 6) the item goes to the local trash, but this change isn't synced (doesn't show in the web interface or in iOS [beta] app) and I can't empty the trash afterwards (nothing happens after selecting to empty the trash).
I was able to delete one of these documents in the iOS (beta) app, and the document then showed in the trash in the web interface and I was able to empty the trash on the web, but the document still shows in the list of documents for the vault on the web and in the macOS app, but has been successfully removed from the documents on the iOS app with which it was deleted in the first place.

This is a really weird problem, and I'm concerned it's indicative of problems with 1P sync.

Thanks,

Tim


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • LarsLars Junior Member

    Team Member

    @twilsonco I'm sorry for the trouble!

    This is a really weird problem, and I'm concerned it's indicative of problems with 1P sync.

    Probably not unless a significant number of people report the same problem. So far, yours is the first report we've had of such a thing, which doesn't make it any less significant for you, but probably means it's specific to something in your own 1Password setup/process.

    I'm just spitballing here, but in another thread you started, you listed "macOS 10.13" as your operating system, and 7.0.BETA-5 as your version of 1Password 7 for Mac. Is that correct? If so, I'd like you to update to the current version of macOS (10.13.4) and the latest beta of 1Password (7.0.BETA-6, and probably soon to be BETA-7, hopefully). Let me know if that does anything. I'm not suggesting it will, but when working with betas, it's good to keep everything on the very latest version. If that turns out to not have any impact, then we'll move on to other troubleshooting. Thanks! :)

  • Sorry. This was for beta 6.

  • twilsoncotwilsonco
    edited April 2018

    Hi @Lars,

    I'm now on v7 beta 7, on macOS 10.13.4, and the problem persists. This was expected, however, since I'm unable to delete using the web interface anyways, so I didn't think the problem was (entirely) caused by the desktop app.

  • brentybrenty

    Team Member

    @twilsonco: Yeah that's definitely a sign that there's something else going on. Thank you for letting us know. Probably a bit counterintuitive, but I'd like you to restart your Mac, reproduce the same issue in 1Password for Mac, and then generate a diagnostic report so we can look at the logs to determine exactly what is happening, as that could give us some of the errors that are being generated:

    https://support.1password.com/diagnostics/

    Please send it to [email protected] and add the following Support ID (including the square brackets) to the subject of your diagnostics email before sending:

    [#TKH-13788-861]

    If you’re reading this and you are not twilsonco, this Support ID is for twilsonco only. Please ask us for your own if you also need help.

    This will link your diagnostics to our current discussion. Let me know once you've sent it. Once we see it we should be able to better assist you. If nothing else, I can put you in touch with the web team to investigate further if that's truly where the problem lies. Thanks in advance!

    ref: TKH-13788-861

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file