Android - Unable to connect to the server

I've setup 1password families and requested my mom to join (as Guest). She had difficulties with initial sign up and did not know how to download emergency kit.

So I went on to do a "Begin Recovery" for her and managed to get the emergency kit scanned. But she kept getting a message on her Asus Zenphone Max running Android 6.01 (with 1password 6.7.3) stating "Unable to communicate with the server. Please check your network connection and make sure the sign-in address is correct".

I asked her to try it with mobile network instead of wi-fi and it was still the same. I read somewhere in this discussion forum that connection needs to be secure and it could be a firewall or anti-virus blocking things. So I felt there must be something weird in her end.

Surprisingly, I got the exact same result when I downloaded 1password (6.7.3) on a spare android I got (Galaxy A3 running Android 6.0.1) and tried scanning her bar code. Using my own emergency kit, everything worked perfectly.

I conclude the issue is with the emergency kit generated while using "Begin Recovery" feature. Is this a known bug? Could it be a specific bug with latest 1password version for guest family member?


1Password Version: 6.7.3
Extension Version: NA
OS Version: Android 6.01
Sync Type: NA

Comments

  • Completed another "Begin Recovery" process. It worked this time without a glitch!

  • brentybrenty

    Team Member
    edited April 2018

    Glad to hear it! Thanks for the update. Account recovery can sure be a lifesaver. I wonder if some settings or software were preventing the secure connection from being establish. It sounds like you should be all set, but let us know if you have any questions. :)

  • I'm having this same issue. I already did 2 recoveries with no success. App version is 7.1.5

  • brentybrenty

    Team Member

    @Tortuguita: Account recovery has nothing to do with it. 1Password cannot connect to the server securely with your network configuration. Try a different network and/or disabling any software that's interfering, like VPN, proxy, or "security" ware.

  • edited July 8

    Yes, I figured this much, but I stumbled across this post while searching for answers to my issue, and I thought I'd post that here.

    Here's a fully detailed account of what's going on on my end. As you can see, I have tried disabling all possible network applications that could affect my connectivity https://discussions.agilebits.com/discussion/105280/android-app-stuck-in-a-sign-in-loop-tried-everything-i-could-think-of-please-help/p1?new=1

    Note that I do have a VPN tunnel running straight from my main (and only) wireless router that I flashed with DD-WRT and uses an OpenVPN client, but this works fine, as all devices in my home are connected to this router, with no issues (including my phone with my 1password app which is the exact same model of hardware and software versions as the one with the problem, and in particular, including the phone with the 1password app problem, where everything else but this app works fine).

  • ag_anaag_ana

    Team Member

    @Tortuguita:

    Thank you for the clarification! So we don't spread information over two different discussions, we will get back to you in the new one you created ;)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file