1p-Extension (4.7.0.92), 1Password (4.6.2.626), Firefox 59.0.2 (32/64 bit), Windows 7 Pro x64 SP1

Hi guys,
I have problems get the 1p-Extension to work in Firefox.
I am using the versions mentioned in the title and nearly tried everything.
The 1p-icon is "clickable" but it has no effect when clicking on the icon (no menu opens). There is also no effect, when I am clicking on the 1Password item in the context menu (right click on website).
When the protocol is set to WebSocket, the icon is "not clickable".

  • .NET Framework is installed (v. 4.7.1)
  • 1p-Helper is set to use Native Massaging Protocol
  • I use Firefox 64-bit version, but also tried installing the browser extension in 32 bit and tried the portable version (32-bit) from portableapps.com with the same result
  • Of course I tried restarting the helper and Firefox, reinstalling the extension and Firefox itself and rebooting the system. Only thing I didn't reinstall is the 1Password-Manager
  • I also tried to install .Net 4.6.2 and the installation finished successfully, but obviously the version is integrated in .Net 4.7.1, because 4.6.2 does not show up under installed programs.

Is it possible, that I am missing a special Windows Update that is required? If yes, i will try to install that update, but I don't want to install ALL available updates, since my experience is that it isn't always the cleverest thing to do... But please - this thread is not a discussion whether this is smart or not :p

Thank you very much for all your help!

PS: Not sure if this is relevant, but a while ago I used Firefox ESR with the old 1p-Extension (I think 4.6.8) and this worked for me. But since I switched to Firefox "Quantum" I never got it up and running... :(


1Password Version: 4.6.2.626
Extension Version: 4.7.0.92
OS Version: Windows 7 Pro x64 SP1
Sync Type: local

Comments

  • GregGreg

    Team Member

    Hi there @nerox,

    Thank you for getting in touch!

    First of all, from a security standpoint it is very important to run the latest version of Windows and install all of the updates, especially if you have Windows 7 and not even Windows 10. Is there a particular reason why you don't install Windows updates? Please share your experience.

    Secondly, please let me know the following:

    • Does 1Password extension works in other browser, e.g. Chrome?
    • Do you have any type of AV/anti-malware software on your computer?

    Thanks!

    ++
    Greg

  • I have the same problem:

    • 1p-Extension (4.7.0.92),
    • 1Password (4.6.2.626),
    • Firefox 59.0.2 (32/64 bit),
    • Windows 10 Pro x64

    I am using desktop version 4.6.2.626. Now de browser extensions of firefox and Chrome are not working.
    I have installed them but there is no connection with the desktop app

    How can I fix this?

    kind regards,
    Raymond

  • brentybrenty

    Team Member

    @RaymondB: Make sure you have Native Messaging enabled in 1Password Help > Advanced. And if you're still having trouble please answer Greg's questions above, and let me know the specific error(s) you're encountering. Thanks!

  • Thank you, it is working now.
    This is de solution.

    with kind regards,
    Raymond

  • GregGreg

    Team Member

    @RaymondB: Great news! On behalf of Brenty you are very welcome! :+1:

    We are always ready to help you with 1Password, so do not hesitate to reach out to us anytime.

    Cheers,
    Greg

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file