I get Unable to reach our server when trying to save password

2

Comments

  • Hi @dteare - I've removed the extension and installed it again, and in each browser / profile that seems to have fixed that problem for me. Many thanks, and good luck figuring out the "why"!

  • brentybrenty

    Team Member

    @mhl20: Thanks for the update! Glad to know that helped. I think @dteare likes a good puzzle, so hopefully he'll have some fun with this one, but the data point helps. We're here if you need us! :)

  • haskelhaskel
    edited June 27

    Hi, same for me. Occurs at different sites, no network errors, no errors in site console.
    License is active
    1password version: 7.0.4
    extension version: 1.7.3
    browser google chrome, version: 67.0.3396.87
    extension console error:

  • brentybrenty

    Team Member

    @haskel: Thanks for getting in touch! We have some improvements in the beta that should help with this. Would you be willing to give that a try?

  • FYI, in case anyone is using the Duo integration...

    I've only tested this on one machine, so I don't have a large sample size. However, when using the Duo integration, if the "Remember Device Authentications" is left at zero (or blank), then this error comes up. I've been able to reproduce it many times. As long as the "Remember Device Authentications" is set to 1 or higher, then all seems to work fine.

  • brentybrenty

    Team Member

    @itgjc: Sorry about that! It isn't supposed to be possible to set it to zero, as you'd then need to authenticate over and over and over (you get the idea) again. We'll get that fixed.

    ref: b5-4807

  • This happens at random times to me as well, and sadly, I haven't been able to figure out what's causing this.

    But the good news is that, trying to lock the extension and enter the master password again fixes this.

  • brentybrenty

    Team Member

    @arunsathiya: I'm sorry for the trouble. We're looking into it. When you get the error, can you check the logs and tell me what it says there?

    1. Open Chrome and go to chrome://extensions/
    2. Under 1Password X, click "background page"
    3. Click "Debug" underneath "1Password X - Password Manager"
    4. Select the "Console" tab
    5. Unlock 1Password X
    6. Copy everything in the Console and save it to a text file

    That may help us narrow down the cause. Thanks in advance!

  • reinstalling 1Password X in Google Chrome worked for me :)

  • brentybrenty

    Team Member

    @Swishy888: Glad that helped! Did you by any chance make some account changes since you setup 1Password X with your account?

  • I just installed 1password and i am having this issue on Firefox. I can't save any password. Please help me with this as i am on my trial period.

  • brentybrenty

    Team Member

    @tzic: I'm sorry for the inconvenience. There is no 1Password X beta for Firefox currently, which would help with this issue, but once we release a new stable version you'll be updated automatically. In the mean time, you can either use the 1Password X beta in Chrome or the 1Password.com web interface if you need to manage your data in a browser. And hopefully it won't be long before the next update either way.

  • Having the same issue here, especially when using Proton VPN. Very frustrating, since I need my VPN on at all times. This limits me to use 1P, unfortunately. Will try beta now and report back if it helped.

  • Do I need a membership for the BETA?

  • Issue is resolved on the BETA it seems :)

  • Hi @Geek,

    I'm happy to learn the beta helped. If you run into any issues please let us know.

  • brentybrenty

    Team Member

    :) :+1:

  • I am still seeing this issue in 1Password X Beta for Chrome version 1.11.4

  • brentybrenty

    Team Member

    @felixfbecker: Doh! Can you grab the logs next time it happens?

    1. Go to chrome://extensions/
    2. Turn on Developer mode in the top right
    3. In "1Password X - Password Manager" click the "background page" link
    4. Click the Console tab and copy/paste any red error messages (unless they're about message ports)

    Thanks!

  • Any timeline for the Firefox fix for this issue? This just happened to me on abebooks.com. Lock and unlock fixed the problem. I'm using:

    Mac OS X: 10.13.6
    1Password7: 7.2.1
    Firefox: 62.0.3 (64-bit)

  • brentybrenty

    Team Member
    edited October 10

    @boberonicus: Version 1.11.0 stable was released yesterday for both Chrome and Firefox. Have you tried that?

  • Issue is back again. Beta.

  • I'm running into this issue again as well.

    Chrome: 69.0.3497.100 (Official Build) (64-bit)
    1passwordx: 1.11.0

  • edited October 12

    @brenty
    I had been using Firefox 1PasswordX 1.10.3 when I noted this problem. I deleted that and installed 1.11.0 per your suggestion. This fixed the problem for me.

    Thanks!

  • I spoke too soon! Put my laptop to sleep, opened it up, and had the "unable to reach the server" message for a different web site. So this is still an issue in 1.11.0. The lock/unlock trick didn't work either. Bummer!

  • dtearedteare Agile Founder

    Team Member

    Well poo. I had hoped we nailed all of these issues. We certainly fixed many of the root causes of this problem but it looks like we missed at least one.

    It's time to start debugging this and see where it takes us. Please collect your console logs from the background page and share those along with your browser and 1Password X versions.

    Thank you! Hopefully we can nail the remaining issue quickly. 🤞

    ++dave;

  • dtearedteare Agile Founder

    Team Member

    Oh, I forgot to add something @bcatubig & @boberonicus: when you attach your logs, please include your automatic lock settings as well. They're likely key to unraveling this mystery.

    Thanks!

    ++dave;

  • dtearedteare Agile Founder

    Team Member

    I managed to recreate this save issue! 🎉 Now we just need to find out how to fix it. 😂🤞

    The way I managed to recreate it was to completely disable Autolock in Settings and then put my MacBook Pro to sleep for over 30 minutes. When I came back I was unable to save new logins. I needed to lock 1Password and unlock it again to make it work.

    Is this the same setup you're using, @bcatubig & @boberonicus?

    ++dave;

  • edited October 14

    Since my last post, I've been trying to recreate the problem and capture a log for you with no success (no "unable to reach the server" messages).

    Having used the product half-assedly to memorize a handful of my own low-quality passwords since 2008, I decided to go all in and actually give myself over to the product's auto-generated passwords (thanks ransom email!) So, I have over 900 logins to edit/delete/change. I'll keep banging away and post something useful if/when I hit it.

    Here are my security preferences in the main product:

    and in the browser extension:

2

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file