Credit card expiry date field not valid [Legacy field, working on fixing it soon]

crommcromm
edited May 2018 in Windows Beta

I've got 7 credit cards in my stand alone vault. Half of them are have "Expiry Date" field saying "This field is not supported by this version of 1Password". Yet the other have is showing Expiry Date without issue.

Edit - also happening for my drivers license (only one of those unfortunately)


1Password Version: 7.0.541
Extension Version: Not Provided
OS Version: Win10
Sync Type: Dropbox

Comments

  • brentybrenty

    Team Member

    @cromm: Thanks for reaching out. I’m sorry for the confusion there! It sounds like there may be some legacy data there that the new app does not support. If you create a new item, does it work as expected? Do you know where and when you might have created these items?

  • Driver's license was created 2013, as were some of the credit cards that don't work with that field. However I've got two credit cards that were created on the same day, one is showing the expiry date without issue and the other shows the error message.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @cromm,

    We'll need to review your item's data structure to understand why 1Password can't parse it, we won't need the data itself, just the way it is laid out. If you're willing to help us fix this, can you do the following:

    1. Select the affected credit card item in the main 1Password window and press F12 on your keyboard, this will bring up 1Password Developer Tools window
    2. In this window, it'll show your item's raw content. Click on Remove personal data blue text on top right to remove your data
    3. Your data should now be sanitized but make sure that it got all of it. Copy and paste this to send it to us at [email protected] and please include the link to this thread and your forum username, so we can connect the email to this thread.

    Thanks!

  • Requested information has been emailed

  • brentybrenty

    Team Member

    @cromm: Thanks! I see that we've received your email, so we can continue the conversation there. We'll take a look at them and get back to you shortly! :)

    ref: FNB-99922-352

  • I have experienced this after conversion to 7 too. I just edited those 3 cards I have noticed being affected manually. Do you need anything from me?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @mzel,

    Yes, we need to look at the original items to see how they were originally saved. Do you still have 1Password 4 installed with the original AgileKeychain vault? If yes, can you email us at [email protected] with your forum username and the link to this thread included, so we can work with you directly to figure this out.

  • I upgraded to 1P7 on my desktop PC, but not on the laptop. I still have 1P4 on my laptop, but it is using the opvault repository. I do not remember switching to opvault, and I do not remember deleting the old repository either. However I can not find the old agilekey repository in my Dropbox

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @mzel,

    That would mean you were already using OPVault and 1Password 7 didn't convert anything.

    We found the cause of the issue as the Credit Card item was originally created with a legacy structure for expiration type that we don't use anymore. We're working on adding special handling to upgrade that field to the one we do use, our aim is to have it in the next update.

    ref: OPW-2144

  • Ok, thanks. It is possible that I converted to OPVault long time ago

  • MikeTMikeT Agile Samurai

    Team Member

    Yep, OPVault came out a few years ago, it's just that 1Password 4 did not default to it.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file