1Password keeps asking for proxy credentials

Everytime 1Password starts I get a pop up dialog to enter my proxy user/password:

Authentication required
The server proxy such_and_such is asking for your username and password. The server reports that it is from proxy.

This is on my office computer. Usually programs get the proxy credentials by default from the operating system, but not 1Password 7.

Best regards,

Juan Andres

1Password Version: 7.0.541
Extension Version: Not Provided
OS Version: Windows 10
Sync Type: local vault

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Susto,

    Thanks for writing in.

    This happens because Windows isn't passing on the default credentials to us when we requested it and thus, we need to ask you to enter the credentials manually.

    Just to be sure, did you ever enter the proxy address manually in 1Password? If you did, try removing the proxy address from 1Password's proxy settings via 1Password's Advanced settings and then click Apply. 1Password will recheck for the default credentials.

  • Proxy settings via advanced settings are empty (see attached image).

    Cancelling the start up proxy dialog produces this log:
    W 139.156ms 1 proxy authentication manually cancelled.
    W 139.230ms 7 proxy connection error: RequestProhibitedByProxy

    If I do enter the credentials, this is the log:
    I 25.350ms 1 authenticating with proxy server.
    I 26.034ms 1 user proxy credentials accepted by server.
    I 26.726ms 7 network connection ok
    I 26.728ms 7 Using proxy configuration, address: True, valid address: True, username: True, password: True
    I 26.729ms 7 proxy is in use
    I 26.729ms 7 network configured in 26.152ms

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Susto,

    Do you know what HTTP Authentication scheme your office proxy is using? 1Password currently only support Basic and Digest HTTP schemes.

    I'm glad to see it works when you entered the credentials manually.

  • According to our IT people, we use "Active Directory Single Sign On” mode. This is a company wide setting and cannot be altered.

    Regards,

    Juan Andres

  • MikeTMikeT Agile Samurai

    Team Member
    edited May 2018

    Hi @Susto,

    That's most likely the scheme that we do not support. We'll take a look to see if we can add it in a future update.

    Thanks for finding that out for us.

  • @MikeT is there any update on this? I am currently having the same situation in the office, where I am using 1Password. I am on version 7.3.684 and we are using as well "Active Directory Single Sign On” and no chance to change it. The popup shows up every day and the only thing I can do is closing it without entering a username/password. 1Password still works, but the popup is awful.

    Thx for feedback on this.

  • MikeTMikeT Agile Samurai

    Team Member
    edited September 13

    Hi @thomcheezy,

    At the moment, we do not support Active Directory Sign On and I'm not sure we will be able to any time soon. However, we are making some adjustments to how proxies work in the upcoming 1Password 7.4 update and it may help.

    If your office is using 1Password.com Teams/Business membership, you should use that channel to report that issue as well.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file