"Show 1Password mini" in Chrome Incogito [Update to 7.1.1 / enable extension in Incognito]

edited August 31 in Mac

AgileBits Update: Please update to v7.1.1 and make sure you’ve enabled the 1Password extension within Incognito mode. Chrome disables all extensions in Incognito by default. Please see this post for instructions: https://discussions.agilebits.com/discussion/comment/432699/#Comment_432699


The "Show 1Password mini" global shortcut - Command-Option-\ by default, though the bug still applies if you change it - doesn't work if you trigger it while menu bar auto-hiding is enabled, the menu bar is not visible, and a Chrome Incognito window is currently focused. 1Password mini does not show up, and if you later show the menu bar (e.g. by moving the cursor to the top of the screen), the 1Password Mini icon is highlighted blue, as if it's open. Clicking it de-highlights if, as it closing it, but at no point is the 1Password Mini window shown.


1Password Version: 1Password Version 6.8.8 (688001) Mac App Store
Extension Version: 4.7.0.90
OS Version: macOS 10.13.4 (17E202)
Sync Type: iCloud

«1

Comments

  • brentybrenty

    Team Member

    @TristanBerger: It sounds like you just don't have 1Password enabled in Chrome in Incognito Mode. Is that correct? In that case, that's expected, as 1Password simply cannot function there at all then. I'm not saying you have to enable it, only that it can't work there otherwise. I hope this helps. Be sure to let me know if you have any other questions! :)

  • @brenty thanks for the reply!

    That's correct, I don't have 1Password enabled in Incognito mode. And I realize that means 1Password doesn't have access to the current page in this case. What I expected was for it to fall back to the behavior it has when there is no current page, for example when Finder is focused: to show the 1Password Mini window, letting me browse passwords, and just omit the smart autofill entries. (Or, if it really wanted to be fancy, with one disabled autofill entry telling me why it can't autofill.)

    At the very least there's a graphical glitch here, as hitting the shortcut in this situation causes the menu bar highlight to show that Mini is showing, when it isn't.

  • LarsLars Junior Member

    Team Member

    @TristanBerger - thanks for the sharp eye on this. I've passed it along to our development team. :+1:

  • LarsLars Junior Member

    Team Member
  • oanoan

    +1 for this feature :)

    I usually login to clients webpages through an incognito window, and it would at least be nice to get the 1Password Mini window to open for me to browse passwords.

    I'm using the 1Password 7 Beta

  • LarsLars Junior Member

    Team Member

    @oan - are you using multiple Chrome profiles? Because it should work if you're not. We do still have an issue if users are using multiple Chrome profiles AND incognito mode in one of them, but if you're a single-profile user, this should be working for you. At least, it is for me here.

  • brentybrenty

    Team Member

    Thanks for the feedback! Perhaps it's something we can adjust in future updates.

  • mlebarronmlebarron Junior Member

    Just had this problem, looks like this is already on the radar. I do have multiple profiles and whenever an incognito window is the active window 1Password mini doesn't open at all, with keyboard or the menu bar option. This is an unfortunate regression in functionality. I get that the extension isn't installed so I can't use it within the browser window, but it should still at least open, just like it does when I'm in safari's incognito.

  • LarsLars Junior Member

    Team Member

    Thanks for reporting, @mlebarron.

  • oanoan
    edited May 22

    @Lars As I understand I have only one profile in Chrome's settings in the People section. Maybe "Sync" is counted as an additional profile?

    Here:s a video of me trying to open the mini: https://www.dropbox.com/s/4o3mcr1ffl4dvby/1password-mini-incognito.mov?dl=0

  • LarsLars Junior Member

    Team Member

    @oan - wasn't able to access your video, but I would doubt "Sync" counts for these purposes. I'd try restarting your Mac (which will also give you fresh starts of both 1Password 7 for Mac and Chrome, and let us know if that helps any. I'm suggesting this because opening the mini from Incognito works quite well here, so I'm not sure why it wouldn't be for you, if you've allowed it in Incognito.

  • When I use a keystroke, or click on the tray icon for mini, a window doesn't come up. I understand that it may not be able to fill on an incognito page, however it has been useful to have the window open so you can grab what you need quickly....


    1Password Version: 7.0 BETA-19
    Extension Version: 4.7.1.90
    OS Version: OS X 10.12.6
    Sync Type: Dropbox

  • Hi @grinch,

    If you want 1Password to work in incognito mode, which it can, you need to manually enable it as by default Chrome won't allow any extensions to work in an incognito window. Visit chrome://extensions/ in Chrome and click on the Details button. In there is an option titled Allow in incognito. If you enable that you should find the 1Password extension now works for you.

    Separate from this is an issue with 1Password and windows that do not have the extension for whatever reason. 1Password mini is failing to display a generic dialog and that will need to be addressed.

    ref: apple-1113

  • Thanks @littlebobbytables - I had no idea that switch was there....It must be new or had forgotten I'd thrown it in the previous version....

  • Hi @grinch,

    It's been there for a while but I couldn't tell you what version of Chrome added it. What is different is it didn't used to be so hidden, the previous extensions page had the switch directly accessible and a bit more obvious that it was there. Glad I could help :smile:

  • I'm a web developer show frequently jumps into Incognito to test a page without any browser extensions running (as they can affect the page). For this reason, I do not want to allow the 1Password extension to run in Incognito.

    It seems 1Password mini should still work (with the shortcut or by clicking the menu bar icon directly) regardless of which app is focussed and whether or not the browser extension is running.

    Due to this bug, my workaround is to open the full 1Password app each time I need credentials and I'm in Incognito.

  • LarsLars Junior Member

    Team Member

    @oliverjash2 - If you're using 1Password 7 for Mac, the keyboard shortcut to open the mini ( ⌥⌘\ ) should work globally, regardless of your Incognito status. Still not going to be the smoothest experience for someone in your specific set of circumstances, but it should save you having to open the main 1Password window each time.

  • As others in this thread have reported, mini does not open (using the shortcut or when clicking on the menu bar icon) when the focussed app is an Incognito window. I believe this is a bug.

  • LarsLars Junior Member

    Team Member

    @oliverjash2 - then your experience is different from mine, having literally switched to Chrome and tried it just moments ago, to make sure nothing had changed and that my memory was correct. Did you use the alt + cmd + backslash command to invoke the mini, and are you using 1Password 7 for Mac?

  • Did you use the alt + cmd + backslash command to invoke the mini, and are you using 1Password 7 for Mac?

    Yes to both.

    There are a few other users in this thread who have reported the same thing:

  • LarsLars Junior Member

    Team Member

    @oliverjash2 - hmmm, strange. Here's what I get:

    Sounds like next step for you would be to create a diagnostics report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/89401/bug-report-show-1password-mini-shortcut-doesnt-work-in-chrome-incogito
    • Your forum username: @oliverjash2

    That way I can "connect the dots" when I see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so I can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Once I see the diagnostics I'll be able to better assist you. Thanks very much!

  • Ah, so it only opens mini when you have enabled the extension in Incognito. However, I specifically don't want to do this. Disabling the extension in Incognito should not stop me from opening mini, it should only stop the integration (i.e. filling credentials).

  • LarsLars Junior Member

    Team Member

    @oliverjash2 - no, the extension is not enabled in Incognito. That's why I shook the mouse underneath the toggle for that option, on the extension page, in the first image in that gif.

  • I'll try to send diagnostics, but in the meantime here is a video:

  • rudyrudy

    Team Member

    @oliverjash2,

    I can't tell from your posts and @lars' replies, are you running 1Password 7.1.1?

  • LarsLars Junior Member

    Team Member

    @oliverjash2 - thanks for the GIF. Looks like you're using the menubar mini, not the keystroke combo ⌥⌘\ though it's hard to tell since keypresses are not shown.

  • I was running 7.0.7. I just upgraded to 7.1.1 and now it works! Thanks.

  • rudyrudy

    Team Member
  • edited August 31

    Fixed here too. Updating from 7.0.7 to 7.1.1 did it, wasn't necessary to enable in incognito mode. I'm betting it's this changelog item:

    • Fixed an issue where 1Password mini could not be opened when Firefox or Chrome were active but without active windows. {apple-issues#1113}

    Thanks!

«1

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file