firefox 1PX and down arrow

Hello,
1PX conflicts with firefox autocompletion using the down arrow key
Since, sometimes 1PX recognises incorrectly a user/password field, or sometimes I use a password not saved, I've seen that disabilng the icon inside forms changes this behaviour, but consider if it could be useful to keep icon in form (accessible using mouse pointer) and leaving the key to firefox


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    1PX conflicts with firefox autocompletion using the down arrow key

    @lcorsini: Thanks for getting in touch! I'm not sure we're going to design around browser autofill — it is always recommended to disable that for both security and usability reasons ("where is my stuff saved?"), but it's something we can look into. Can you clarify what the conflict is though?

    Since, sometimes 1PX recognises incorrectly a user/password field, or sometimes I use a password not saved, I've seen that disabilng the icon inside forms changes this behaviour, but consider if it could be useful to keep icon in form (accessible using mouse pointer) and leaving the key to firefox

    It sounds like the real issue may be that 1Password X is misidentifying the field. Is that the case? If so, that's definitely something we need to investigate. Can you tell me the URL?

    We do want 1Password X to be accessible using the mouse cursor, as that allows people to use assistive devices — or just use the keyboard because they prefer it. But either way we want to improve whatever we can. :)

  • Hi brenty,
    Let me explain better:
    Firefox caches the content of most form fields (and it's not related to the internal password manager) and this cache is accessible by pressing down arrow, the same (when internal password manager is disables) happens with username fied.
    For me, some password are better stored in my mind or I nedd to use a different user that is not stored in 1P, so mostly I autocomplete the username and insert the password by hand, and in this case 1px gets in the way trying to autocomplete the desired field

  • brentybrenty

    Team Member
    edited May 2018

    Hi brenty, Let me explain better:
    Firefox caches the content of most form fields (and it's not related to the internal password manager) and this cache is accessible by pressing down arrow, the same (when internal password manager is disables) happens with username fied.

    @lcorsini: Gotcha. Thanks for clarifying. But again, there are known exploits of browser "autofill" in the wild that can result in this information being collected by websites, so we do recommend disabling it.

    For me, some password are better stored in my mind or I nedd to use a different user that is not stored in 1P, so mostly I autocomplete the username and insert the password by hand, and in this case 1px gets in the way trying to autocomplete the desired field

    You may prefer it for some reason, but it's definitely not "better" for either usability or security. 1Password exists because we have too many passwords to remember, or not enough to keep us safe and secure online. 1Password solves this saving and filling passwords for us so that it is feasible to have a unique, randomly-generated one for each. Storing weak passwords in our brains and trying them ourselves is the thing that people got 1Password to escape from, so it's just not something we're going to design around.

  • MitchMitch

    Team Member

    Hey @lcorsini,

    Thanks for the feedback. I agree with Brent that you may have compatibility issues if you try to use the built-in auto fill at the same time as 1Password X. On the other hand, I’d like to add more control over keyboard shortcuts in a future release and the down arrow will be one of the ones on the list. :)

    Mitch

  • Maybe just give us the option of disabling the arrow down. I never use the arrow down to load some 1PS stored info, every time I use the arrow down I just wanna see the options that are saved in my browser.
    I've already checked false on "Make 1Password the default password manager" and "Allow 1Password to show notifications" but it doesn't work the I way I thought would. Unfortunately when I'm working and I know I'll face this issue a lot (since I'm testing websites and often use lots of different logins which are temporary and I don't wanna keep on my 1PS) I have to disable 1PS plugin completely.

  • DaltonDDaltonD

    Team Member

    Hey @malumatos. Disabling the "Make 1Password your default password manager" option allows you to continue using Firefox's built-in password manager, which may increase the occurrences where you're experiencing conflicts. Since it sounds like you prefer using Firefox's built-in dropdown menu for filling, you might find it useful to disable 1Password's inline menu and just using the popup to view and fill your items. You can disable 1Password's inline menu by opening the popup, clicking the gear icon in the top right corner, selecting Settings, then disabling "Offer to fill and save passwords".

  • Thank you, that's definitely a better option than disabling the plugin completely. But it would great if I could just disable the arrow down shortcut on the plugin and still have the option to click on the 1Password icon inside the inputs whenever I wish to use it.

  • brentybrenty

    Team Member

    Thanks again for the feedback. Perhaps we'll be able to offer more customizability in a future version. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file