Lock screen issue: 1Password X for Firefox on Ubuntu 18.04 🐛⚠️

beyerbeyer

Team Member
edited June 14 in 1Password X

We are currently tracking a bug with Ubuntu 18.04's ibus package which causes password fields to not focus correctly in Firefox. The 1Password X popup (which is opened by hotkey or by clicking the 1Password logo in your toolbar) can't remain open without maintaining proper focus. This is preventing 1Password X from being able to be unlocked from the popup in Firefox. So far we've only seen and reproduced this issue using Ubuntu 18.04.

This bug was reported to Ubuntu by one of the Firefox contributors and in our testing affects all versions of Firefox on Ubuntu 18.04.

There are a few ways you can bypass this issue until Ubuntu 18.04's ibus package gets appropriately patched:

  1. Unlock 1Password X by signing into your account at https://start.1password.com/signin: Any account that you have added to 1Password X will be unlocked by signing into it using 1Password.com.
  2. Change the Keyboard input method system to XIM: In the Language Support app, change the "Keyboard input method system" setting from iBus to XIM.
  3. Use the Wayland based display server: This issue appears to only be affecting X (the default display server). To try Wayland out, choose Ubuntu on Wayland from the cog on the Ubuntu log in screen.
  4. Downgrade or patch the ibus package (advanced): If you're the type of Linux user that knows their way around the terminal, you can try downgrading ibus which has been reported to solve this issue. We highly recommend you wait for an official patch for Ubuntu 18.04 and can't support any issues that arise from this process.

Please let us know if you see this issue on any other distribution or version of Ubuntu. We are proud to support Linux and rely on our amazing Linux users to help weed out OS specific issues.

We will keep this thread updated with any pertinent information that may arise.

&drew

Comments

  • josegfvjosegfv Junior Member ✭

    I just tried using the Wayland server and it works well. I will keep it like this until Ubuntu sends a fix for X.
    Thanks.

  • jonrandyjonrandy ✭

    Signing in on the web page works - but is far from practical. Not keen on using Wayland as it is slower on my system than X. Will try it and report back

  • brentybrenty

    Team Member

    Sounds good. :) :+1:

  • Signing in on the web page works. Its good enough for me until a definitive fix is released. Thanks!

  • brentybrenty

    Team Member

    Likewise, thanks for the update. Hopefully a fix won't take too long.

  • Tried the ibus downgrade too, much better workaround than singing in the web page... The bug was affecting the overall performance of Firefox whenever a page had a password input. Firefox was sluggish.

  • brentybrenty

    Team Member

    Ouch. Glad that made a difference for you then! When my browser is sluggish, it really cramps my style. :dizzy:

  • mfg36mfg36 ✭

    If you go to Language Support -> Keyboard input method system -> change from ibus to xim it works around the issue

  • brentybrenty

    Team Member

    Glad to hear that helped! Thanks for letting us know. :)

  • dserodiodserodio ✭

    Thank you so much for this. Besides making 1PX work, it also made my Firefox so much faster! I'm using the XIM input method workaround.

  • brentybrenty

    Team Member

    I guess I hadn't considered any other benefits, but I'm glad to hear that it's helping with that as well as with 1Password X in Firefox. Cheers! :chuffed:

  • I think it's worth noting that the XIM and Wayland workarounds can both cause incompatibilities with other applications.

    XIM currently causes display bugs in Gedit (the solid background isn't drawn). I'm not sure if other applications are affected. Relevant links: Ask Ubuntu question, Launchpad bug

    Wayland is still incompatible with some applications also, which is among the reasons why it isn't the default in 18.04 after a trial run in 17.10.

    Of course, these only matter to people who use the affected applications.

  • brentybrenty

    Team Member

    Good point. Thank you for mentioning that! Looking forward to more of this getting smother out in future releases. :)

  • lodelode ✭
    edited July 13

    Just wanted to let you know I'm affected as well, using GNOME Shell 3.28.1 on Ubuntu 18.04. The XIM keyboard input does not fix the issue for me. Switching to Wayland does work. As does the first workaround of first signing in on the website.

  • brentybrenty

    Team Member

    Interesting. Thanks for letting us know!

  • dajonkerdajonker ✭
    edited August 9

    I find that running a "vanilla" Gnome Wayland session on Ubuntu 18.04 is much more stable than anything else I've tried.
    You have to install the "gnome-session" package, restart, and choose the regular "Gnome" session (not Gnome Xorg) when logging in.

  • brentybrenty

    Team Member

    I tend not to prioritize stability necessarily, but that could be a good option for those who do. Cheers! :)

  • primeprime ✭

    I just updated to Pop!_OS 18.04 LTS and I have this issue. I wish I read this before I did a fresh install :(

    Any update on a fix yet?

  • brentybrenty

    Team Member

    @prime: Since the bug is in ibus it's not really something we have control over. However, one of Beyer's suggestions or another user's may help. It's worth a shot!

  • primeprime ✭

    @brenty
    I’m using the 1st option for now. I’ll check out the keyboard input next to see if I’m able to change this. I’m still a newbie on Linux :)

  • brentybrenty

    Team Member

    I hear you. I still feel most at home on Windows myself, in spite of not really liking it and using both Linux and macOS for decades too. Just what I grew up with. Old dogs and new tricks, as they say. :)

  • Hey guys,
    I'm glad I found this discussion. I wasn't having focus issues on forms (it was saying I needed to log in correctly) but I was having issues with the popup. My OS version is Ubuntu 18.04.1 LTS and I'm using Firefox 61.0.1 (64-bit). I was able to solve the popup issue with suggestion #2. Thanks for keeping us updated :smile:

  • brentybrenty

    Team Member

    Glad that helped! We'll continue to update this thread when there's more info. :)

  • I don't see a "subscribe" button so I'm just commenting to get notifications on this thread. Ignore me.

  • brentybrenty

    Team Member

    @fritzophrenic: No worries! But I did want to mention in case it helps you or anyone else in the future that clicking the "star" icon at the top of the thread will bookmark it so you can be notified of new posts, even without commenting. Cheers! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file