Activating Chrome 1password extension forces Chrome to be in front of any other running applications

If the extension is active, any time I try to leave Chrone for another application, and then type/click/do anyhting, I'm immediately back in Chrome. Everything is up to date: Chrome, Windows 10, 1Password.


1Password Version: latest
Extension Version: latest
OS Version: latest windows 10
Sync Type: dropbox latest

Comments

  • brentybrenty

    Team Member

    @empireoflight: What do you mean by "If the extension is active"? A browser extension doesn't have any control over window focus, as that's all handled by the OS. Which versions of 1Password, Chrome and the extension are you using, since you omitted that information from your post? Thanks in advance!

  • Thanks for your help. Not sure how I omitted the information since I stated they were all the latest, but I guess I needed to be specific:
    Chrome Version 66.0.3359.181 (Official Build) (64-bit)
    1Password for Windows Version 4.6.2.626
    1Password extension (desktop app required) Version 4.7.1.90
    MS Windows Pro Version 10.0.17134 Build 17134

    By active, I mean If I enable the extension (see attached). If I then switch to another application, say Photoshop or the file explorer, and the click or type anything, I'm instantly popped back into Chrome.

  • I installed it for Firefox vs. 60.0.1 and it behaves the same way. I can't even use the extension; clicking the icon does nothing, and hitting ctrl+\ doesn't do anything either. Could be I have some malware, but I ran several AV scans and didn't find anything.

  • GregGreg

    Team Member

    Hi @empireoflight,

    If you are using 1Password 4, please do the following:

    1. Quit Chrome and 1Password
    2. In Windows Explorer, enter %localappdata%\AgileBits in the address bar and press return.
    3. In the resulting folder, you should see a file named OPX4.auth. Delete this file.
    4. Restart your PC.
    5. Open the main 1Password app and go to the Help Menu > Advanced > Use Native Messaging.
    6. Restart your web browsers and check if the issue remains.

    Thanks! :+1:

    ++
    Greg

  • OK, that seems to have fixed things. Thanks.

  • GregGreg

    Team Member

    @empireoflight: Great! I am glad to hear it worked. :chuffed: Feel free to get in touch with us anytime.

    Cheers,
    Greg

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file