1Password 7.0.1 on Mac no longer works with EFTPS.Gov

I upgraded to 1Password Mac 7.0.1 this morning on my 2017 iMac running MacOSX 10.13.4. I have a login stored for EFPTS.Gov, however the 1Password entry no longer properly autofills in Safari. The login page is https://www.eftps.gov/eftps/login/loginInitial

When I look at my saved web form details, the 1Password entry still remembers the special fields: EIN1, EIN2, SSN1,SSN2,SSN3,PIN,Password. It luckily still has these fields saved! However, it appears 1Password 7 assumes that EIN2 and password are the default username/password for this webpage and only fills in those two pieces of information. Everything worked in 1Password 6. Is there anyway to edit the behavior back to the special webforms for 7?

Thanks,
Josh Hogan


1Password Version: 7.0.1
Extension Version: 4.7.1
OS Version: Mac OS X 10.13.4
Sync Type: 1Password

Comments

  • @drhogie I realize it isn't the most elegant solution, but have you tried jotting down all your login info, deleting that entry from 1Password, and then log in manually and save a fresh entry for that site? If it's the only one that is causing troubles for you it might be the quickest solution.

  • @driverdon I tried that and it worked! Thank you so much man! For 1Password Support, I have multiple saved logins for that site, so if I need to save anything for error checking I can.

  • @drhogie I'm glad that worked out for you!! :)

  • MrRooniMrRooni

    Team Member
    edited June 2018

    Crud, @drhogie, you're right! We haven't changed anything here and I successfully logged into EFTPS myself last month to set up my quarterly disbursements. My hunch is that the login form changed subtly as saving a new Login also resulted in me being able to fill again.

This discussion has been closed.