Log me in using current browser or tab, not default browser?

I hate to be a complainer but is AgileBits ever going to fix this bug in which when I try to fill in a login form for a website using the 1Password mini extension, 1P will go to a new tab in my default browser, go to the website, and log me in in that default browser instead of logging me in using the browser I currently have in focus? 1P should always log a user in using the browser that is in focus, not their default browser. This has been a really annoying bug in 1Password for a couple of years now and it's high time it was fixed. I use multiple MacOS browsers (default = Safari but I also frequently use Chrome and Firefox) and when I want to log into a website, 1P should log me in using the browser that currently is in focus, not my default browser. And if I'm already viewing a login form in a tab, it should log me in in that tab, in that browser, not go to my default browser, open a new tab, go to the website, and then log me in there. I shouldn't have to open the 1P Mac app and copy and paste the fields in just so that I can log in to the website in the browser tab I'm currently viewing. Yeesh.


1Password Version: 1Password 6 Version 6.8.9 (689001) AgileBits Store
Extension Version: Chrome 4.7.1.90
OS Version: 10.12.6
Sync Type: Your cloud

Comments

  • Corey_CCorey_C

    Team Member

    Hi there @rif

    Well that is certainly strange. I just went and tried it myself right now. Using both 1Password mini up in the menu bar or the 1Password extension, selecting an entry in the 1Password logins section opens up that site in a new tab in whatever browser I am currently using.

    You say in your information that you are syncing through our service, which would imply that you have a 1Password membership. If that is indeed the case, you should try upgrading to 1Password 7 and seeing if that fixes your particular issue as 1Password 7 changed the way that URL calls are made.

  • Again this morning I'm trying to open my email and my bank accounts in Chrome while I'm in Chrome and 1Password always switches back to Safari and logs me in there. I can't stress how frustrating this is. And it's even more frustrating when your team doesn't even acknowledge it could be a problem or how we could troubleshoot it together. That's not the response I expect as a subscriber and long-time customer. As for switching to 1Password 7, I'm not going near it until it's at least at a point one or point two release. I've seen all of the other frustrated customers in these forums who are having problems with it and I don't need the additional hassle.

  • dancodanco Senior Member Community Moderator

    A quick question in case it is relevant.

    When you have the browser in focus, does it actually have an open window?

    I have never had any problems (even with no open window) and neither has Corey_C, which does indicate something strange on your machine.

    Does the problem arise with other logins? Your first post suggests that it does, but your specific mention of email and bank accounts makes me wonder if they have some special features that cause it.

  • Hello @rlf,

    Are you by any chance clicking on the website field from the item details when initiating open-and-fill from inside 1Password mini? This particular way of using open-and-fill is shared with the main 1Password window and so in the past it has always used the path of passing the URL to the operating system and leaving it to the operating system on how to handle it. So this route will always use the default browser.

    In 1Password 6 you could always initiate open-and-fill by searching and selecting the Login item from the main menu (in contrast to entering the item details). This approach does require that the currently open page does not match the domain of the item though but will use the active browser. In 1Password 7 there is a blue open-and-fill button in the upper right hand corner and this will do the same, use the active browser.

    So there are two ways to invoke open-and-fill, one will always use the default browser while the other will use the active browser. Does this explain what you're seeing and allow you to use open-and-fill in the active browser?

  • I think that one frustration I had was that, aside from having this problem in the first place, there wasn't much of an attempt to help me troubleshoot it. Telling me to upgrade my app without indicating that the problem I was experiencing had definitively been resolved by a new version of the software is always the easy way out and takes no effort. One of the keys to providing good technical support is admitting that there may actually be a problem. And one of the worst ways to provide technical support is to say, "Well, I tried replicating your problem and it works for me. Maybe upgrade your software." Having worked in technical support, I can tell you that's not good technical support. Customer empathy goes a long way. He should have started out by asking me, did I have the 1P extension installed in the browser that wasn't being populated? Does this problem happen with all websites that I try to log into or just some of them? And if so, what's different between the settings for one that works as opposed to one that doesn't work? Then he might have delved into what those settings mean. If configured improperly, could any of those settings cause this problem to occur? If this ticket had gone in the direction I just described, then even if we couldn't resolve the problem, I would have known that at least we had tried. In the end, I figured out what the problem was by myself.

  • Hi @rlf,

    Personally my first suggestion wouldn't have been to update but I also appreciate that AgileBits allows us each the freedom to approach each task as we see fit rather than insist on following a pre-defined script. That can sometimes mean we may get things wrong or that a particular personality doesn't mesh well with a specific individual. We probably would have been having a different conversation if I'd found your query first but this is where we are. As you have figured out the problem can I ask what it was?

  • Fixing the problem entailed setting display: always and Submit: Always submit. Not knowing how this application works internally, I can't tell you why they worked but thankfully they did.

    I disagree with you with regard to following a pre-defined script (as would NASA, by the way). Having a predefined script for various problems makes eminent sense. Every problem has a root cause. Things don't just happen. Something makes them happen. If you understand how something works, then a well-thought out script that walks you through the various things that could be wrong and then eliminating the things that aren't causing the problem is a much better way to resolve the problem then just telling a person to upgrade. The latter approach is just lazy. But then, that's just my opinion.

  • I once reported to my ISP at the time that by broadband speed had significantly dropped. They responded by asking if I was sure my username and password were correct. They would do this each time I called because they were following a script. Personally I believe a script adaptable enough to be of use would likely be complex enough that creating and updating it would be a pain let alone trying to use it.

    The two options you found work as follows.

    • display The option controls whether the item should appear in 1Password mini when using 1Password from inside a browser and the default value is Always .
    • submit Allows a per Login item behaviour that overrides the global setting in the Browsers tab of 1Password's preferences. The default value is Submit when enabled. The Always submit option allows you to set a global default of do not submit after filling while explicitly flagging certain Login items to ignore this.

    As I said earlier, I wouldn't have mentioned updating. That said I've seen queries relating to 1Password 5 and yes my first move was to say update. Much has changed and 1Password 6 supports both the same versions of macOS as 1Password 5 as well as using the exact same licence meaning there is no good argument for running it. I don't however say the same thing to 1Password 4 users because more often than not they're running still Mavericks.

  • Thanks for the information. I appreciate the follow-up.

  • Do let us know if you run into any other trouble with 1Password.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file