1Password cannot fill an item because browser code signature or identity could not be verified

This problem began for me this morning.

Error message: "Google Chrome is connected but its code signature could not be verified. Filling and other features are disabled until this configuration issue is resolved. This usually happens if Google Chrome is in t he middle of an update. Please try to restart Google Chrome to fix this issue."

This is also a problem for my Opera installation.

I'm using Chrome Version 66.0.3359.181 (Official Build) (64-bit) and Opera 53.0.2907.68.

Multiple relaunches of both apps have failed to correct the problem.

Can anyone advise how to fix this problem for these two browsers? Searching this error has turned up threads from a couple of years ago, but none of that info has helped me fix the issue.

Thanks.


1Password Version: 1Password 5 Version 5.4.1 (541003)
Extension Version: 4.7.1.90
OS Version: OS X 10.10.5
Sync Type: No idea
Referrer: forum-search:1Password cannot fill an item in your browser because its code signature

Comments

  • Hello @WillH,

    If you're genuinely running 1Password 5 then that's your problem right there. The good news is 1Password 6.8.9 can verify the current code signatures of both Chrome and Opera and 6 is a free update to anybody with a valid 1Password 4 or 5 licence.

    Here is what I recommend.

    1. From the main 1Password window quit 1Password using the keyboard shortcut ⌃⌘Q.
    2. Drag the 1Password 5 application bundle from /Applications/ to your Trash.
    3. Download and install 1Password 6.8.9
    4. Launch 1Password 6.
    5. Restart any open browsers.

    You should find filling resumes in both browsers after this. I've directed you to download 1Password from our site as I'm assuming you would have updated 1Password before now if you had purchased from Apple's Mac App Store.

  • WillHWillH
    edited May 2018

    Thanks for your help, but I'm slightly confused.

    You stated "If you're genuinely running 1Password 5 then that's your problem right there."

    I've supplied the information presented by 1Password. Or is the information found when clicking on 1Password5 > About 1Password unreliable? How do I verify the version I have?

    Also, what if upon upgrading it says for whatever reason the upgrade isn't free? I had this happen once before and it caused no end of havoc. And in the end, I had to pay the additional fee to get everything running again. Needless to say, I'm not really up for repeating that experience.

    Everything has been working fine until this morning and I've not upgraded any of the versions of my browsers (I don't let things auto update), so just rather bemused as to why this has happened.

    Thanks,

    Will

  • Hi @WillH,

    We sometimes see confusion and reports about 1Password 5 are rare. We're more likely to see 1Password 3 or 4 than 5 because people might be running 3 as 4 was a paid update or they're running 4 because they're still running with OS X 10.9 AKA Mavericks. Version 5 is rare because 4-6 all use the same licence and any version of macOS capable of running 1Password 5 can run 1Password 6 as well.

    If you purchased 1Password at some point since 2013 you have a valid licence to run 1Password 6 as all three versions, 4-6 use the same licence. While the Mac App Store doesn't have licences in the strictest sense, a purchase also covers all three.

    You are currently running the latest version of both Opera and Chrome and to the best of my knowledge you can't actually stop them autoupdating. The same applies to Firefox. As 1Password is connected to not just the operating system but also the browsers updates to one can impact the other. The Opera 53 update for example saw a change to their signing certificate which stopped 1Password 6.8.8 from being able to verify Opera. That required all our 1Password/Opera users to update to 1Password 6.8.9.

    Now 1Password 7 is the current version of 1Password but it is a paid update and that's why I've linked you to 1Password 6 which you are entitled to run.

    Does that help at all?

  • How very strange.

    I think I'll back everything up and then see what my options are. I haven't bought a licence since I purchased 3 in 2013, so any upgrade I'm sure will be chargeable. I also notice 1Password uses a "rental" based model now for their software, which I don't go for, so perhaps a different tool for future password storage is in order.

    Thank you for your help. I'll review things and then come to a decision.

    Regards,

    Will

  • Thanks for your time, but I've resolved this.

  • Hello @WillH,

    If you purchased a licence in 2013 then you have a licence for 1Password 6.

    While we do have a subscription service, which we refer to as 1Password accounts it is important to note:

    1. Their existence doesn't invalidate any existing licence you have.
    2. We haven't done away with licences.

    1Password 7, which is a paid update, allows either for a 1Password account or purchasing a licence.

  • Thanks again for your help.

    When I navigated to the Pricing page of the website (https://1password.com/sign-up/) the subscription option was the only one listed. There's no mention on the page of being able to buy a licence to use the software.

    I think this will put more than just me off and thus lose AgileBits some customers. Perhaps someone should rethink that page.

    I've now moved everything to a new app, so not a worry for me, but I have to wonder how many people visited that page and thought the same and just kept going.

    Sorry, 1Password. Had your page been clearer I would probably have stayed with you, but as I've changed to a new app now, I have no reason to move back again.

    But again, thanks for your help. It's appreciated.

    Will

  • I'll close this now so that others can't reply and have you unnecessarily pinged over a conversation you likely feel is concluded. The closure of this particular conversation of course does not mean we don't want to hear from you should you wish to discuss 1Password at any point in the future.

This discussion has been closed.