Slow performance in 1Password 7.2 [7.2.580 update will be out soon, more improvements coming in 7.3]

2456

Comments

  • brentybrenty

    Team Member

    @komocode: Thanks for letting me know. I'm sorry for the trouble in the mean time, but the good news it that we're not nearly done optimizing it.

  • @brenty Will do, thanks!

  • brentybrenty

    Team Member

    @oryschakj: I think there's still more we need to do, but if the beta helps in your case please let us know.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    Just to be clear, while there are internal core optimizations we're doing in the first few 1Password 7.2 betas, they're not at that stage where 1Password mini benefits from them just yet. It's a much larger and longer fix.

    The performance issue with 1Password mini you're seeing after unlocking 1Password is a threading issue; there simply isn't enough resource available within 1Password to render 1Password mini while also decrypting, loading data, syncing data, etc. We're currently putting too much strain on 1Password after adding local vaults in 1Password 7 and Watchtower 2. The work we're doing in 1Password 7.2 starts the path to overhaul some of the internals to give us more head room but it's going to take some time.

  • @brenty I am inconsistently experiencing the same issue. After opting into the beta and installing it, I fired up the command to initialize the 1P browser popup. That took about 5-6 seconds to appear. Once I submitted the master password, nothing happened next for another 10-15 seconds. Finally the 1P popup appeared. Selected the creds I wanted to use and it took almost 20 seconds to fill the fields. Waited for 1P to submit those creds...nothing. Still sitting on the login screen and no submission by 1P, and the setting is checked to submit after filling username/password.

    Went to another site (1P already unlocked), fired up the command to fill in the creds, and everything worked as it should. Filled the creds and submitted, all without any lag.

    Locked Windows (locks 1P), logged back in, went to that last site again, fired up the command to initialize the 1P browser popup, filled in the master password, waited 5-6 seconds before 1P filled the fields with creds, waited 2-3 seconds before 1P submitted them.

    Went to another site, fired the command, filled without lag, no submission.

    Overall...inconsistencies with performance and submissions, and the performance issues occurring mostly when 1P has been unlocked with the master password.

  • @MikeT Thanks for the explanation.

  • GregGreg

    Team Member

    Hi @realtvater,

    On behalf of Mike you are very welcome!

    If you are using 1Password account in 1Password 7, not standalone vault, please create a Diagnostics Report from your PC, so we could take a closer look at what is going on. Attach the report to an email message addressed to [email protected] and post your Support ID number (not a report itself) here, when you receive an automated reply from our BitBot assistant.

    Cheers,
    Greg

  • AgileDaveAgileDave
    edited August 2018

    I have the same problem,Win10 ENT, Firefox 61, 1password extension, reacts very slowly like described above. Mini app much faster. I use dropbox sync. I'll enable Beta to see if that improves.

    (Edit) I was on the Beta channel already but didn't have the beta Extension for Firefox. Now running 1Password 7.2.576 and Extension 4.7.3.1, it seems a lot smoother on first testing.

  • brentybrenty

    Team Member

    @AgileDave: We've made some improvements in this area already, but a lot of the work we're doing will be held back until 7.3 so we can get 7.2 and all of its good stuff out to everyone and take the time to test and refine things further in the next beta. Thank you for your feedback and participation!

  • I have these performance issues as well. Or let's say I do have them now while they did not exist yet in the first couple of versions of 1P 7 for Windows 10. It works like this:

    1) opening a website in a recent Firefox (fast performance)
    2) hitting the shortcut (Alt-Gr + #) or clicking on the 1p Icon opens the browser addon (fast performance)
    3) choosing the right 1password record with the mouse or cursors (slow performance ~10-15 seconds). Nothing happens visually in that time until somewhen the login and password is filled into the input fields. If you switch tabs during that time the procedure dies.


    1Password Windows: 7.2.576 (local vault)
    Addon Firefox 61.0.1: 4.7.2.90
    Windows: 10 Pro (1803)

    PS: I do have the feeling that this happens especially after you just unlocked the container and happens less often when you are already authenticated for a while.

  • MikeTMikeT Agile Samurai

    Team Member
    edited August 2018

    Hi @mort,

    PS: I do have the feeling that this happens especially after you just unlocked the container and happens less often when you are already authenticated for a while.

    Your feelings are correct, this is the start of the problem; we've managed to add so much features at the same time that we're running into new threading issues (doing too much of everything) and we're working on rebuilding our thread scheduler in 1Password 7.3. The more CPU is being used, the worse the performance in 1Password.

    When you unlock 1Password, it starts a bunch of heavy-resource tasks; sync, Watchtower update, etc. It finishes them all before it can get data you need and the problem is, that is not our intention.

    The correct behavior is that you should be able to use the app and get your data while all of the background tasks are being done in in the background without affecting the data or the app. Unfortunately, some of the tasks ended up taking over and pausing other tasks, so we have to re-jigger all of our tasks to make sure they behave correctly concurrently and without affecting your workflow.

  • Ok, I've been running the beta for a couple weeks and it hasn't really improved anything. Even after the computer has been on and 1Password has been running for a while, I still get instances where autofilling a username/password takes 30s+ and hangs 1Password in the meantime.

    Sounds like you're already tracking on this stuff, though.

  • GregGreg

    Team Member

    Hi @oryschakj,

    We started fixing it in 7.2, but it is much larger and longer fix. I am sorry for this inconvenience.

    If you downgrade to 7.1, does it work better? Please let me know. Thanks!

    Cheers,
    Greg

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    Just an update, the 1Password 7.2 stable update will not have this fix, it's still ongoing and will be in 1Password 7.3 update instead.

  • beirnebeirne Junior Member

    Please hurry on 7.3. I got upgraded to 7.2.56 this morning and 1Password on Windows 10 is now unusable due to long wait times to do anything in the main program, and by extension the browser. I have to go to my Mac to look up passwords and then type them in on Windows.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @beirne,

    It is not supposed to worsen at all. There is a one-time database migration that happens after the update but after that, it should get back to the same time you saw before.

    Please use this guide to generate the 1Password diagnostic report and email it to us at [email protected]. Also, in the email, include the link to this thread along with your forum username, so that we can connect the email to this thread.

    Let us know here when you've sent it, so we can confirm we got the email.

  • beirnebeirne Junior Member

    Hi @MikeT ,

    I went and did other things and after reading your message I went back to check. 1Password is working now, so I must have been seeing the migration you mentioned. I'll hold off on diagnostics unless I see problems again.

    Thanks,
    Beirne

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @beirne,

    Thanks for the follow-up, hopefully that was it.

    We'll need to find a way to notify people when there is an internal database migration going on after an update is installed.

  • beirnebeirne Junior Member

    Hi @MikeT , the problem came back today, I just emailed the diagnostics.

    Thanks,
    Beirne

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @beirne,

    Thanks, we got the email. At first glance, your sync is taking over five minutes to finish due to an issue with one of the vault files. I'll reply to your email as soon as we finish analyzing the report.

  • Hi all. Just wanted to jump in. I've had this issue for a couple of weeks as well, and it got to the point where I decided to see if others were having it too.

    I see you are, indeed, having the same issue.

    I'm running:

    Windows 10
    Chrome
    Syncing with Dropbox

    Exact same issue on all 3 computers I use on a daily basis. Happens the first time I try to use it after not having used it for a while. Takes almost a minute sometimes. Which means it probably takes 15 or 20 seconds and it feels like a minute. I'd send diagnostics, but it sounds like at this point there's no need. But I'm happy to do whatever an Agilebits developer asks me to.

  • Yep, same here. After starting or unlocking the app on Windows 10 it is unusable for 30 seconds. I can click on whatever password record in the middle column but don't see anything changing in the right part. After about a 30 seconds 1password comes to life and can be used. But not using the browser extensions at the moment, they are too slow. Copy-paste is faster.

    Using one local vault and ca 20 team vaults.

  • MikeTMikeT Agile Samurai

    Team Member

    Thanks for your comments, guys.

    It is correct that we do not need the diagnostics reports at this point, we're working on addressing the performance/threading issues as we speak.

    @AJH2,

    But not using the browser extensions at the moment, they are too slow. Copy-paste is faster.

    Once 1Password comes to life in 30 or so seconds, the extension should be back to normal. The background sync that starts after every unlock is what causes the delays in all parts of 1Password. Once the sync is done, the app will be normal.

  • I have found that in Windows 10, reverting back to 1pass version 7.0.558 and not updating to v 7.2.576 ended the lag problems.

  • brentybrenty

    Team Member

    Not something we'd really recommend since it means giving up Watchtower and a bunch of other improvements we've made since then.

  • Similar behavior has presented itself over the last week for me.

    • Browser extension slow to respond
    • Desktop app seems to freeze when making changes (offline changes appears)
    • Standalone vault is syncing changes between devices, but not backing up when changes are made.

    I switched to the beta version last night with no improvement.

    Tech support ticket: #RQV-35882-644

  • I am also having the same issues in terms of 1Password Mini taking a long time to fill in forms. I sent in an email to the address listed a few posts above with a diagnostic log, so hopefully, it helps (My Ticket ID is #ALS-66294-994)

  • GregGreg

    Team Member

    Hi @Buzz69 and @AdamMiros,

    Sorry for the inconvenience!

    I have found your Diagnostics Reports on our side and we will get back to you via email asap.

    Cheers,
    Greg

    ref: RQV-35882-644

    ref: ALS-66294-994

  • Thanks, @Greg !

  • bundtkatebundtkate

    Team Member

    On behalf of Greg, you're most welcome, @Buzz69. I see he's been in touch already, so I'll leave you in his capable hands. :chuffed:

This discussion has been closed.