Slow performance in 1Password 7.2 [7.2.580 update will be out soon, more improvements coming in 7.3]

1235

Comments

  • brentybrenty

    Team Member

    @mzaurov: What exactly are you having trouble with? It would be helpful to know the specific symptoms you're seeing, and the context. Are you using a 1Password membership subscription account, local vaults, or both?

  • @brenty I’ve emailed several videos you can look at, one just earlier. I wanted to comment publicly since prior to finding this thread I thought i was the only one experiencing this.

    My issue is opening the app takes forever from both task bar and mini window in Chrome. It also takes long to fill in user/password after clicking on an entry, sometimes not working at all. I’m using a family account.

  • brentybrenty

    Team Member

    @mzaurov: Ah, thanks for clarifying. I didn't realize you'd been in contact with someone else. I do thank you for chiming in, but it's best to continue the conversation in a single place with the person who has all of the context, in order to avoid duplication of effort, since that slows down response times for everyone -- including you. I'm sorry to hear that you're having trouble, but you're in good hands. We'll do what we can to help with your particular case. :)

  • Unfortunately I am still having this slow performance issue but it is not as bad as it use to be! It only happens sometimes too. So that is the good news!

    I may even go back to Windows 7 or Windows 8.1 to see if it still does it just for the heck of it. If I have time.

    That or redo my 1Password login and info if I can print it all first. xD

  • Newest update to 7.3 has been really fast on my system. Thanks for all the hard work!

  • @mzaurov I will let you know if either of these things help or not.

    I don't expect you to do them though. I shouldn't even have to but I kinda feel like it if it can help. Only if I get time though. Thanks.

  • @mzaurov same here but it comes and goes. It is really weird.

    I did do a restart which helped but otherwise it is mostly fixed but not totally. Which is ok. I just wonder if other versions of windows or if smaller login lists help any.

  • ttim03ttim03
    edited January 12

    Weird it is working really fast now 1Password extension. Though that is a good weird thing! We want it to work fast!

  • brentybrenty

    Team Member
    edited January 12

    @ttim03: Hey, that's my kind of weird! :chuffed: :+1:

    We had a lot of big changes in this area in 7.3, and have released a quick minor update to help with some specific issues some people were experiencing. Hopefully that did the trick, but if you encounter any of the other kind of weirdness, just let us know. :)

  • brentybrenty

    Team Member

    @mzaurov: Thanks for the update, and the kind words! It took longer than we wanted (doesn't it always? :lol: ), but it seems like it's been worth it, helping a lot of people. Cheers! :chuffed:

  • ttim03ttim03
    edited January 12

    @brenty sad it seems to slow down once it is locked and I reclick on the 1password browser extension. Takes 10 to 20 seconds to respond.

    Never mind scratch that it is definitely slow once it locks itself.

  • @brenty how to a create a whole new 1password profile without deleting my current one? Is that possible?

    Also how do I print out all my login and information ?

  • ttim03ttim03
    edited January 12

    I think I may have found the culprit or problem. Windows 10 Build 1809 but not 100% sure.

    Hmm maybe not. :(

    This is frustrating.

    I hope I can find it. If not I hope it at least fixes itself.

  • All fixed for now! Not sure what the issue was or how I was able to fix it. I just did a clean install of Windows 10 Pro build 1803 then updated to build 1809. Then fresh install of 1Password 7.3!

    Seems to be fixed

  • brentybrenty

    Team Member

    Wow. That sounds like a lot of work, but I'm glad it helped. I'm still actually on 1803 here myself since I haven't yet been offered 1809 on my PC (and will wait patiently for that this time around), so maybe something went a bit wrong with the update for you. I'm glad to hear that you're all up to date now and things are working well for you. :)

  • It's faster but still has some delay. I'll try reinstalling.

  • ttim03ttim03
    edited January 14

    @brenty it was but worth it!

    Ok I think I might of figure out what is slowing it down or what causes it to start maybe.

    Follow my steps exactly.

    Open 1password extension in the browser of your chose and choose any login.

    Right click and click edit in 1Password.

    After you do that close the windows it popups up.

    Now try to click on the 1Password extension again in your browser and tell me if it is slow now please?

    P.S. took me 5 minutes to post this because of how slow it was :(

    Must go back a previous image with Macrium Reflect to fix it.

  • GregGreg

    Team Member

    Hi @komocode,

    Please let us know how it works for you. Hopefully, everything will be okay. Thanks!

    Cheers,
    Greg

  • ttim03ttim03
    edited January 19

    @komocode any update?

  • @ttim03
    it has always worked fast after the first time using the extension until you reboot the computer. the problem i had was unlocking the vault and then being able to use a login would take ages

    i've reinstalled 1password. it still takes about 5-10 seconds to load the vault for the first time upon reboot so it's not quite as quick as macOS' version, but this far more usable than waiting 30 seconds.

  • @komocode same here.

  • brentybrenty

    Team Member

    @ttim03, @komocode: Thanks for letting us know. We'll continue to work to make things more efficient where we can. It sounds like 7.3 helped, but perhaps not as much as we all hoped.

    Can you both tell me more about your setups?

    • OS version
    • CPU/RAM
    • HDD or SSD
    • Local vaults, 1Password accounts, or both

    Thanks!

  • @brenty Windows 10 Pro 17134.523 64bit
    i7-6770HQ
    32gb ram
    samsung 960 evo
    dropbox local vault

  • @brenty Windows 10 Pro 1809 64 bit
    i7 7700k
    32 GB of ram
    Samsung 950 pro
    1Password account online

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    @ttim03, here's a video of me trying to reproduce it, can you confirm it is what you're doing? I'm not able to reproduce it though.

    Note that the initial unlock will always be slowest; we still do a lot of network calls like Watchtower updates, HaveIbeenPwned updates, Rich Icons as needed. Unlock becomes faster later because we don't need to repeat that.

    @komocode; can you try to disable all Watchtower features as well as Rich Icons in 1Password Settings and see if the initial unlock is still the same speed?

  • @MikeT i have watchtower off for a while now (i notice it shows it still updates upon logging in even when switched off).

    have turned off rich icons, rebooted, and still has about a 5-10 second initial delay before extension is in a usable state

  • @MikeT next time, I know I didn't say sorry, click on save after going to edit one of your logins.

  • @komocode can you please list or say which other applications you have installed? Thanks.

  • komocodekomocode
    edited January 22

    @ttim03 i have lots of apps installed. not sure if that would be productive listing everything out.

    i do have avast antivirus and dropbox running.

  • @komocode ok np.

    I have Emsisoft Anti-Malware malware scanner running

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file