Touch ID not working for 1Password after MacOS reinstall

MacBook Pro (15", 2016)
1Password7 installed and working fine with TouchID.
Disk / permissions snafu :(
Reinstalled OS, set up TouchID.
Restored docs, apps from Time Machine.
1Password not showing TouchID to unlock

...various resets, reinstalls, to no effect...

I see the 1password log has lots of entries:

[LOCKSERVICE:(Main Thread):] E secretForKeychainUnlockForProfile: | Failed to decrypt data with secure enclave: Error Domain=NSOSStatusErrorDomain Code=-50 "ECIES: Failed to aes-gcm decrypt data" (paramErr: error in user parameter list) UserInfo={NSDescription=ECIES: Failed to aes-gcm decrypt data}

As opening 1Password with TouchID is the only use I have for the Touch Bar, I'd like to get it back...

PS: Just thought to check - 1Password & TouchID work fine in a quick test on a newly created user.


1Password Version: 7.0.4
Extension Version: Not Provided
OS Version: 10.13.5
Sync Type: dropbox
Referrer: forum-search:touch id

«13

Comments

  • Same problem here, thanks for your help !

  • I'm seeing these log messages as well - TouchID isn't working at all on 10.13.5 with 7.0.4

  • brentybrenty

    Team Member

    @louisxiv: Thanks for sharing this with us. We're tracking an issue which causes Touch ID to stop working in some environments, and others have reported that reinstalling macOS helps. It's weird that it didn't in your case, but creating a new user account did. Did you maybe migrate something to the first user account you setup?

    To be clear, we don't think people should have to do either of those things, so we're investigating this ourselves and have also reached out to Apple for guidance. Thanks for your patience.

    ref: apple-1594

  • The OS install was an install with restore from time machine so yes indeed quite a lot of something was migrated, though not a previously working touchID link for 1Password.

    I’ve disabled touchID, removed 1P, allowed Hazel’s cleanup routine to clear related files, restarted, emptied trash, then manually cleared AgileBits entries in the ~/library, Application Support and Containers, restarted etc, then reinstalled 1P - but all to no avail. Still no touchID for 1Password.

  • brentybrenty

    Team Member

    Thanks for confirming. To be clear, I'm not even sure what could be carried over that could cause that, since 1Password 7 uses the Secure Enclave to store the secret. We'll keep digging.

  • +1 for this same exact issue... no issues using TouchID in version 6, but since upgrading to version 7, TouchID isnot working.

    Fri Jun 15 09:28:31 2018| 70004001 [LOCKSERVICE:(Main Thread):] E secretForKeychainUnlockForProfile: | Failed to decrypt data with secure enclave: Error Domain=NSOSStatusErrorDomain Code=-50 "ECIES: Failed to aes-gcm decrypt data" (paramErr: error in user parameter list) UserInfo={NSDescription=ECIES: Failed to aes-gcm decrypt data}

  • brentybrenty

    Team Member

    @kestryl: Thanks for getting in touch, and the detail. The bad news is that we don't know why this is happening to some people; the good news is that you're experiencing the same issue that we're investigating, so any workaround we find ourselves or that Apple suggests will help you and the others. Thanks for your patience.

  • +1 Please let me know if there is any additional information (e.g., log files) I can share to help debug this problem.

  • brentybrenty

    Team Member

    @gerrymiller: Thank you for the offer. It's definitely something we'll keep in mind, but so far the information we really need is not something that macOS exposes to us. It's something we're continuing to look into though.

  • I'm currently unable to get 1Password to unlock via touch ID on my MacBook Pro. I have performed the following steps to attempt to get Touch ID working:

    • Restarting my MacBook Pro
    • Removing/Re-adding my finger print
    • Enabling/Disabling touch ID for my MacBook and 1Password

    When prompted to enter my master password, my touch bar shows 2 buttons, one grayed out fingerprint and a blue box that says unlock, there is nothing asking me to use touch ID to unlock. Any help would be greatly appreciated.


    1Password Version: 7.0.4
    Extension Version: 4.7.1.90
    OS Version: macOS High Sierra 10.13.1
    Sync Type: Not Provided

  • I had to wipe my very new and expensive MacBook Pro due to display (screen) trouble. Apple installed a new display (twice!) They erased everything and told me not to use a backup in case a software issue was involved. What a royal pain! In reinstalling my 1Password 6 I had problems because my license 6 version wasn't anywhere to be found. Support finally sent me the correct link. Works fine but I cannot open the preferences security option in order to enable touch ID. It was working fine before the hard drive was erased. I'm happy to have 1Password 6 working since it is essential in my daily computer use. Why can't I get the one touch operational? I'm grayed out and don't have any other "unlocking" password other than my master one. Anyone have an idea?

  • MrRooniMrRooni

    Team Member

    @hcm_cmnich Could you try installing the latest 1Password 7 beta (currently 7.0.5.BETA-2) and see if that fixes things for you? You can find the installer here under the Feeling adventurous? section: https://1password.com/downloads/

    @BonnieGal It's hard to say what might be going on without digging deeper. I'd like to ask you to create a diagnostics report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: url
    • Your forum username: username

    That way we can "connect the dots" when we see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so we can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Once we see the diagnostics we'll be able to better assist you. Thanks very much!

  • @MrRooni I have tried installing the 1Password 7 beta and I'm still seeing the same behavior. I have attached a screenshot of what I am seeing rather than the touch ID prompt on my touch bar

  • rudyrudy

    Team Member
    edited June 2018

    @hcm_cmnich,

    I'd like to ask you to create a Diagnostics Report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the Diagnostics Report(s) to an email message addressed to [email protected].

    Please do not post your Diagnostics Report(s) in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report(s) in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report(s) and ensure that this issue is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

  • Thank you @rudy

    I have sent over the diagnostic report, the support ID is [#LAM-45827-848]

  • rudyrudy

    Team Member

    @hcm_cmnich,

    We'll continue the conversation on that email thread.

    Rudy

  • EdelheidEdelheid
    edited June 2018

    I just had this same exact problem earlier today after re-installing 10.13.5 and putting everything back using Migration Assistant. I’ve done pretty much all the obvious troubleshooting tips like re-installing 1Password (MAS and Direct), re-enabling Touch ID within both 1Password and System Preferences, turning FileVault off and back on, then restarting my Mac in-between some of the aforementioned tasks, and what finally fixed it is installing 7.0.5 BETA-3 released today. It’s not mentioned anywhere in the release notes, but by some miracle Touch ID is working again.

    I hope it stays this way, it was a nightmare going back to typing my Master Password. :'(

  • louisxivlouisxiv
    edited June 2018

    Confirm 7.0.5 beta 3, though I had TouchID enabled in 1Password preferences already and needed to disable, enable again for b3 to start using it.

  • rudyrudy

    Team Member

    @edelheid,

    Just don't upgrade to the macOS Mojave 10.14 developer beta 2 or newer. There is an issue with at least one of the system processes that's involved in letting Touch ID work in 1Password.

  • ricctoriccto Junior Member


    for what it's worth, with Mojave public beta 1 and 1password 7.06 TouchID still doesn't work (in fact the touchid icon doesn't even appear next to the password prompt)

  • padrepipespadrepipes Junior Member

    I am having a similar problem with version 6.8.9. Since installing Mojave Beta Touch ID does not work. It is not checked off in preferences and when I try to it repeatedly asks me for the master password.

  • rudyrudy

    Team Member

    @padrepipes,

    Looks to be the exact same problem to me. We'll see what Mojave beta 3 brings with it.

  • Any updates? This is painful...

  • rudyrudy

    Team Member

    @gerrymiller,

    We will see what Mojave Beta 3 brings with it. We've already filed a radar with Apple regarding the secd process' inability to read our entitlements.

  • Thank you, @rudy. Does that imply I'll need to either run a beta OS or wait until it's released in October to get this feature back to working? It seems strange that it used to work, and suddenly stopped.

  • rudyrudy

    Team Member

    @gerrymiller,

    The latest posts have all been about Touch ID on Mojave, which is known to not function as of beta 2. If That's not the configuration you find yourself in then we'd need to get a Diagnostics Report to see why its not working for you currently.

    Sending Diagnostics Reports (Mac)

    Attach the Diagnostics Report(s) to an email message addressed to [email protected].

    Please do not post your Diagnostics Report(s) in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report(s) in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report(s) and ensure that this issue is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

  • Thank you, @rudy, the original message in this thread wasn't about Mojave, but it seems to have morphed into that. Like the original poster, I am also running 10.13.5 (High Sierra).

    Support ticket ID is #NMT-16274-479.

    Thanks again,

    • Gerry
  • Hi - I am experiencing the exact same problem described above. I also created a diagnostics report and sent to the email above with a link to this thread and my username. Looking forward to hearing back from you. Thanks!

  • brentybrenty

    Team Member

    @yairerez: Thanks! I was able to find your email. We'll be in touch. :)

    ref: AWQ-92484-165

  • brentybrenty

    Team Member

    @gerrymiller: Thank you! I see that we've received yours as well, so we can continue the conversation there. We'll get back to you shortly! :)

    ref: NMT-16274-479

«13

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file