Problem with upgrade and uninstall, 1password.exe file is locked by system.

Hi guys,

I noticed that 1password was unable to update to latest version due to "1password.exe" being in use by SYSTEM.
I don't use malwarebytes, only windows defender, and for the heck of it i tried disabling WD too without.

Here's what the setup log says when attempting to upgrade/reinstall;
2018-06-13 21:49:27.782 Message box (Abort/Retry/Ignore):
C:\Users\%username%\AppData\Local\1password\app\7\1Password.exe

                      An error occurred while trying to replace the existing file:
                      DeleteFile failed; code 32.
                      The process cannot access the file because it is being used by another process.

                      Click Retry to try again, Ignore to skip this file (not recommended), or Abort to cancel installation.

2018-06-13 21:55:02.248 User chose Abort.
2018-06-13 21:55:02.249 User canceled the installation process.
2018-06-13 21:55:02.249 Rolling back changes.
2018-06-13 21:55:02.259 Starting the uninstallation process.
2018-06-13 21:55:02.261 Uninstallation process succeeded.
2018-06-13 21:55:03.777 Deinitializing Setup.
2018-06-13 21:55:03.823 Log closed.

In my attempts of fixing the problem I seemingly uninstalled it successfully - except from 1password.exe and a few other files being left over that I'm not allowed to delete.

Below is a two events from event log.
Any help is appreciated !


1Password Version: 7.0.558
Extension Version: Not Provided
OS Version: Windows 10 1803 (10.0.17134)
Sync Type: Not Provided

Comments

  • GregGreg

    Team Member

    Hi there @franzoir,

    Thank you for the detailed report! :+1:

    Is it possible that you still have 1Password 4 installed on your computer? If you have, please uninstall it first, reboot your PC, and try to install 1Password 7 from the ground up. If you have any other copies of 1Password installed, please uninstall them all before the installation.

    Let me know if it works. Thanks!

    Cheers,
    Greg

  • Hi @Greg

    I have no previous versions of 1pwd installed.

    I tried uninstalled 1password before posting the first time, but some files still remains:
    C:\Users\%username%\AppData\Local\1password\app\7\1password.exe
    C:\Users\%username%\AppData\Local\1password\data\1Password10.sqlite
    C:\Users\%username%\AppData\Local\1password\data\user.json
    C:\Users\%username%\AppData\Local\1password\logs...

    To me, it seems like my installation is corrupted. Making me i'm unable to remove excess files (locked by system). I ran a cleanup with ccleaner today and rebooted afterwards, but that didn't get me any further.

    I tried re-registering kernelbase.dll and running sfc /scannow to no avail.
    Well, it's about time for my quarterly reinstall of this computer so, I don't want to put that much more effort into troubleshooting. :smile: But i'll wait a few more days in case someone here comes up with suggested actions.

  • Hi,
    I have the exact same Issue. 1Password wasn't able to AutoUpdate. Process "System" locked %localappdata%\1password\app\7\1Password.exe
    I put some exclusions to Windows Defender without success.

    Version of 1Password.exe -> 7.0.558.0
    Windows 10 1803 (Build 17134.112)

    Cheers,
    Andi

  • GregGreg

    Team Member

    Hi @franzoir and @AndiKausG,

    Could you please check if you have any pending Windows updates on your side? If you do, please try to install them, reboot your PC, and check if the issue with update remains after that.

    Thanks! :+1:

    ++
    Greg

  • Hi @Greg,

    Thank you, I installed CU - kb4284835 (https://support.microsoft.com/en-gb/help/4284835/windows-10-update-kb4284835)
    Unfortunately the problem remains.

    /Jacob

  • Hi @Greg,

    Thank you, my System is Up2Date, last successfully installed Update KB4284835 (installed last week.)
    The Probelm starts three weeks ago.

    Andi

  • MikeTMikeT Agile Samurai

    Team Member
    edited June 2018

    Hi guys,

    Please try this:

    1. Download the latest copy of 1Password from here but do not run yet: https://1Password.com/downloads/
    2. Uninstall all instances of 1Password using the Control Panel's Uninstall a program option. Note: Do not allow any third party uninstaller to clean up 1Password. Your 1Password data will not be affected.
    3. Open Windows File Explorer and enter %LOCALAPPDATA%\1Password in the address bar. You should not see the app folder but if you do, move this to the desktop.
    4. Reboot your computer but do not open any browsers including Edge. Run the 1Password 7.1 installer you've downloaded from step 1 and see if it works now.
  • Hi MikeT

    the Problem, you can do nothing, when 1password.exe is locked by "system". I Try a few things using sysinternal tools (try to rename 1password.exe during boot, try to kill the handle), but they also not working.

    in Windows safe mode 1.password isn't locked by system and i can rename the folder :)

    • Unsinstall 1password,
    • boot Windows in Safe Mode (holding shift-key while pressing Restart )
    • rename the 1password.exe or the 1password folder.
    • Boot to Windows Normal state
    • Install 1password using latest copy

    1password works again.

  • brentybrenty

    Team Member

    @AndiKausG: That's frustrating, and shouldn't be necessary, but I'm glad that workaround helped you. We're you able to determine what was locking the file? We see that a lot with "security" software — for instance while doing a scan — or backup utilities.

  • @brenty, Ransomeware Protection or AntiVirus that was my first thought too. I added some exclusions to Windows Defender.
    The Windows Kernel it self locked 1password, In Taskmanager the Process called "System" -> %windir%\system32\ntoskrnl.exe (Pid 4)
    I'm using handle and ProcMon

    I didn't create a screenshot, :( but I have saved a Logfile created by handle.exe -> reduced to 1password entries:

        Handle v3.46
        Copyright (C) 1997-2011 Mark Russinovich
        Sysinternals - www.sysinternals.com
        ------------------------------------------------------------------------------
        System pid: 4 \<unable to open process>
           1C: File  (---)   C:\Windows\System32\config\SYSTEM
         2A74: File  (RW-)   %LOCALAPPDATA%\1password\app
         40D0: File  (R--)   %LOCALAPPDATA%\1password\app\7\1Password.exe
         4240: File  (RW-)   %LOCALAPPDATA%\1password
    

    Please let me know if you need more information

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @AndiKausG,

    Not much we can see in that log.

    However, if you did click on Abort during the setup, then you must uninstall and remove the app folder manually if the uninstaller didn't clean it up. Our current installer does not perform Abort cleanly, so we'll be removing it and looking for a new installer very soon. We have some plans for the new installer that we think that will help with this issue.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file