1 Password X won't open

northysnorthys
edited June 15 in 1Password X (beta)

Most of the time 1 Password won't open when using my configured shortcut or even clicking on the icon. When I click to login form it shows 1 Password with message "Press Ctrl + comma to unlock 1 Password" so the extension should work.

When 1p shows master password prompt, it works perfectly all day. I've set 240minutes idle lock time.

Is there a way to collect debug data for you?


1Password Version: -
Extension Version: 1.7.4 @ Firefox 60.0.2
OS Version: Ubuntu 18.04 bionic
Sync Type: my.1password.com

Comments

  • DaltonDDaltonD

    Team Member

    Thanks for letting us know that you're seeing this behavior, @northys. I see that you're using Ubuntu 18.04 and Firefox from the helpful details you included when posting. With this being the case, it's likely that you're experiencing a known bug with how password fields are handled in Firefox on Ubunut 18.04:

    Lock screen issue: 1Password X for Firefox on Ubuntu 18.04 🐛⚠️

    I recommend reviewing the workarounds listed in the link above and see if any of them work for you.

  • @DaltonD thanks! logging in via my.1password.com opens the extension, brilliant! btw third workaround is Wayland... I'm running on Wayland.

  • dtearedteare Agile Founder

    Team Member

    Thanks for the update, @northys. I'm glad to hear that work around is working for you.

    It's interesting to hear this is happening to you while on Wayland. Pinging @beyer as it looks like that isn't a magic bullet after all.

  • @dteare, @beyer: nah, checked it again and 18.04 LTS is running on X11 by default.

  • dtearedteare Agile Founder

    Team Member

    👍

  • Just installed Ubuntu 18.04.1 a few days ago, and it defaulted to Wayland on my AMDGPU graphics card, which I had to manually disable amdgpu.dc on (because I need DVI-D dual link support), and it just produced this issue. I also confirmed that logging into my.1password.com page unlocked the extension.

    Fake edit: Huh, it appears to be using X11 this time around. I guess that's the default.

    Extension version 1.9.0
    Firefox version 61.0.1
    OS Version: Ubuntu 18.04.1
    Sync type: my.1password.com

  • beyerbeyer

    Team Member

    @kode54: Thanks for the update. Unfortunately, it doesn't look like either the ibus or Ubuntu teams have completely resolved this issue. Until then, my list of workarounds is the best way forward.

    -Beyer

  • The *.1password.com login method worked. And now that I'm on an Nvidia card (GTX 960) and running the nvidia proprietary drivers, the unlock popup dialog works, too.

  • brentybrenty

    Team Member

    Glad to hear it! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file