repeatable: Chrome extension attempt to fill paypal login/password crashes 1p (be

repeatable complete 1p crash when attempting to fill login/password for paypal in chrome extension. (and safari, see below)

rebooted system, updated chrome etc. Reinstalled 1p chrome extension. Tried again, same result.
Crash report sent.

Tried the same thing in safari, produced a 1p hang, force quit 1p), then a crash report the 2nd time. Sent.

Tried one or two other logins, they seem to work ok.

1Password 7
Version 7.0.5.BETA-2 (70005002)
AgileBits Beta
Chrome Version 67.0.3396.99 (Official Build) (64-bit)
Non-Beta chrome extension


1Password Version: 7.0.5.BETA-2
Extension Version: 4.7.2.90
OS Version: OS/X 10.13.5
Sync Type: 1password account

Comments

  • dmkahndmkahn
    edited June 2018

    this is far worse than I thought. Searching for paypal crashes 1p when I type the 'y' in 'pay', scrolling through logins crashes 1p. Am I f-cked or what?

    the ios app seems to be ok to the extent I can open 1p and search for paypal and copy the password there and then paste it in the login form on my mac. I can scroll through all my logins in the ios version, so I guess my db is ok for the moment?

    I wonder if I should try to go back to the non-beta version?

    My guess is something is corrupt in the mac cached version of the db and it has nothing to do with paypal and we really don't want that to propagate anywhere.

    How do I recover?

    -David

  • Just checked 1p running in a windows 10 vm, the db there is ok also. All these accounts are logged into the same 1password account.

  • dmkahndmkahn
    edited June 2018

    So I tried the troubleshooting procedure to remove all data, and that resulted in my being logged in to my 1p account with no data records at all. My vaults were all there, they just appeared to be empty.

    So I followed the slightly modified version of killing off the app completely ....

    https://support.1password.com/uninstall-1password/

    ... removing the app and removing a container for the data, though the instructions I found seemed tailored to an older version of 1p, so I deleted the 1p7 version of the helper folder. I also had to manually kill off some 1p message helper app that didn't die when using the menu to kill 1p completely. (something missing there? Is that message helper thing new with this beta?)

    Reinstalled non-beta 1p7, it seemed to have me already logged in to my 1p account, but it also seems to be behaving ok for the moment. All my data seems to be here and I can find and fill the paypal login from the chrome extension.

    Sticking with 7.0.4 for now until we can figure out what happened.

    I'm just glad the corrupt data (or whatever it was) didn't get written back to cloud. How do we guard against that? Are there multiple versions of the data stored in the 1p cloud? Is there a way to manually backup my data locally?

    -David

  • .. not even an acknowledgement to a data integrity issue reported here.

  • ag_kevinag_kevin Junior Member

    Team Member

    Hi @dmkahn ,

    I'm sorry for the late reply. We’ve received a large influx of support requests lately and are working very hard to catch up.

    So it sounds like an entry in the database was not saved properly, an entry in the local db was corrupt. This would have caused a crash in beta releases. This data is not possible to be saved back to the cloud as there are integrity checks before it is allowed to push the contents to the server. The same check that caused the crash would also have been prevented the sync to the server.

    Regards,
    Kevin

This discussion has been closed.