1Password 7 Firefox 60 Extension (v4.7.2.90) not working on MacOS 10.13.4

MacOS: 10.13.4 (17E202)

1Password 7
Version 7.0.4 (70004001)
AgileBits Store

Firefox 60.0.2 (64-bit)

1Password extension (desktop app required): 4.7.2.90

Given the above configuration, after upgrading to 1Password 7 and re-installing the browser extension the Firefox extension does not work anymore.

Originally, neither did the Chrome extension, but after completely uninstalling 1Password 7 with AppZapper and re-installing it, the Chrome extension has now begun to work.

In Firefox, the 1Password extension Icon 'flickers' between enabled and disabled states. Clicking the icon does nothing.

Things I've tried:

  • Rebooting the machine (multiple times)
  • Restarting Firefox
  • Uninstalling the extension, restarting Firefox, re-installing the extension.
  • Uninstalling / re-intstalling 1Password 7
  • Restarting the helper via help > troubleshooting (clicking 'Show 1Password Extension Helper Log' does nothing).
  • Downloading / installing the troubleshooting app and taking suggested actions (fixing permissions, extended attributes, launch services).
  • Created a diagnostic report and sent to AgileBits (still waiting on a response).

Some other potentially important information:

  • I have been a standalone license holder through versions 3 to 6.
  • I was recently added to a 1Password team and as such have an account for that team, but not for my personal/local vault.
  • I upgraded to v7 after being prompted to do so via the app.
  • Personal vault is saved to a local EncFS filesystem (mounted via Fuse). Syncing is handled via the syncthing protocol

I've tried everything at my disposal. I can not get the extension to work in Firefox.

This is incredibly disruptive to my workflow as using a browser from a different vendor is not an option.

I would very much appreciate any help getting to the bottom of this issue.


1Password Version: 7.0.4
Extension Version: 4.7.2.90
OS Version: 10.13.4
Sync Type: WIFI / Bespoke

Comments

  • Hello @tthew,

    I've managed to locate your diagnostic report and I'll reply to that email. If you hadn't sent one in I was going to ask for one anyway as it's our best chance at figuring this out so that was a nice pre-emptive move on your part.

    ref: QPL-87527-263

  • Having the same issue with Firefox AND Chrome for more that 6 months after updating app to version 7, when clicking 1password button in browsers 1password app is brought to front and immediately goes back to background. Tried all different methods I was able to find over the internet, same as author, no luck :(

  • Hi @lostintime,

    If you haven't already then I'd like you to send in a diagnostic report. it will be much quicker than attempting to guess the cause of the problems you're having as there are a few reasons why this may happen. This link will guide you through the steps and has sections for the various supported versions of 1Password.

    How to send a 1Password diagnostics report

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    Once you've sent the report you should received an automated response from us with a ticket ID. If you can post that ticket ID here it will help us locate your diagnostic report and we'll see what it reveals.

  • edited June 5

    I solved this issue by quitting Firefox, then force quitting '1Password 7' and '1Password Extension Helper' from within the Activity Monitor. After that, I opened 1Password and Firefox and the extension was working again.

  • Hi @tkemperman,

    There can be a variety of causes and some may be very dependent on the version of 1Password. We did have some trouble with the 1Password 7.3 for Mac update and some people have found they've had to either quit 1Password entirely, restart their Mac or in the more tough cases delete the 1Password application bundle, restart and then install a fresh copy. We're investigating why in order to try and ensure future updates aren't this bumpy. Given the age of the previous posts though it is unlikely it is the same cause in all cases.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file