Cant get 1PW X on FF started

Hello there,
i wanted to try out the Addon for FF (im using latest Version 61.0 on Windows 10pro). I have a running membership, and use the regular Windows program and regular Browser extension.

I saw 1 PW X in Chrome over at a friend and said wow... tried now to install the 1 PW X Beta Addon for Firefox.
Installation is ok, but when i Click on it, there just stays a blank page.
In Chrome i saw there was a Login Form and after that all was great.

But FF wont even load that.

May it have a problem cause i already using the regular Browser extension ?
Already deinstalled that once but no change...
Can you help me anyhow ?

Thx in advance


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: WIN 10pro 64bit
Sync Type: 1 Password

Comments

  • Facing the same issue in my Windows 10 pro desktop too in firefox browser. No such issues with 1password X in chrome browse though. Is it that 1password X does not work in windows environment in Firefox?

  • MitchMitch

    Team Member

    Hi all,

    Can I ask if you had Private Browsing turned on in Firefox when you installed 1Password X? We've recently discovered an issue where 1Password X shows a blank page when Private Browsing is enabled because it's unable to create its local database. If this is the case for you, the extension will work if you uninstall it, turn off Private Browsing, then reinstall it.

    -Mitch

  • Hi Mitch:

    Does this mean 1password X will not work in Private browsing mode? Are you planning to resolve this issue? Or, will this be the feature and one is forced to work in the normal window and give up private browsing mode?

    Cheers
    Krishna

  • Hi there,
    No, I didn’t have private browsing activated.
    Normally I never do that at home.
    Also tried to deactivate the regular browser plugin and reinstall X for Firefox. But nothing helped.
    It still shows up a blank page.

    Is it possible that the add on tries to send me a welcome / login screen and it can’t handle that I’m already in an activated browsers environment for 1PW ?

  • I didn’t have one of those options running, but still are not able to get past this blank page.
    I initially reported this topic and I thought if it could be that Firefox doesn’t recognise or can’t handle, that I already activated the browser due to earlier registration and activation of the regular browser plugin (not X) ?

  • brentybrenty

    Team Member

    @mantok: Rather than try to troubleshoot your issue (which seems to be different than the topic of this discussion anyway) in multiple places, I'll merge your posts together in one place.

  • SystemSystem

    Team Member
    This discussion was created from comments split from: Blank page when using 1Password X in Firefox.
  • brentybrenty

    Team Member

    @mantok: If you're not using Private Browsing windows in Firefox at all (not just the "Always use private browsing" setting) and you're still seeing this, I wonder what might be different in your case. If you create a new Firefox profile and install 1Password X there, do you see the same behaviour? However,

    Is it possible that the add on tries to send me a welcome / login screen and it can’t handle that I’m already in an activated browsers environment for 1PW ?

    Can you clarify what you mean here? Thanks in advance!

  • brentybrenty

    Team Member

    @mantok: Unfortunately Firefox doesn't support the extension.getBackgroundPage() API in Private Browsing mode for some reason. Since we're not confident that Mozilla will address this any time soon (Chrome does support this already as part of the WebExtensions spec), we're investigating to see if there's a way we can work around it on our end. In the mean time, Firefox will unfortunately show only a blank window for 1Password X in Private Browsing mode. We'll see what we can do though.

    ref: b5x-352

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file