Safari not filling passwords OSX

edited July 2018 in Mac

Long time user, first time caller... I'm a fan

Problem Description

On my Mac, the Safari extension is not working correctly: it does not fill passwords on websites. I have to manually copy and paste the passwords.

When I'm on a page with a login and I click the 1Password icon on the Safari window, it launches 1Password where I login and then click fill in the 1Password app and then it launches another window that says "looking for 1Password app", and then I get a prompt to "Do you want to allow this page to launch 1Password 7?", and then it goes to "Couldn't connect to 1Password" and I have the options to "Try again" and "Learn More". Every once in awhile, it will say it is connected and ready to go, but even then it does not work.

However, the Safari extension does offer to save new passwords when I type them in, and the saving works, so it is at least partially working and it is talking to the 1Password app.

System and Configuration Details

1Password 7.0.7, Safari Extension 4.7.1, OSX 10.13.5

I'm running a 27" mid-2011 iMac with 8Gb of RAM. I did a full clean reinstall of OSX on this computer earlier this year using a single Samsung 850PRO SSD; the drive is setup with one partition and I did a plain vanilla install, I don't have any other drives hooked up to the system. The computer is working very well, except for this issue.

IIRC, I was running an earlier version of 1Password on this setup and it was working completely fine...but I'm not sure. Maybe I went straight to 1Password 7 after my clean OSX install? I don't remember.

I've been using 1Password for several years, and recently bought the subscription. 1Password is working fine on my PC and my iPhone.

The only other browser extension I'm running is Ad Block Plus, and the only security software I'm running is Malware Bytes. I don't have any other 3rd party password managers installed.

I'm running the extension from the store, I have 'Always keep 1Password Extension Helper Running', 'Automatically sign in after filling..." and "Detect new usernames..." all enabled. There are no exceptions in the 'Detect new usernames'.

I have it set to automatically detect new versions, but I have not selected the option for beta builds.

I have a single account with a single vault.

I do see the 1Password button my Safari browser window. I am not hiding the button and have never hidden it.

I am not running any kind of proxy or VPN.

I am not running a 3rd party firewall on my Mac and I have not done any configuration to the OSX firewall.

I only have one install of 1Password.

I don't have any other user accounts running.

I am not logged in as admin, but I have the admin password.

Troubleshooting Steps I've Tried So Far

I've tried rebooting my Mac.

I've tried multiple variations of quitting 1password, uninstalling and reinstalling the Safari extension and rebooting the system before, in the middle of and after the extension removal and reinstall procedure.

I've tried the steps from this link (most of them do not seem to apply to my situation): https://support.1password.com/extension-troubleshooting/

I've also looked at this page, but it does not seem to apply to my situation: https://support.1password.com/firewall-proxy/

I've tried uninstalling and reinstalling both the extension and the whole 1password application.

I've also tried, various beers and wines and am ready to move on to cocktails....I'm open to your suggestions on what you think will work best here.


1Password Version: 7.0.7
Extension Version: 4.7.1
OS Version: 10.13.5
Sync Type: Subscription Login

Comments

This discussion has been closed.