Autofilling doesn't work on Android P

Yo.
So right now I am running the Android P Beta 3, and while I know it isn't released yet, I thought I would bring up this issue in case it is something on your side.
I can't seem to make autofilling work in the beta (at least not consistently). My test case is the Capital One app, which has always worked for autofilling (though I am noticing this behavior in other apps such as Chrome as well). The "Autofill with 1Password" dialog does show up, but when I click on my capital one entry, it just doesn't do anything. I have all of the filling settings turned on, and what is weirder is that when I switch to the keyboard, after selecting my login, the "Fill Username" and "Fill Password" buttons don't show up anymore.


1Password Version: 7.0.BETA-15
Extension Version: Not Provided
OS Version: Android P Beta 3
Sync Type: Dropbox

Comments

  • mverdemverde

    Team Member

    @burn123 I'd be happy to help figure out what's going on here. Could you start by telling me if you're syncing with 1Password on another device? Did you recently upgrade from using the AgileKeychain format to using the OPVault format? I'm chasing down a couple of clues here to see if this might be related to other reports that have similar symptoms.

  • I'm using dropbox to sync with my laptop and desktop, this is the only phone I'm syncing it with, and I switched from agilekeychain a couple years ago :)

  • mverdemverde

    Team Member

    @burn123 thanks for confirming those details for me. Could you also let me know which versions of 1Password you are using on your laptop and desktop? And are they Mac or Windows machines?

  • Both machines are Windows, I've been away from my desktop for a few months, so I don't think that has much to do with it, nor do I remember :P My laptop is running 7.1.567

  • periperi

    Team Member

    Thanks @burn123. If you go to the Capital One website in Chrome, are you able to fill there?

  • @peri Nope it exhibits the same behavior

  • brentybrenty

    Team Member

    @burn123: Very odd. It's working here in both the app and Chrome. What device are you using?

  • Google Pixel

  • mverdemverde

    Team Member

    With the help of another one of our beta testers, I've managed to reproduce a similar issue with a sample Login item. It looks like this may be a side-effect of some of the changes we've made to the way that item properties are handled in 1Password for Android. I hope to have this one sorted out very soon.

  • Cool, thanks!

  • periperi

    Team Member

    :smile: :+1:

  • mverdemverde

    Team Member

    @burn123 if you haven't already updated to the latest beta, could I get you to do so and try using Autofill with the Capital One app again? We fixed the issue I mentioned above in the beta, so I'd like to confirm that it also fixes the issue you were experiencing.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file