Can you update a document in the mac app yet?

I would like to be able to open the document, click save and then it save back to the system. I lost a lot of work because that is what I thought it was doing originally, only to learn the hard way. Documents for me is pretty useless without a way to update it.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:update a document

Comments

  • This can be done via the web interface.

  • brentybrenty

    Team Member

    @bgarmen: Documents are intended as secure file storage, not a workspace for living documents; but indeed, you can drag one to replace another in the 1Password.com web interface. It may be something we can add to the app as well, depending on demand.

  • I encountered this problem today. I'm organizing scanned images of important documents (like passport) where both the image and the textual data in it are useful. I used to store these documents in Evernote but it's been rough. The mixture of image and text doesn't look clean and Evernote generally sucks at structured data.

    I had to make a change to one of the images and noticed that it's impossible to replace the file in the document with a new one in the Mac app. I thought about just importing the new image and deleting the old one but I had typed a LOT of meta data in that document. Maybe a way to merge the meta data of one document to another could be a workaround.

    P.S. I uploaded an image about 300MB in size and the web app crashes every time when viewing the document in Chrome. Maybe don't auto-preview the file when it's too large?

  • brentybrenty

    Team Member

    @zodiase: Sorry about that. Unfortunately there are some very real technical limitations within the browser. You'd need to upload a file that large using the desktop app instead. It will not work in Chrome, though smaller ones will.

  • cmw022cmw022 Junior Member

    @brenty Odd comment about "living documents" vs "secure file storage". What document doesn't change from time to time? I'm trying to use a 1PW shared vault to share information about my affairs, living will, POA, etc. with my family in case something happens to me. It would seem 1PW would be the ideal place for this. As opposed to, for instance, dropbox, which is not secure and has now been crippled by new limitations on free accounts. But the inability to update a document easily in the Mac app is a hassle. Also the lack of folders to organize Documents.

  • brentybrenty

    Team Member

    @cmw022: Okay, then save the new file to the shared vault in 1Password and other will have access to it. :)

    I don't know why you're trying to start an argument with me about a comment I made in conversation with someone else nearly a year ago. 1Password is a password manager, not a replacement for Dropbox. :tongue:

    Can you tell me what difficulty you're having adding a Document in 1Password for Mac? It seems to work here.

    "Folders" are not used anymore because we have tags, which can serve the same function without the limitations of folders (e.g. sync conflicts in shared vaults, items cannot belong to more than one folder at a time, etc.) But if you have specific suggestions on how you'd like to see us improve our implementation of tags, let us know. :)

  • cmw022cmw022 Junior Member

    @brenty Thanks for the reply. I apologize for the argumentative tone. The problem is not adding a document, it's updating a document when it changes. If I drag and drop the document to the list of documents, it creates a new one. OTOH if I drag onto the existing doc, it adds it as a new one and adds a "related items" link to the old doc.

    Also, tags are useful as a way to try to keep related docs together but as an additional way of organizing I'm adding them as attachments to a secure note. So when I update a document, I have to manually follow the following steps:

    1. Add the document
    2. Tag it
    3. Move the previous version to the Trash
    4. Edit the secure note and delete the related item (old version)
    5. Link Existing to the new version.

    Can you suggest an easier way to do this?

    I also tried updating the document in the web app. At first I had trouble with it not syncing to 1PW7 on my mac or if it did sync, when I tried to open it (with Safari, it is a .webarchive) Safari claimed it was damaged and instructed me to put it in the trash.

    I decided to change file formats to pdf --- I had several funky things happen with webarchive --- and repeated the experiment and that all works now and seems to be an adequate workaround.

    Thanks

  • brentybrenty

    Team Member
    edited May 2019

    @cmw022: No worries. Thanks for being a good sport, and for clarifying! :chuffed:

    The problem is not adding a document, it's updating a document when it changes. If I drag and drop the document to the list of documents, it creates a new one. OTOH if I drag onto the existing doc, it adds it as a new one and adds a "related items" link to the old doc.

    It sounds like you want us to change 1Password's behaviour to allow a drag operation to replace the existing Document. That makes a lot of sense, and is probably worth considering. I'm not sure it makes sense for any other kinds of items, but I'm not sure how often people use the "drag file to existing item to create a new Document linked to that item" feature, so maybe there's room to change without messing up existing workflows.

    I really appreciate the info on how tags tied into this too. It wasn't clear to me earlier that it was connected, but that makes a lot of sense too in this context. I agree that workflow isn't very convenient, and we should do better. I think it just goes to show that there's still plenty of room to iterate on the (relatively new) Documents feature. I'll bring this up with the team. I can't promise these specific changes, but we do want to make Documents more useful and convenient for everyone. :)

    Finally, you also hit on something we've done in the web interface that hasn't made it to the native apps yet. I'm not sure we want it to work just like that, which is part of the reason we don't have this feature everywhere yet (rolling it out in the web app makes it available across all platforms, and allows us to tweak it more easily). But we'd definitely like to do something like that with the native apps eventually too. Thanks for taking the time to explain your use case and what you had in mind. That helps a lot as we continue to develop 1Password. Cheers! :)

    ref: b5/b5#6005

  • @brenty Just stopping by to mention I also encountered this UX/feature mismatch issue. Apologies if it's necromancing a thread, but here's my scenario:

    I needed to update a file in a shared vault, and like others got confused that drag & drop just created new linked files (Mac app v7.3.1). When I spot-checked my sanity with others using the shared vault, they also got confused ('could have sworn i was able to edit it before'). Seemed they also forgot this had to be done through the web interface.

    When I did check the web interface, I had consistently missed the [edit] button:

    • On a full-screen'd browser, it's not as obvious on the bottom right hand side.
    • As an outlined box without filling or call out styling, this further exacerbated the subtlety (props to the team on the clean UI, though)
    • I also expected it to be in the top left since the [edit] button is in the top left of the Mac OS app, because humans are creatures of habit.

    Thanks again for your hard work, and hope this is something that helps the team clarify and bring attention to the confusion. Cheers!

  • BenBen AWS Team

    Team Member

    Thanks for sharing your experience with this @morrob. I personally would love to have an easier way to update files that exist as Documents within 1Password.

    Ben

  • Sorry for necroposting, but I've actually run into a very similar issue, and I wanted to express my frustration in hopes of some form of improved functionality being added to the app to alleviate this.

    My issue is similar because I have a csv of credentials stored in 1Password that I've gone and updated a couple of times as I've made more accounts.

    "If they're credentials, why not save them as such in 1Password?"
    2 reasons:
    1) They're not my credentials, they're credentials for programatic accounts and accounts for other people I've had to create.
    2) I acquire them as a CSV, so it's easiest for me to just keep it as it is.

    So I first made a few accounts, got a csv of the credentials, stored it on 1Password (I am also on a mac as the original post). I later made more accounts, got a csv of the credentials of the new accounts (just the ones I made at that time, not including the older ones), went to the csv in 1Password, opened it with my editor of choice, copied from the newly downloaded csv to the one I have saved in 1Password, saved, quit, and then later went back and realized that the new credentials were gone.

    Here's the problem: I assumed that upon saving that 1Password would detect the file change and update the remote instance of the file from the temporary local one. Another program I use, Cyberduck, has this functionality, and I use it often, so I erroneously expected it here. With Cyberduck, you can double click on a file, and it will create a temporary local copy, open it, and when you make changes and save it, it syncs those changes to the remote copy.

    As a result, I've actually lost these credentials and now have to remake multiple accounts on the system I'm using. I see now that after I make changes to it I'm going to have to re-upload the completed file to 1Password manually for the changes to actually occur, and I for one find this unintuitive.

    I'll be more careful in the future, but I hope my tail of woe will help someone out in the future, or possibly introduce the idea of a sync-on-save feature to 1Password.

    Thank you,
    monodemono

  • BenBen AWS Team

    Team Member

    Hi @monodemono

    Thank you for sharing your experience here. Personally I'd like to see this functionality expanded as well. There really hasn't been much demand for it though, and so it hasn't been able to bubble to the top of the to-do list. Fingers crossed it'll make it there at some point. :)

    Ben

  • We routinely encounter the same problem on a large development team. We store JSON-ic credentials that are programmatically access via the CLI tool. If we need to update any of the secrets, the "replace an existing file" dance is grating. You probably don't "see much demand" for it because there's no good "upvote" mechanism in these forums, like there might be in say GitHub. My guess is if you asked the people who use 1P in a professional setting, you would find a lot of desire for this issue to be fixed.

    Hope this helps!

  • BenBen AWS Team

    Team Member

    @kapanka

    If you're using 1Password Business I'd encourage you to reach out to your account rep (or [email protected] if you aren't sure who that is), as they'll be in the best position to advocate for business oriented features.

    Ben

  • Using a Mac desktop with personal 1Password. I previously had created a Word document with all of my 93 year old mother's financial accounts/information and thought 1Password would be the ideal, secure place to store it. I did just that a few months ago. Her financial information changed, so found and opened that same MS Word doc from 1Password and made about 2 hours worth of edits/editions. Hit "Save" thinking updated document would be saved either in Word to my iCloud account and/or to 1Password. Then printed doc with all changes. Printed version, after hitting save showed all my changes/additions. Closed Word.

    Now, when I try to find the updated document, it seems to be gone. Not saved in my iCloud account with other Word docs. Not saved in 1Password. The prior version, before my 2 hours of edits/additions is in both places.
    So, there is no way to update documents stored in 1Password and save them?
    At least I have the printed document with changes made, but would be nice to be able to digitally save those changes.
    Maybe I'm missing something?

    Do I need to somehow cut and paste to create a new document with a different name and then save that new document in Word, then import that updated doc with new name into 1Password, then delete it from Word and finally, go back and delete prior version? Seems pretty cumbersome.

  • ag_anaag_ana

    Team Member

    @EEinIA:

    Her financial information changed, so found and opened that same MS Word doc from 1Password and made about 2 hours worth of edits/editions.

    Did you download the document to your computer before editing it? I think currently you need to download the document, edit it and reupload it rather than being able to edit the document directly within 1Password.

    Do I need to somehow cut and paste to create a new document with a different name and then save that new document in Word, then import that updated doc with new name into 1Password, then delete it from Word and finally, go back and delete prior version? Seems pretty cumbersome.

    You can skip several of these steps: download the document to your computer, edit it, and upload it again to 1Password (you can even overwrite the existing one if you prefer).

  • Did you download the document to your computer before editing it? I think currently you need to download the document, edit it and reupload it rather than being able to edit the document directly within 1Password.

    Apparently I did not download document to computer. Thought I did, but apparently not. Clicked on document in 1Password and got a prompt to “Open” with a selection of editing programs. Chose MS Word and opened document with that. I didn’t think I was “editing the document directly within 1Password” by doing this. But maybe I was? Seems like I was outside of 1Password and editing within MS Word.

    Edited document and hit “Save” several times during editing process. Assumed this would save document back to 1Password or onto computer but now I know that does not happen. Seems to be saving document while in Word program but, from what you are saying and what I’ve read on this forum, that does not happen. At least I thought to print edited/updated document before closing it when I was done, so at least I have a hard copy with changes/edits that I made.

    Today I’ll go back and re-do it all from that hard copy.
    This time will try to download original document to computer first. I’m somewhat uncomfortable doing this as I really don’t want that document on my computer with sensitive information on it. But if that’s what it takes, I’ll download, edit/make changes then upload edited/changed document back to 1Password. Then I’ll have to go back and delete document from my computer as I don’t want it ‘visible’/unsecure there. Not easy, but ‘doable’.

    Thanks for your reply/help.
    I might suggest some kind of instructions or built-in prompts within 1Password for users to warn them edits are not saved when editing documents from 1Password. (Would have saved me a lot of time.)

  • BenBen AWS Team

    Team Member

    Thanks for letting us know about this pain point @EEinIA. I'll be happy to share your feedback with our team.

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file