7.1.BETA-2 and now browser extensions don't work [7.1.BETA-3 fixed filling issue with Safari]

tulleratullera
edited August 12 in Mac Beta

Just did the beta install of the latest version and now when I click the toolbar button for 1password in Chrome/Safari/Firefox, it briefly flashes the 1password app, then returns back to the browser window and nothing happens. No mini window, nothing. Reinstalled the extensions and still no go. If the app is quit, then it doesn't launch the app or show the mini window.

1password the app works fine, I don't think I realized how much I rely on the browser extensions to do my daily tasks. Let me know if I can provide any more information.


1Password Version: 7.1.BETA-2
Extension Version: 4.7.2
OS Version: macOS 10.13.6
Sync Type: Not Provided

«1

Comments

  • rudyrudy

    Team Member

    @tullera,

    Did you quit 1Password completely or simply do a cmd Q/Quit ?

  • Ahh, I just did a cmd-Q, I just did a "Quit Completely" and now things are good again. Thank you!

  • Co-signing. When I use Cmd-\ to fill in, it asks me to install the browser extensions which are already installed. Frustrating.

  • jcrjcr Junior Member

    Same issue; Quit Completely from 1Password menu item seems to have resolved. I know this is a beta and all, but I would kinda expect the installer (which seems perfectly capable of quitting the 1P app) to take care of "Quit Completely" for me, if it is necessary to work properly. :-)

  • kennonbkennonb Junior Member

    Having the same issue here. I thought maybe it was related to Mojave, but looks like you're still on High Sierra.

  • kennonbkennonb Junior Member

    Also, I did "Quit Completely" works for a min and then borks out again.

  • edited August 7

    Having the same problem here. Also tried uninstalling the extension and reinstalling it with no luck. High Sierra here.

  • edited August 7

    Can confirm same as @kennonb - able to get extension working briefly by forcing a quit on 1password, extension appears to work, try to fill a password, it then reverts to just flashing the app up briefly. Running High Sierra, same issues in both Safari and Chrome.

  • edited August 7

    Can confirm that I have the same problem here.
    On Mojave beta 6.
    EDIT: Tried quitting 1P completely but as others pointed out, appears to work for a while before it goes back to flashing the app.

  • go2jogo2jo Junior Member

    Yup ... installed 1Password 7.1.BETA-2 (70100002) & when in Safari I still get this:

    Why are we directed to the Apple's website and not to the 1P beta plugin installer web page? When did you force the Apple Extension Library page & stop allowing the 1P web installer where we could choose beta plugins? Have I been asleep ... or doesn't it matter any more?

    Like the others, even after doing a complete quit, the extension no longer works as it did. Mini still thinks the plugin is NOT installed as the image above indicates. I've even gone as far as, uninstalling the plugin, reinstalling 4.7.2 plugin, complete quitting & rebooting my iMac. Nope. Didn't fix anything.

    BTW ... I used Time Machine and went back to 1Password 7.1.BETA-1 (70100001). Works fine now.

    Sure hope you fix this quickly & push beta 3.


    macOS 10.3.6
    iMac (Retina 5K, 27-inch, Late 2014)

  • 1puburap1puburap Junior Member

    Same problems here. Neither "open and fill" nor "autofill" works.

  • OAWOAW Junior Member

    Just cosigning. "Quite Completely" works momentarily and then it flakes out again. I'm getting the same message contained in go2jo's screen shot above. 1PW 7.1 Beta 2 and macOS Mojave 10.14 Beta (18A353d).

  • thejokellthejokell Junior Member
    edited August 7

    Same issue here. Quitting 1Password completely appeared to fix it, but my first attempt to fill a password did nothing and then the extension would "flash" the full window and back to Safari.

    1Password 7.1.BETA-2
    Extension version 4.7.2
    macOS 10.13.6
    Safari Technology Preview Release 62 (Safari 12.1, WebKit 13607.1.1)

  • OK, I'm having exactly the same issue. 1Password 7 Version 7.1.BETA-2 (70100002), Safari extension V4.7.2, Safari 11.1.2, macOS High Sierra V10.13.6.

  • edited August 7

    Same here, did a quit completely and the Safari extension is not working :(
    MacOs Mojave (Bets 6)

  • jcrjcr Junior Member

    Yeah, it came back for me too (after initially being fixed by quit completely). I'm reverting to beta-1.

  • Is there a link to Beta-1 until this get's fixed?

  • Same problem here as Tullera, same configuration; also Firefox extension broken, too. Reverted to 1Password 7.0.7. Safari works again. Firefox a fizzle. What is time-sensitive in the beta so that what worked yesterday doesn't today? No more adventures for me.

  • rudyrudy

    Team Member

    I'd like to see a Diagnostics Report from someone willing to stay on beta 2.

  • Pelorus32Pelorus32
    edited August 7

    I have the same problem. How do I get you a diagnostic report?
    1Password 7
    Version 7.1.BETA-2 (70100002)
    AgileBits Beta
    @rudy

  • edited August 7

    Happy to provide a Diagnostic report. Please let me know how.

    Scratch that, I remember I had the app, generating now.

  • @rudy Just as an aside, the only thing in the logs for 1Password is this - from about 45 minutes ago:

    Wed Aug 8 06:23:39 2018| 70100001 [UPDATER:(Secondary Thread 0x600000265940):<OPUpdateWindowController: 0x7f926740d250>] E MD5FromServer | Error downloading MD5 hash 'https://c.1password.com/dist/1P/mac7/1Password-7.1.BETA-2.zip.md5': (null)

  • Looks like the tool doesn't attach the report in Mojave, where is the file actually generated so I can attach it?

  • Pelorus32Pelorus32
    edited August 7

    @rudy I've sent a diagnostic report to the support email.

    I'd like to see a fix soon though...it's pretty painful

  • Gilles9Gilles9 Senior Member

    It just does not see the extension...sight

    You guys have many problems since 1Password 7...unfortunately

    extension, screen sharing, filling fields badly, autosubmit off and on

    hummm

  • ekivemarkekivemark Junior Member

    I can confirm the same issue. Using High Sierra (10.13.6), Safari ( 11.1.2 ) or Chrome (69.0.3497.23 (Official Build) beta (64-bit))
    1Password 7.1.BETA-2

    Doesn't matter whether 1Password7 Beta or standard Safari or Chrome Browser Extension.

    The symptoms are the same as others have reported. Click Browser Extension and 1Password app flashes up and focus returns to Browser. Unable to paste into fields from 1Password.

    Tried Quit Completely from 1Password7 mini. This has no effect.

  • rwakefordrwakeford Member

    Gosh, I seem to be having more problems than anyone as the extension just flicks on for a second and then off and 1Password main beta 2 just opens but no response when trying to open any site with Mojave beta 6. Just totally dead :-(

  • @rudy just sent a diagnostic as the problem came back. [#WJW-33738-615]

  • I am experiencing the same issue reported here on both macOS 10.13.6 and 10.14 beta. Tried quitting completely to no avail.

  • ekivemarkekivemark Junior Member

    Nice work Agilebits. This is why we love you and 1Password! 7.1.BETA-3 fixes the issue of not pasting into forms for both Safari and Chrome.

    I just upgraded to Beta-3 and now everything is working again.

«1
This discussion has been closed.