Not filling in extra saved form details

This isn't "new," but it's definitely ongoing and extremely frustrating.

I have some sites (two in particular, Amazon AWS and Volgistics) which require more than just Username and Password for login. They also require an Account ID or something else to that effect. That account ID is stored in the Web Form Details section.

For some accounts this is easy for me to key in by hand (it's my company name or something else to that effect) while in others it's a 10+ digit numeric ID which there's no way I'm going to remember with infrequent use, meaning I have to dig deeply into the entry and expand the form details, copy them, then paste them into the form before I can log in. This is especially frustrating when auto-login is enabled in 1P and the form gets submitted missing information and you end up getting thrown back to an error page.


1Password Version: 7.1-BETA3
Extension Version: 4.7.3.1
OS Version: OS X 10.14
Sync Type: 1Password

Comments

  • LarsLars Junior Member

    Team Member

    @signe - sorry for the trouble you're having just now with a couple of sites. I'm wondering: have you already tried re-saving the item, manually? If not, that would definitely be my first step. Sites sometimes change the behind-the-scenes setup of their login pages, and it renders old data in 1Password anywhere between semi- and non-functional. If you haven't done this, the steps are right here. Give that a whirl.

    However, if you have tried that, or trying it now doesn't resolve the issue, then if you wouldn't mind sharing URLs with us, we can have a look at what we might be able to do on this end.

  • xz4gb8xz4gb8
    edited March 14

    @Lars
    I was reviewing these postings and recalled a site which just changed login page format. So, of course, I followed are right here as you suggested. After clicking the 1Password button in my browser, I found no Save New Login choice. Apparently this has been removed in the latest Beta. I did try Option-clicking as well. Eventually I found that Option-Clicking the Menu Bar 1Password icon, a New Login choice caused the 1Password - Save Login window with Create New/Update Existing to appear as we are used to seeing.

    I don't know if this is a bug, feature, or design change yet to be documented. It is puzzling.

    Update: Just tested the new differently named object. Open and Fill works for login.speedway.com now. Maybe somebody at Speedway is a 1Password user?

  • LarsLars Junior Member

    Team Member

    @xz4gb8 - ahhh, you must be using the beta, and hence the new mini. In the current iteration, the gear icon has been removed, but you can still right-click the mini in your Mac's menubar and get the option to save a new Login for the current page, as you discovered.

  • @Lars
    Yes, it is the beta.

    Since the saving of a new or updated login from the browser is a browser-related event, the browser 1Password icon should be a working path to the function. As a product manager and manager of programmer teams I found that Users and Developers almost never have the same view of a product. This appears to be a "change for change sake" done without completely thinking through how users actually use 1Password. The naive view is that the browser button is there to be used whenever using the browser. Requiring use of a different button is a violation of the principle of minimum astonishment. Please pass this on to the Beta team.

  • LarsLars Junior Member

    Team Member

    @xz4gb8 - you're not wrong, IMO, about users and developers having a different view of the product. What seems obvious/necessary/superfluous to one group is different from what seems like any of those things to the other group, frequently.

    To give you a little behind-the-scenes, of the criticism of the new mini that's been in 1Password 7 for Mac since launch, the overarching theme was that it was cluttered and confusing. Fewer, clearer items with more intuitive functions were what people, in one way or another, were asking for. What we have now is a beta, in which we're road-testing a much more stripped-down version of the mini. This included seeing if we could remove that gear icon by offloading the functionality it contained. I suspect we aren't quite to the point where we can do that just yet, and you may very well see its return in upcoming betas. Thanks for noticing and taking the time to share your experience/ideas. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file