Proxy address invalid since 7.2.576

nakagronakagro
edited August 2018 in Windows

Pre-7.2.576 my 1Password was authenticating over my networks proxy with no issues (corporate), since updating to the latest stable the same address that worked is now considered invalid, I did notice in the patch notes there were changes made to validation the proxy address so I'm sure this is related. I have two proxys at my disposal and if I use their IP address it passes validation and won't spit back an error however using it's DNS name it will always fail validation, it's very weird.

The DNS of the two proxies work like this:

  • proxy.domainname.state.edu.au port:3128, requires a user/pass (where state is 3 letter abbreviation of the state my work is in)
  • proxy.domainname.anotherdomain.net.au port 8080 or 3128, requires no user/pass.

Both of these domains fail proxy validation in 7.2.576

Has anyone else run into this issue?


1Password Version: 7.2.576
Extension Version: Not Provided
OS Version: Windows 10 1803
Sync Type: Cloud

Comments

  • GregGreg

    Team Member

    Hi @nakagro,

    There are indeed some changes in the latest version 7.2.576 of 1Password for Windows. However, they are supposed to improve the situation with proxy, not worsen it.

    Could you please try to sign in to your account on 1Password.com in the browser and create a new test item there? Are you able to do that with your proxy on or you see an error? If you see an error, it means that there is something else going on here.

    Thanks in advance!

    Cheers,
    Greg

  • Yes, same problem here. Every entry shows the error "Proxy address invalid", even if just a password change occured. But, if the new Password is entered in the popup where 1password asks for authentication for the Proxy, the entry of the new Password works.
    Only in the settings pane every entry is invalid.

  • GregGreg

    Team Member

    Hey @aixxo,

    Are you able to sign in to your account and make changes in the browser, not in the app? Please confirm.

    Thanks in advance!

  • Hi Greg,
    I'm not quite sure, what you want.
    I have an Internet Connection through my browser all the time, but when the Proxy Setting is not filled in the 1password app, I'm always asked to provide the user name and Password and since the newest veriosn of 1password every entry in the windows app is marked with the "Proxy address invalid" error.
    The webiterface of 1Password is not affected at all.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @aixxo,

    Please use this guide to generate the 1Password diagnostic report and email it to us at [email protected]. Also, in the email, include the link to this thread along with your forum username, so that we can connect the email to this thread.

    Let us know here when you've sent it, so we can confirm we got the email.

  • etahametaham
    edited October 2018

    This is still a major issue. Corporate proxy connections are still not working. I have the same error as Greg.

    Thank you!

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @etaham,

    As this is an older thread, there are no known proxy regressions in current build. The issue was that you cannot use DNS/hostname entry in the proxy name, you have to list the IP address instead. If you enter the DNS/hostname, it will come back as invalid.

    Please try entering the IP address instead.

    We're working on an update that may support PAC files directly without any proxy settings and we'll look into adding hostnames support to the proxy address.

  • Unfortunately, I can't use an ip at my corp. The proxy servers are HA via dns. Is there an ETA as to when this will be fixed? It will block several of your customers and block adoption in enterprise.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @etaham,

    We do not have an ETA at the moment, it is something we're working on as we speak.

    Would you be willing to try a private build to help us test to ensure it works in your specific network environment?

  • It does seem to work by IP, but not FQDN. I have a similar setup that we have several physical servers behind a load balancer of sorts... If you're looking for someone to run a test build, just let me know...

    DJ

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @DarylJ,

    Very kind of you to offer to help, thank you. We will definitely reach out as soon as we have a build ready.

    We've tried last week and unfortunately, we ran into unexpected issues where the DNS name would interfere with some other network calls, so we had to scrap the original implementation and try a different approach.

  • I can confirm that the issue is not resolved in 7.2.581. In order for me to download some really important data I saved in 1Password, I had to switch tethering on my phone and use my (costly) mobile network so that I could have the PDF on my computer.

    I currently disagree with what @Greg said: "However, they are supposed to improve the situation with proxy, not worsen it.". The proxy used to work, but not anymore.

    Do you guys run tests sometimes? To be honest, it's frustrating sometimes to experience such issues.

  • bundtkatebundtkate

    Team Member

    @msxtj: "Supposed to" and reality are not always the same, especially when not all of us use 1Password (or proxies for that matter) in the same way. In this case, the proxy changes were an overall improvement for many, but did negatively impact others. You may well fall into the former category as well – DNS/hostnames won't validate, but as MikeT mentioned, IP addresses will. If you're able to swap to an IP address in advanced settings all should be well.

    Of course it's frustrating to encounter issues. We don't just build 1Password, we use it every single day (and we use internal builds at times, to boot) so we see these issues too. If Mike had a cookie for every time I've sent him an all caps complaint about something, well ... he'd have cookies to last for this holiday season and many more. We know this is a problem and understand it's causing some frustration, but as Mike mentioned here, though, adding DNS/hostname support has proven more difficult than expected. We understand it's frustrating and we're working on it as we speak. Hopefully you're able to enter an IP address for now, but if you're not do let us know if you're interesting in testing a private build when we have one ready and you'll be among the first to see this solved.

  • Thanks @bundtkate - I cannot use an IP address in my corporate environment here -so please send me a private build that has an improved proxy support. The current settings seems quite primitive. See all the possible options Firefox proxy settings ask (http, https, socks 4/5 etc..).

    I'm glad you use 1Password every day. Sometimes I get issues on a regular basis and I scratch my head asking myself, do the devs even use this product? I am sorry to say that this way - don't want to be mean, but it's just a strange feeling..

    There are several usability issues and I could make a long list of them. Let me know if you want me to open a new thread for each feature request but let ms state a few:

    • Inability to create new sections for a password. There is only one. Go ahead, try it out and you'll discover indeed you can't do that.
    • Unable to add an attachment to a password. You need to do lots of hooplas and tricks to make it work. Right now, the cumbersome workaround is to create a new item and then "Link existing". I have the impression I could drag and drop on Mac back then, when I was on 1Password 4 for Mac. I do not have a Mac anymore.
    • Unable to force sync with the server. I make a change on an item on my Android phone and it takes forever for the change to appear on Windows.
    • much more..
  • @bundtkate - As you suggested , can you please send me a build that has a working proxy implementation, which I could test?

  • bundtkatebundtkate

    Team Member

    @msxtj: That's something we'd need to do when we have it ready and that day is not today. As Mike mentioned earlier, we're working on it and aware of the issues with DNS names, but don't have something we're happy with yet. I will happily let you know when we do.

    Regarding your other feedback, related items are a newer implementation of attachments and, indeed, are in need of some more attention. Mac does allow drag and drop (as do we for Document creation), but you can't yet create an attachment within the item you're linking it to.

    The sync issue is likely the performance trouble we're working on for the next update. Syncs are happening slowly for many right now and we're reworking much of that system. If you'd like, I can certainly take a look at some diagnostics to be sure, but that's my best guess at a glance.

    Finally, new sections, I can create new sections anywhere, even for Password items, but perhaps I'm not understanding you correctly. Are you looking to have a secondary password for a particular item, perhaps? I want to make sure I'm actually barking up the right tree here. Thanks!

  • Hello everybody, any updates on the Proxy issue? I cannot use 1Password properly since November 2018 as sync doesn't work.

  • I am having a similar proxy issue. My client and cloud do not sync if I am behind a proxy. When I go to type in my proxy information into the client settings, there seems to be a bug with accepting my information. It won't persist my settings. After typing a username, it disappears immediately after I type it. I also get a red error message on the form that says "Proxy address invalid".

    Any help would be appreciated, as it causes me extra steps to connect to my mobile hotspot to sync and back to the corporate network again, each time I change a password.

  • bundtkatebundtkate

    Team Member

    @msxtj: No news at the moment. We're winding up our current development cycle, which was focused on some performance issues. Once the current beta gets to stable, we'll be back at it and look at new priorities for that cycle. Given we've already put some work into DNS names for proxies, I'd not be surprised to see that as one focus, but since we haven't yet found something that works as we'd like, it may still take time.

    @dennis_s: Based on the error, I suspect you're trying to use a DNS name and you're right that this is the same issue. Try using an IP address instead and let me know if that works. If you are using an IP address and are still running into issues, of course, let me know. :chuffed:

  • Thanks for the quick response. Our proxy does not accept connections by IP address since it uses host headers. Unfortunately this will not work for me.

  • bundtkatebundtkate

    Team Member

    In that case, I'm afraid you'll need to hang tight for a bit. As Mike mentioned here, this is something we were planning to implement earlier, but we found it caused other issues with network calls and couldn't be released, so we've needed to take more time to refine DNS name support. I can't comment specifically on when it may be ready, but if you'd be interested in testing a private build when we have one available, let me know and we'll be sure to reach out when we have something ready. :chuffed:

  • MikeTMikeT Agile Samurai

    Team Member
    edited January 9

    Hi guys,

    If you're using a DNS hostname for your proxy and cannot use the IP address, use the 1Password 7.1 build where it did work. We won't be able to fix this in 1Password 7.3 but it is a high priority and ongoing, 7.4 is where we plan to add it and we do want to ship it quickly.

  • Hi,

    This issue has been problematic for me for some time too. I have to hotspot to sync my passwords at work. Even when I use the proxy IP, it tries for a while then reverts to auto detect settings, which is a WPAD file that fails. It prompts for auth but the credentials are never accepted.

    Is there an ETA for 7.4 when this issue might be resolved?

  • GregGreg

    Team Member

    Hi @Al Nelson,

    We bumped into some unexpected difficulties with that update, so it is taking longer than expected. I do not have any ETA right now, but we are working really hard to make it happen. You can switch to beta updates in 1Password 7 settings and receive an update automatically, when it is available.

    Let us know if you have other questions. Thank you!

    ++
    Greg

  • Is there any update as to when the PAC file network issue is ever going to be fixed? It seems to be a constant "we bumped into some unexpected difficulties."

  • brentybrenty

    Team Member

    Yep, proxies on Windows are a bag of hurt. Nothing to announce at this time, but we'd very much like to find a workable solution.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file