Trouble connecting to the 1Password Agent background process

My 1Password has been broken for days, i.e. the Chrome and Firefox extensions (I don't use Safari) cannot connect to the 1Password agent and are therefore useless. The troubleshooting page is not much of a help, some instructions are invalid, other refer to Safari and not the browsers actually in use.

Any ideas?

Comments

  • BenBen AWS Team

    Team Member
    Hi MacMacken,

    Can you please email us the troubleshooting report as an attachment and in the body of the message include a link to this thread?

    support at agilebits.com

    Thanks!
  • JasperhoundJasperhound Junior Member
    Same for me - I have to unlock 1Password's extension every time EXCEPT within a few minutes of launching Firefox. The extension is set to 'Enable Universal Unlock' yet when I run a troubleshooting report, the report reads 'Universal Unlock enabled NO'. I'm using extension 3.8.6, 1Password 3.8.10 and OS 10.6.8 on an iMac. It's really annoying as the 1Password system used to work so well up to recently. By the way I get the same problem when I travel with my MacBook Pro. I'm starting to wonder if there's a problem with syncing my password file via Dropbox - possible?
  • guys 1 password works perfectly, just download FF5 and 1P 3.7.2........

    The new versions by all accounts do not work for one reason or another........
  • MacMackenMacMacken Junior Member
    edited November 2011
    pds2011 wrote:

    guys 1 password works perfectly, just download FF5 and 1P 3.7.2........

    The current Firefox version is 7.0.1.
  • MacMackenMacMacken Junior Member
    bwoodruff wrote:
    Can you please email us the troubleshooting report as an attachment and in the body of the message include a link to this thread?

    support at agilebits.com

    You've got mail, thank you!
  • jpgoldbergjpgoldberg Agile Customer Care

    Team Member
    Thanks everyone for sending the troubleshooting reports. They are a help in that they at least let us know what isn't the problem, but unfortunately they don't pin point the problem either.

    However there is a newly minted version of the extension, 3.8.7, which fixes a couple of connectivity problems and improve the troubleshooting report.

    Your browsers should find and update the extensions on their own, but if you want you can hurry the process along

    In Chrome go to Window > Extensions from the menubar and click on "Update extensions now".

    In Firefox go to Tools > Add-ons from the menubar then "Extensions" and then in the tools (gears) thingy near the search field, use "Check for updates".

    First see if the new extensions fix the problem. If so we are good to go. If that doesn't do it go to Help > Troubleshooting > Restart Helper in the 1Password menubar. (Note that this menu doesn't exist in the 1Password 3.9, but as you are both using Snow Leopard, you must be using 1Password 3.8 ).

    Finally, if neither of those work, send us the Troubleshooting report from the 1Password.app. This is again available from the 1Password ( 3.8 ) menubar as Help > Troubleshooting > Diagnostics Report. Those, again, should be mailed to us instead of posted publicly.

    I think that the new extension version should fix the problem, but because we never got to the bottom of what the problem was, I can't be sure. But hopefully that will do the trick and we can avoid another round to digging into diagnostics reports.

    Cheers,

    -j
This discussion has been closed.