AutoFill iOS 12 setup

sissingsissing
edited August 2018 in iOS Beta

Hi,

I just downloaded the latest 1Password beta for AutoFill Passwords in iOS 12. First of all, this is awesome! I can turn off iCloud keychain and manage all my password properly within 1Password.

  1. When I set it up, it asks if I want to receive a push notification for Clipboard Notifications (two-factor codes). I can't find this setting inside the 1Password app. To change this, I need to turn off and on the AutoFill Password (under iPhone Settings app > Passwords & Accounts).

  2. The message is not completely clear. It asks if I want to get a notification, but I tried to turn it off and use the two-factor code, but it's not available. I would be nice to turn this on but not get the notification every time the code has been copied to your clipboard.

That's it for now,

Thanks!


1Password Version: 7.2 (70200001)
Extension Version: Not Provided
OS Version: iOS 12 beta 8
Sync Type: iCloud

Comments

  • Same here: would like to have 2FA without the notifications.

    Is the current implementation because of some technical limitation?

  • Seconded. The notifications workflow is a bit rough around the edges. It was extremely unclear to me why the notification options screen appeared after turning on autofill and Face ID'ing, some copy text there would go a long way.

    (Love, love, LOVE the new feature, BTW! ❤️)

  • MrRooniMrRooni

    Team Member

    Thanks for the feedback, all. As it stand right now the intention is to only copy TOTPs to the clipboard if notifications are enabled since we don't want to put one-time passwords on the clipboard without letting you know.

  • I did not test this, but are 2FA codes cleared from the clipboard after some time?

  • MrRooniMrRooni

    Team Member

    If you enable the option to Clear Clipboard in 1Password > Settings > Security then your one-time password will be cleared from the clipboard after 45 seconds. This feature does not, however, restore the previous value of your clipboard.

  • Yes, I was/am confused by the fact that the notification remains while the clipboard is cleared.

    (I like the clearing of the clipboard; I wish the notification was removed as well)

  • brentybrenty

    Team Member

    I think that would be great, but as far as I know iOS doesn't offer a good way to do that. Interesting idea though. :)

  • Sent an email invitation per instructions. As a long term 1Password user on all my iDevices and Mac’s and a registered Developer using iOS 12, I’m hoping to give the new features a try and help test it out. Looks great guys! Thanks.

  • MrRooniMrRooni

    Team Member

    Thanks @cdorschel. As you might imagine we're swamped with requests to join the beta, but I promise that we will get to yours as well. 🙂

  • For those of you that don’t want the notification to remain just turn off everything except for the banner notification in iOS notification settings for 1Password. That way you just get the drop down banner and never see it again. Works pretty slick.

  • brentybrenty

    Team Member

    That's a great tip! :)

  • Thanks @MrRooni! I received my TestFlight beta and have been running it with iOS 12 DP 10 on my iPhone X and iPad Pro 10.5’s. Made sure it’s activated in iOS Password’s setting and so far it’s 100%. I’ll make certain to report any bugs and/or recommendations with further use.

    Thanks again!

  • brentybrenty

    Team Member

    Likewise, thanks for participating in the beta! :chuffed:

  • How do I sign up for beta? I already sent an email but never heard back.

  • brentybrenty

    Team Member

    @asif_nabi: I don't know offhand if we have any open slots, but if you followed the instructions here we'll see if there's room and get back to you via email either way. :)

  • Does the new iOS auto fill only work with 1Password on iPhone vs. iPad. I’ve updated to 12 on both and I dont’ seem to have the same option to select it on my iPad Pro.

  • brentybrenty

    Team Member

    @gonzojohnson: Any device running iOS 12 can use it, unless something has gone really wrong on yours. You'll need to enable it on each one though; this setting doesn't seem to sync through iCloud:

    Use 1Password to fill and save on your iPhone and iPad

  • Very strange. The option wasn't there yesterday and showed up today. Not sure what happened, as I was for sure already on iOS 12. Thanks anyway. All is working now.

  • brentybrenty

    Team Member

    I couldn't tell you, but sometimes a restart helps. Glad to hear that iOS is now offering you the autofill option though. Cheers! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file