Qantas login

Hi. I've read the previous discussions and still can't seem to get this to work.

I've tried various options including:

https://discussions.agilebits.com/discussion/76751/issues-with-1password-and-the-qantas-frequent-flyer-login

https://discussions.agilebits.com/discussion/comment/442417#Comment_442417

How can I get this to work?


1Password Version: 1Password 7 Version 7.0.7 (70007001) Mac App Store
Extension Version: 4.7.2
OS Version: 10.13.6
Sync Type: 1Password

Comments

  • Hi @antjnr,

    So I visited https://www.qantas.com/fflyer/dyn/program/welcome and I filled in the three fields of the visible sign-in form titled Frequent Flyer Login - I didn't use the one in the drop down menu. I saved a Login using the "How to save a Login manually in your browser" ( https://support.1password.com/save-login-manually/ ) method and after clearing the form I found filling would populate all three fields. It could easily be argued that designating the surname as the username is wrong and I can show you how to modify that if you like but the key part was all three fields filled for me from a freshly saved Login item. I tested 7.0.7 and 7.1 as they have different filling code but the results were consistent between the two and I would hope you would find the same.

    If you're not seeing this can you tell me what is happening for you as we should be seeing similar results.

  • Pardon my ignorance but that worked. The login screen (on the Qantas site) looks a little different to whichever screen I was on. But that has worked. Thank you.

  • Greetings @antjnr,

    If things are working and you're happy then it's a win :smile: Glad to hear I could help and I apologise for the delay in replying. If you come across any other unusual sites please do let us know and we'll see if we can maintain this success rate.

  • PantherPanther
    edited September 2018

    I wanted to join in on this one as I too am having trouble with the Qantas site. Unfortunately Qantas seem to have many different login pages that all use different fields but after following the tips above to save the login manually I still can't get it to work. When I do that, 1Password seems to fill in the Last Name and PIN fields but not the member number. When I look in 1Password and show all login form details, the member number isn't even being saved at all.

    The URLs I'm having this issue on are https://www.qantas.com/fflyer/dyn/program/welcome, https://www.qantasmoney.com/account/login and https://www.qantaspoints.com/home. Also, is there a way to make a single 1Password entry that will work on all the Qantas sites?

    Edit - should mention that I'm using 1Password 7.1.1 on macOS 10.13.6.

  • Hi @Panther,

    Just before we delve into this can you confirm that a single account is used to access all of these different domains i.e. a password change on one is reflected on the rest. I just want to make sure what is really needed is some sort of generic item that works on several very different domains.

  • Just looking at these and the Qantas Cash one is different (as it uses an email address, so ignore that one) but all the others are identical, and when you change the PIN on one, it changes on them all. I'm sure there'll be even more Qantas login pages but these are just the ones I use. To give you more background, one thing I've noticed is often when you can get this to work in 1Password on one of these domains, say the https://www.qantaspoints.com/home one... when you then try a subdomain of that site which uses a similar form, say https://onlinemall.qantaspoints.com/ it then doesn't fill all the fields - it seems I can easily get this to work with filling the Last Name and PIN but it never fills the member number consistently.

    Yet another oddity I've noticed is that the drop down login top right of https://www.qantas.com/au/en.html is different again to the one on https://www.qantas.com/fflyer/dyn/program/welcome even though both of those login forms take you to the same place! I've been using 1Password since version 3, so I like to feel like I know what I'm doing but these Qantas logins have driven me mad for years with no easy solution as often when you manage to trick it into working, they make minor adjustments to their pages (and as you can see, there are a lot of them) and everything falls over.

    Yesterday I went in and deleted all my Qantas records in 1Password (I had about 8 separate entries all with the same info) and then did the save login manually method you suggested above. This did get it working for one single login, however when I then tried to add other URLs, or to add additional fields to the form so it could fill them in on different versions of the form, it then stopped working (the qantaspoints.com example I gave earlier in this post is a good example of that). So I deleted that one again and recreated a new manual entry so it was working for that one URL, but then when I tried adding other seperate manual entries for the other URLs, the autofill stopped working correctly as soon as there were multiple logins on the same domain (as some of the domains start to cross over, and presumably 1Password wants an identical match).

    Hopefully that makes sense, sorry for the long post! Let me know if you need more details.

  • brentybrenty

    Team Member
    edited February 10

    @Panther: Indeed, they're crazy! Just to confirm, are those the only login pages you've found (I use "only" loosely)? I was able to get the username and password filling correctly by creating a login by hand in the main 1Password app, entering the username, password, and all of those URLs. The "membership number" field doesn't work though, even if I add that field manually in the web form details section of the login as those pages are setup a bit differently. We'll see if we can find a way for 1Password to better accommodate this sort of thing, but for now I'm sorry that I don't have a good solution for you besides filling the username and password and then copying and pasting the membership number. :(

    ref: xplatform/filling-issues#262, x/b5x#570

  • Hello @Panther,

    Brenty has filed the relevant bug reports but in the meanwhile I can help reduce the craziness a little. This won't work for Qantas Money as that page does things just differently enough to not play well but I have managed to make an item that will fill the wine, points and frequent flyer pages. So that should reduce it to three items, one for cash, one for money and one for the others.

    1. Download this 1PIF (1Password Interchange Format) file and save it to your Desktop.
    2. Drag the 1PIF file to the 1Password icon in the macOS dock to import into the current vault.
    3. Edit the newly imported Login item.
    4. Click the Show Saved Form Details button (show web form details for those running 1Password 6 for Mac).
    5. Replace the placeholder values for the three fields with your real account credentials.
    6. Save.

    Obviously not perfect, three Login items for the same account doesn't seem great but the way they're doing things is just not friendly at all towards a sane approach. It will be interesting to learn what we can do to make sense of this craziness.

  • @brenty, thanks for reporting this one as a bug. It's been around for quite a while (and I'm kicking myself for not really reporting this sooner!). I know you've commented in most of the threads about this in the past but I guess if you search the forum for Qantas you'll find plenty of examples of other people with this same issue. There are lots and lots of login pages across many domain names, and for some reason they don't use a single sign on so it's quite messy. You can find more URLs by just clicking around their menu on the Qantas homepage - for example, I just found https://www.qantasassure.com which has a similar login form (but I don't use this one). Hopefully there'll be a way to fix this in a future update.

    @littlebobbytables, thanks for the 1PIF file - it's amazing! I do not know how your one works when all the ways I tried didn't (I swear I had a very similar setup with the web form fields) but I can confirm it works on almost all the login pages I can find. Considering this is a login I use almost weekly, this is a massive improvement from where I was before. Really appreciate your help!

  • brentybrenty

    Team Member

    @Panther: It's hard to say just whose bug it is, since this problem doesn't exist with other sites (and didn't with some of theirs in the past even — they change over time!) But as far as we're concerned, if there's something we can do to work around it, we'll be glad to do so, as that would help you and other customers (and those of us here with Qantas accounts as well!) I think it's too early to say for sure that we will be able to find a solution, but I think we have some ideas worth pursuing. Anyway, glad lil bobby's skills have proved helpful to you here in the mean time. Cheers! :)

  • Hello,
    I realise this thread is a year old, but I'm wanting to be able to use 1Password to log in to the QANTAS site..

    (I've tried downloading the 1PIF file mentioned by @littlebobbytables above, but it doesn't seem to work in 7.3.2 - or am I doing something wrong?)

    Anyway, I followed the instructions about not using the popup and creating a manual entry (filled out the three fields, then use the 1PW menubar item to create an entry). This stores the 'Last name' and 'PIN' fields, but not the 'Membership no.' field.

    However, if I tick the 'Remember details' checkbox, it does seem to work. Yay!

    .. but..

    That seems to work by using a cookie for the 'Membership no.' field.

    That would be a working solution for people who have only one login on any computer.

    For me, though, I manage the logins for three others as well as myself, so is only a partial solution.

    Is there a better/proper solution to this problem?

    Thanks in advance!

    Karl

  • Hi Karl (@karlg)! Could you let me know the actual URL you're visiting so I can try things on my end and see what workarounds, if any, might exist at this point in time?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file