Anyone else having problems with Santander UK two page logins no longer filling properly

Previously has always filled properly but since update to 7.1.1, no longer works. It puts the same password in to both boxes.


1Password Version: 7.11
Extension Version: 4.7.3.90
OS Version: OS X 10.13.6
Sync Type: DropBox
Referrer: forum-search:Anyone else having problems with Santander UK two page logins no longer filling properly

Comments

  • brentybrenty

    Team Member

    @adam_philip_herring: I'm not aware of any existing issues with that, but it's possible that they have different login pages or the new filling engine has had a negative impact in some cases. Can you give me the specifics? What the exact steps are you taking, and what is (or is not) happening as you expect? For example, if you fill using the keyboard shortcut -- ⌘ \ -- does that work? Be sure to let me know the URL so we're looking at the same thing. Thanks in advance! :)

  • I just use the 1password extension button in Chrome (Version 68.0.3440.106 (Official Build) (64-bit)), also have same problem in Safari.
    First page is here: https://retail.santander.co.uk/LOGSUK_NS_ENS/BtoChannelDriver.ssobto?dse_operationName=LOGON&dse_processorState=initial&redirect=S

    You need to put in a Customer ID (which I am not willing to share!). As an aside 1password now shows this in plan text!

    After that you get to a second page (see attached screenshot: I

    Again I use the 1password extension button and for 1password 6.x to 7.07 this worked fine and it would fill the Passcode box (Complicated password generated by 1password) and the Registration number a five digit PIN. It now seems to put the five digit PIN into each box (judging from the five * in each). I've tried deleting and recreating the login information. I've tried using the 1password program and taskbar buttons.

  • Hello @adam_philip_herring,

    Can you try manually saving two Login items for me please, one per stage and using the steps outlined on How to save a Login manually in your browser for each.

    If you attempt to fill the first first with its dedicated Login item and then the second stage with its one do you find things work as expected or do you continue to see odd behaviour?

    The kicker is we won't be able to reach the second page to see or test it without a genuine customer ID but you are absolute right in not sharing yours and if we were to ask I would hope you would be emphatic in your refusal. This is what tends to make financial institutes so hard to test for compatibility, only those with real accounts can reach the later stages of the sign-in process and we can't create test accounts like we can for the likes of Twitter or Amazon.

  • I'm having the same problem. I'm using firefox. Tried creating two separate logins but second login still enters same value in both fields

  • The manual save doesn't work it only saves the Passcode. On a plus point at least I'm not the only person having this problems. At the moment I am copying the password and pasting then typing the passcode. It works!

  • littlebobbytableslittlebobbytables

    Team Member
    edited September 6

    Hi @adam_philip_herring,

    If the passcode and registration number fields are both of type password then saving a new Login item will only ever display one of them at the top of the page but the other should be stored in the saved form details. The test is really to see what fills when you use the item. With that said, based on @shgUK's report it looks like even a dedicated Login item isn't working.

    Adam, I'm going to reach out to you via email but shgUK don't worry, if we learn something useful I will ensure it's communicated here as well.

    ref: IGA-86784-156

  • If it's any help - Using Firefox "Inspect Element" reveals that one is "authentication.PassCode", the other is "authentication.ERN"

  • I thought it was just me - 1password ended up locking me out of my Santander account and I had to wait 6 days for letters to come through the post with new customer number etc. Fortunately my Wife had a login that had access to our joint account so we could survive. It had worked flawlessly with these vault entries for a long time. I got locked out by then trying to select and copy the details from the 1password mini interface, after the usual auto login failed, but instead it filled and submitted the fields with the wrong details and before I knew it I was locked out. Have now switched off auto submit and unfortunately my new Santander customer ID has a revised login process requiring selected parts of my password and PIN so can not automate the login any more.

  • Hi @littlebobbytables,

    Any update to Santander issue?

  • Greetings @shgUK,

    I haven't made any progress yet I'm afraid but if you're willing there are a couple of things I'd like to test. I'll send you an email.

  • I'd be more than happy to help resolve this issue. send away

  • Hello @shgUK,

    Sent :smile:

    ref: KXK-73466-791

  • littlebobbytableslittlebobbytables

    Team Member
    edited September 14

    Hi @fryrpc and @adam_philip_herring,

    Thanks to the assistance of Adam and @shgUK I think we have a solution. I've written the details up and posted it in Santander (UK) workaround for 1Password 7.1 for Mac and 7.2 for Windows. If it works you will even find it means you can use a single Login item to fill both pages. Please do let me know if it works as well for you as it seems to for one of our other users who helped me with the testing.

    Due to it being a bank and the multi-stage sign-in process this really was not possible without the help of Adam and shgUK. They were both willing to help me learn more about the page in question and to test stuff as I tried to figure out what might work. Given the price of being locked out of a bank's online service I wish I didn't need them to act as guinea pigs but we would never have learned what we needed without somebody willing to try.

    ref: fill-269

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file