7.1.1 doesn't fill password anymore...

... in my CC's access page (www.nexi.it/privati.html) :-/

thanks for having a look


1Password Version: 7.1.1
Extension Version: 4.7.2
OS Version: 10.13.6
Sync Type: iCloud

Comments

  • Hi @pl_svn,

    Can you try creating a new Login item for me please using the steps outlined on our support page How to save a Login manually in your browser. As you kindly supplied the URL I tested and found the Login item I created filled both fields. Hopefully you find the same. Please do let me know if you find otherwise.

  • pl_svnpl_svn Member
    edited September 2018

    just tried and... no: new login too only fills username :-/

  • Hi @pl_svn,

    Odd... we should have seen identical results. What browser were you using? it's rare but maybe there's difference and that explains why things worked for me but continue to fail for you.

    When you test, are you manually visiting the page and you can see all the fields are empty. Then after instructing 1Password to fill that is when only the username field is filled? I only ask as sometimes I've seen browser autofill cause confusion and I'm wondering if it's a factor here.

  • pl_svnpl_svn Member
    edited September 2018

    I'm using Safari (on macOS 10.13.6)

    yes: I opened the page from my bookmarks and tried using 1PW's new login (all fields were empty)

  • pl_svnpl_svn Member
    edited September 2018

    thinking about it... what is your language setting on that page: IT or EN?
    (being local mine obviously is IT ;) )

    and if I change my settings to EN... 1PW doesn't even fill username :-/
    (neither from the original or the new, manually saved, login)

  • littlebobbytableslittlebobbytables

    Team Member
    edited February 11

    Hi @pl_svn,

    So unless I'm told otherwise I will always test a site using the default language, I like to try and avoid any unexpected differences because I've altered the language. If I need to I'll load the English version in a completely separate browser to help me navigate in the browser where I'll be performing the tests.

    It seems Safari is a factor though. I find both fields fill in Vivaldi, my daily use browser, and both fields still do in my test just now. Despite that though I see the same as you, only the username fills on Safari. For some reason 1Password reacts differently when filling in Safari than it does in Vivaldi.

    I'll file a report but in the meanwhile I'm hoping you find the following helpful.

    1. Download this 1PIF file.
    2. Drag the 1PIF file to the 1Password icon in the macOS dock to import it.
    3. Edit the newly imported item and replace the placeholder values for the username and password with your real account credentials.
    4. Save the changes.

    If you try filling do you find this works in Safari as well as any other browser you may use? It's a slightly modified item to coax 1Password into a filling decision that ensures it fills the correct password field.

    ref: xplatform/filling-issues#252

  • pl_svnpl_svn Member

    hi @littlebobbytables

    tried and... it works :)
    (Safari is the one and only browser I ever use, sorry ;) )

    thank you so much indeed :)

  • Greetings @pl_svn,

    I'm glad that helped :smile: My personal experience is browser differences are thankfully rare but sometimes they do exist as we've just seen firsthand. At least everything ended well.

    If you come across any other problematic sites do let us know.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file