1Password 7 crash, refuses to run

I have not been able to run 1Password7 on my laptop for some time. Here's what I have...

1Password 7.2.576, installed 8/24, on Windows 10 laptop.I should have 2 images attached to this email. One is from msinfo32 describing my system info, and the second is the windows application event log showing the crash details. The issue is that 1Password7 worked fine until I applied a windows update, shown below. I haven't been able to get the desktop app to work since.
https://support.microsoft.com/en-us/help/4100347/intel-microcode-updates-for-windows-10-version-1803-and-windows-server

I do have the Firefox browser addon working just fine. That is what is what I'm using for now when I have to use the laptop.



1Password Version: 7.2.576
Extension Version: Not Provided
OS Version: Windows 10.0.1734s
Sync Type: Not Provided

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @setigamer,

    Thanks for reporting this.

    We need the .NET error that follows after the 1Password.exe error in the Event Viewer, the error isn't from 1Password but Microsoft's .NET runtime on your Windows PC. Windows 10 updates have .NET updates built in, so that could explain why this started after the update was installed.

    Instead of the screenshot of the .NET error in Event Viewer, you can right-click on the error to select Copy > Copy details as text and paste it here.

    After that, try to uninstall 1Password and then install a fresh copy from here: https://1Password.com/downloads/ to see if that'll help. Uninstalling from Apps & Features list will not remove your 1Password data.

  • You got it ... I got it and then reinstalled, same version, same error.

    Log Name: Application
    Source: Application Error
    Date: 9/12/2018 11:35:35 AM
    Event ID: 1000
    Task Category: (100)
    Level: Error
    Keywords: Classic
    User: N/A
    Computer: SETINDUSTRY
    Description:
    Faulting application name: 1Password.exe, version: 7.2.576.0, time stamp: 0x5b69b6af
    Faulting module name: ntdll.dll, version: 10.0.17134.228, time stamp: 0x2c71c7b8
    Exception code: 0xc0000409
    Fault offset: 0x0005be3e
    Faulting process id: 0x108
    Faulting application start time: 0x01d44acfc6864779
    Faulting application path: C:\Users\noone\AppData\Local\1password\app\7\1Password.exe
    Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
    Report Id: 59f158ea-0d58-48c1-a6ff-89002a7f3f9f
    Faulting package full name:
    Faulting package-relative application ID:
    Event Xml:



    1000
    2
    100
    0x80000000000000

    28256
    Application
    SETINDUSTRY



    1Password.exe
    7.2.576.0
    5b69b6af
    ntdll.dll
    10.0.17134.228
    2c71c7b8
    c0000409
    0005be3e
    108
    01d44acfc6864779
    C:\Users\noone\AppData\Local\1password\app\7\1Password.exe
    C:\WINDOWS\SYSTEM32\ntdll.dll
    59f158ea-0d58-48c1-a6ff-89002a7f3f9f





  • Forgot to mention, this app used to work fine. I believe the problems coincided with the install of 2018-7 Update for Windows 10 Version 1803 (KB4100347)

    For grins I'll uninstall that and see what's up. Thanks for the help.

  • Uninstalling that didn't fix anything. Lot's of windows updates coming through now, I'll try the app again after they're done.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @setigamer,

    I don't see any .NET errors in your log, did you select the .NET source right under 1Password?

    If you have a lot of Windows updates, then that may be the issue. We've seen crashes because of incomplete updates that is resolved when all updates are finished. We're not sure why it happens but hopefully, it is the case here for you.

  • setigamersetigamer
    edited September 13

    I don't see any options to select any .NET source. The only thing after the 1pass error is the windows error reporting notice. I'll grab the .wer report.

    I had 3 updates, including the one that I uninstalled. I'm running sfc to verify integrity. I'll run dism and see if that finds anything too.
    I'm seriously contemplating resetting the darn thing.

  • Interesting, I didn't notice it before as I haven't run it in a while, but Acrobat Reader DC also crashes with the same fault.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @setigamer,

    What's more interesting is that you didn't see .NET error. 1Password runs on .NET, .NET loads first and the last to exit the crash, meaning they should always be there to capture the crash report.

    Try to look at your Reliability History, see if there were any other updates that were installed. Open the Start menu and search for Reliability History to open it. See if there are other internal crashes you may not be seeing. If you see a lot of crashes, it is possible you may want to revert back to a system point created before the last update that worked fine.

  • And there's absolutely no other place it would report .NET errors?

  • MikeTMikeT Agile Samurai

    Team Member

    As far as we know, it would go straight to Event Viewer.

    You can try to look in this directory but it may not help as it may not capture the .NET errors without 1Password being able to run once: %LOCALAPPDATA%\1Password\logs\events

    The last option is to try moving out your 1Password folder.

    1. Sign in to your 1Password account first using Firefox (https://my.1Password.com) and click your account name on top right to select Get the Apps
    2. Open Windows File Explorer and enter the following in the address bar: %LOCALAPPDATA%
    3. Move the 1Password folder to your desktop
    4. Install the latest 1Password file here: https://1Password.com/downloads/
    5. See if 1Password opens up without crashing. If yes, switch back to Firefox and scroll down to step 2 to find the blue Add your account details button, click it and 1Password should open up waiting for you to enter the master password.

    Hope this helps.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file