Why was auto-submit removed? [Intentional; auto-submit not returning]

Gilles9Gilles9 Senior Member
edited September 2018 in Mac

Hello

in a few responses on these forums, the Agile's reps mentionned that autosubmit will not work with Mojave and Safari 12
and this was the reason Agile withdrew that option
( note: some said because of Mojave, some others because of Safari 12)

I am using 1Password 7.0.7 because auto submit is still available with this version ( and because of some websites filling issues )
and AUTOSUBMIT works just fine

why did you remove it ? if it is because of Macos, it might be for 10.15, not Mojave as far as I can see.

Why don't you leave it avaiblable meanwhile or should I say reinstate it with 7.2

it was an extremely usefull feature


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

«1345

Comments

  • Auto-submit stopped working for all sites

    This is what I have tried so far:

    Open the main 1Password app.
    Go to 1Password > Preferences in the menu, then click on the Browser tab.
    Make sure the setting for 'Automatically sign in after filling usernames and passwords' is enabled (there should be a check mark next to it).
    Find a Login item in your vault that isn't being auto-submitted correctly, then click the Edit button.
    Make sure the 'submit' setting (near the bottom of the item details) is either Submit when enabled or Always submit (if not, change it to one of those).
    Click Save.
    Open that site in your browser and use the 1Password extension to fill your username/password.
    Uninstall the 1Password Safari extension and install the latest version

    What should I do now?
    Thanks


    1Password Version: 6.8.8
    Extension Version: 4.7.0
    OS Version: 10.13.3
    Sync Type: iCloud

  • LarsLars Junior Member

    Team Member

    @Intruth - is your copy of 1Password 6 for Mac from the Mac App Store, or from us?

  • It's from the Mac App Store.

  • LarsLars Junior Member

    Team Member

    @Intruth - thought that might be the case. Occasionally a permissions issue on your Mac can cause this to not work as expected. If that, or the autosubmit script became damaged for some reason, reinstalling it can help. Try this:

    • Close all browsers
    • Quit 1Password and the Mini completely, by typing ^⌥⌘Q (or just holding down the Control and Option keys as you choose Quit from the 1Password menu)
    • In the Finder, go to the following folder: ~/Library/Application Scripts/2BUA8C4S2C.com.agilebits.onepassword-osx-helper (if you have trouble finding that, select Go > Go to Folder and copy/paste that location in the field that appears)
    • Delete the 1Password_Autosubmit.scpt file.
    • Restart your Mac.

    See if that helps, and let us know how you get on.

  • Not sure about it not working on all sites as I only use it on one and it stopped working in the move from 1P6 to 1P7.0.2.

    I've tried the advice above but it have not made any difference.

    What can I try next, so far 1P7 feels like a backward step, though I'm sure it is not.

    Regards

  • LarsLars Junior Member

    Team Member

    @iwaddo - I'm sorry for the trouble, but I've got a few clarifying questions for you: what "advice" have you already tried, specifically? Do you have 1Password 7 for Mac installed in /Applications, or some other location? Do you see Read Only anywhere when looking at the main window of 1Password, and do you have the 1Password browser extension installed?

  • @Lars I tried the advice in your post further up in this thread to delete 1Password_Autosubmit.scpt file

    Yes, 1P for Mac is installed in Applications
    No, I do not see Read Only anywhere in the 1Password main window
    Yes, I have 1Password browser extension for Safari installed (it installed itself)

    Regards Ian

  • LarsLars Junior Member

    Team Member

    @iwaddo - OK, thanks for the additional information. I'd like you to remove the 1Password extension in Safari, restart your Mac, then Re-download and install our extension, and let us know whether you're still experiencing the same issue. Thanks.

  • camerdooncamerdoon
    edited June 2018

    @Lars @rudy I'm still in the same predicament as @iwaddo at the start of the discussion.

    [Note from 1Password team: your earlier comments, along with replies, have been merged into the new discussion you started: Multiple issues with 1P7 - Auto submit and now Safari extension]

    Did @iwaddo get his issue resolved successfully?

  • @camerdoon no it’s not working for me yet.

    Not sure what I do now.

  • @iwaddo @rudy - please refer to - please close this conversation and refer to https://discussions.agilebits.com/discussion/91221/multiple-issues-with-1p7-auto-submit-and-now-safari-extension#latest to for the latest. for the latest. @iwaddo I've created a new user on the Mac and migrating across as a stop gap. Not ideal, inconvenient, and requires enough knowledge to be dangerous. Cam.

  • LarsLars Junior Member

    Team Member
  • LarsLars Junior Member

    Team Member

    @iwaddo - I'm sorry to hear you're still having ongoing difficulties getting 1Password for Mac's autosubmit script working. Have you closed all running browsers, and then toggled the Preferences > Browsers button marked "Automatically sign-in after filling usernames and passwords" OFF and then back on again?

  • During fault diagnosis I went down a “dark path” and messed up a heap of my apps or systems; the things I do for a great piece of software AgileBits. With my data backed up I performed a clean install of MacOS and now all seems ok. Just in the process of reinstalling but 1P 7 is all good now. As my system was always upgraded from previous versions of the operating system and 1P, it suggests to me something from past installs of 1P, other software or MacOS/OS X, carried over a permission or incompatibility that 1P7 exposed.

  • BenBen AWS Team

    Team Member

    Thanks for the update @camerdoon. Glad to hear you were able to get the issue sorted.

    Ben

  • @Lars exiting browsers and toggling the preference seems to have corrected my problem. Thank you for your help.

  • JacobJacob

    Team Member

    Glad to hear it! :)

  • I tried all the resolving methods in the forum but got nothing.
    This is what's in 1Password_Autosubmit.scpt

    --This simple script allows 1Password
    --to sign in automatically by pressing the return key on your behalf
    tell application "System Events" to keystroke return
    

    When I auto fill, a gear icon appears shortly on my menu bar then disappear. However the login is not auto submitted.


    1Password Version: 7.07
    Extension Version: 4.7.2.90
    OS Version: OS X 10.13.6
    Sync Type: 1password

  • Some additional info: If I use command + \ shortcut, the auto submit won't work. If I click the browser extension icon and select my password then the auto submit works. My browser is Chrome.

  • BenBen AWS Team

    Team Member

    Hi @Haobo,

    Auto submit is in the process of being decommissioned. As of 1Password 7.2 it will no longer be in the product at all (see comment from development here). There are some security concerns with extensions being able to simulate key strokes, which is what 1Password is doing in order to auto-submit forms (emulating the ‘return’ key). Going forward extensions including 1Password will be prevented from doing this. Finding the right balance between security and convenience is always difficult, but in this case the security concerns seemingly outweigh the benefits provided.

    I’m sure we’ll have more information to share on the subject as things progress.

    Ben

  • MrRooniMrRooni

    Team Member

    Hi there @Gilles9. Autosubmit has been removed from 1Password with the 7.2 update. There are a number of reasons for this, including user experience and reliability, but the main reason is for security. This is because the way this is achieved (by having the browser extension ‘imitate’ you pressing the Return key) can also be exploited by malware to do some fairly nefarious things. Starting with Mojave we no longer have the ability to mimic the Return key, and took the opportunity to finally rip the bandaid off and remove autosubmit everywhere.

    I apologize for the inconvenience this has caused, but hopefully you’ll get used to just tapping your ‘Return’ key after filling with 1Password and soon enough you won’t miss it as much as you think.

    I hope this helps! Please let me know if you need anything else at all, and myself or another member of the team will be more than happy to help.

  • Gilles9Gilles9 Senior Member

    you say: Starting with Mojave we no longer have the ability to mimic the Return key

    Why is it it works with 7.0.7 and Mojave

  • BenBen AWS Team

    Team Member

    @Gilles9

    That’s hard to say, but Apple is removing the ability to simulate the return key (for good reason). As such we’re removing autosubmit, as it relies heavily on the ability to do that. We do not have plans to resurect it at this time.

    Thanks.

    Ben

  • edited September 2018

    Hey guys,
    Removing "autosubmit" is one of the BEST features of the software. Please consider re-adding it back in for Chrome/Firefox. I'll have to revert down to pre 7.2 for now. Why is there no mention of it's removal from release notes?
    thanks
    brandon

  • Ok. Getting pretty irked by this. Just tried to rollback to 7.1.2 but it says my database has been updated and I can't?

  • I'm surprised people are willing to roll back... it's a quick press of the return. Security is more important than an "autosubmit" feature. However, I agree that it should have been added to the release notes as I had to search why it stopped working.

  • MrRooniMrRooni

    Team Member

    I’m sorry you were caught off guard by this removal, Brandon. Autosubmit has seen its last days, however. When it worked it was great, but when it didn’t it was a pretty rough experience. I definitely understand where you’re coming from, I was pretty annoyed at first too. Now that I’ve gotten used to it, however, I find the peace of mind at seeing forms filled in the way I want much better than dealing with autosubmit misfires.

    Also, yes, I’m afraid we updated our database format with 7.2, so rolling back to an older version isn’t straightforward. Do you have a 1Password membership or are you using 1Password in standalone?

  • KepiKepi
    edited September 2018

    This probably should’ve been mentioned in 7.2’s release notes as I came here looking for a cause/solution as well.

    Though this change will come in handy for the sites 1Password tried its best on but ended up auto filling and submitting into a search field (rare, but I’ve come across it) 😁

  • MrRooni, I use standalone version synced via dropbox and have multiple (client) vaults so I assume these have been updated as well? Rolling back will be pretty hard I'm assuming. I never had too many issues with "autosubmit" because I always made sure to have the proper url with the login. That was the key. I really don't want more clicks. I'm logging in/out to sites all the time and having it autosubmit was one of my FAVORITE featues. I've already had a few calls from clients who are complaining that 1Password doesn't "work" anymore. Please consider re-implementing this feature.

  • BenBen AWS Team

    Team Member

    @echoparkbaby and @Kepi

    My apologies but after significant consideration... unless the landscape shifts substantially I don’t see auto-submit coming back. That said, it is an excellent point that we should’ve mentioned its removal in the release notes, and we’re discussing how to best address that situation.

    Rolling back is really not ideal. You’ll essentially have to be “frozen in time” with 1Password, macOS, and your web browsers in order to do that which just isn’t a practical solution in most cases. It is also a really poor option in terms of security, which is one of the core reasons to use 1Password in the first place.

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file