Windows 10 7.2.580 installer issue "Access is denied" - can't install, lost access to my passwords!

Recently it seems 1password tried to update itself. I had previously installed using installer version 7.2.576 on 8/13/2018. This was working fine (though 1password was buggy, constantly crashing from the Firefox extension) until last night when in the background 1password apparently tried to update itself. This update failed with the "Access is denied" message. When I manually download 7.2.580 to install I get the same message. I've also tried to remove the installed version of 1password via the "Add/Remove Programs" control panel and it gives me a different error: "Cannot find the utCompiledCode record for this version of the uninstaller".

So I'm stuck. And completely lost access to my passwords on this computer. Our company is a corporate teams customer, of that matters any.


1Password Version: 7.2.580
Extension Version: N/A
OS Version: Windows 10 Latest Update
Sync Type: 1Password Teams
Referrer: forum-search:access is deined windows 10 installer

Comments

  • I guess I should also mention that the update process appears to have removed the old version of 1password from my computer, so the browser extension is no longer working--that's the reason for not having access to my vaults.

  • MikeTMikeT Agile Samurai

    Team Member
    edited September 25

    Hi @ssutch,

    Thanks for writing in.

    For the future reference, you can always access your data on https://my.1Password.com if something goes wrong with the 1Password app.

    That sounds like your anti-malware solution blocked 1Password from completing the install and it corrupted the install, which is why you can't uninstall it either.

    Try temporarily disabling the anti-malware solution and download the installer from here: https://1Password.com/downloads/ and run it once more, it should complete the whole install.

    If you can't, try running the installer anyway to see if it works. If not, you'll have to get in touch with your IT department to help with this since their security system is interfering with 1Password installs.

  • MikeTMikeT Agile Samurai

    Team Member

    Also, we have no known crashing issue with the Firefox extension. Let's make sure 1Password is working first and we'll look at your Firefox issue next.

  • I don't have any anti-malware software installed. This is a vanilla windows 10 machine.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @ssutch,

    Do you have a screenshot of the whole error dialog that may include other error codes?

    Were there any browsers running when you tried to install 1Password?

    Try this:

    1. Download the 1Password installer but don't run it.
    2. Reboot the computer but do not open any browsers yet.
    3. Open Windows File Explorer and enter the following in the address bar: %LOCALAPPDATA%\1Password
    4. Move the app folder to the desktop
    5. Run the downloaded installer and see if it works now.
  • Unfortunately I don't have a 1Password folder in %LOCALAPPDATA%

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @ssutch,

    If you create a new folder in %LOCALAPPDATA%, what happens?

  • Very interesting. Even though I have hidden files visible, the 1Password folder must not have been visible, because creating a new folder there called "1Password" asked to replace an existing one. I allowed it, since this 1Password donesn't store anything locally that couldn't be synced. Even so, there is still apparently an issue with the installer, the same as before. Attaching the screenshot of the installer error.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @ssutch,

    That explains the problem. Windows don't allow 1Password write to hidden folders. There isn't a reason for it to be hidden but we've seen random Windows 10 updates do this out of nowhere, which can break the automatic update and also crashes.

    You have to fix the hidden folder issue, here's how:

    1. Open Windows File Explorer and enter: %LOCALAPPDATA%\
    2. Right-click in this directory to select Properties and go to General.
    3. In the General tab, go to the bottom to the Attributes section, uncheck the box next to Hidden and you'll get a confirm dialog, make sure it is set to Apply changes to this folder, subfolders, and files and press OK.
  • THAT DID IT! WOO!

    Thanks a bunch for the help. This might also fix the crashing from firefox, will report back if that remains an issue.

  • MikeTMikeT Agile Samurai

    Team Member

    :smile: I love that GIF.

    You're welcome, let us know how it works out with the Firefox extension.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file