1password 7 and MacOS 10.14 Mojave with Touch ID

With the recent upgrade to MacOS Mojave I have noticed I am prompted for my master password to authenticate 1password, whereas before the upgrade I could use Touch ID the majority of the time.

The Problem
In 1password prefs I have enabled the option to use Touch ID to unlock my password vault, and set the option to require master password again after 1 week. Even though this option is enabled I can't seem to use Touch ID to authenticate.

What I Have Tried
- Making sure that my 1password version is up to date
- Uninstalling and Reinstalling 1password
- Restarting my machine

Not sure if this is a known issue or if there is currently a work around but I wanted to bring this to your attention. Let me know if you have any further questions or if you are experiencing this as well.

Zach S.


1Password Version: 1Password 7 Version 7.2 (70200017) AgileBits Store
Extension Version: Chrome Extension version 4.7.3.90
OS Version: OSX 10.14
Sync Type: Not Provided

«13

Comments

  • rudyrudy

    Team Member

    @ZachWorkman,

    Have you yet removed all your fingerprints and then re-added them to System Preferences -> Touch ID?

  • Hi!

    I have the same problem. I have tried the same things as Zach S. And I have also tried to reset the NVRAM / PRAM - and I have deleted and re-added all of my fingerprints.

    I really appreciate any help you can provide!

  • Hey @rudy , I just removed all of my fingerprints from System Preferences and added them and it still did not prompt me to use my Touch ID to auth. I also disabled "Allow Touch ID to unlock 1password" in 1password 7 > Preferences then re-enabled it and still doesn't work.

  • rudyrudy

    Team Member
    edited September 2018

    This sounds like a scenario we've heard of where the System Keychain loses some invisible information that associates it with the Secure Enclave, which negates our ability to create the key pair that's then used to encrypt/decrypt (all done inside the Secure Enclave) our access token. We've had some luck with moving the keychain out of ~/Library/Keychains, restarting and then moving it back in again.

    This was a thread where we talked about the issue: https://discussions.agilebits.com/discussion/90046/touch-id-stopped-working-after-keychain-reset#latest

  • Hey @rudy after moving > moving it back, then moving > restarting > moving it back I still am prompted to use my master password each time. I will go through that discussion and explore some further options. I will also reach out to others using 1password with Touch ID and see if anyone else in our organization is experiencing the same issue

  • I'm having the same issues and have tried all the suggested solutions to no avail.

  • I am having the same issue. Purchased a new mabook pro, upgraded to Mojave and installed your software for the first time. No option to use fingerprint to unlock despite options being properly checked.

  • @rudy After going through that thread and trying what they suggested I am still not getting prompted to use Touch ID to auth. It was working until I updated to Mojave so I am thinking that it is a similar issue to that which was discovered a few months ago but with a different cause. Only one other person in our org has updated to Mojave and they aren't having the issue, and those still running High Sierra (10.13.x) aren't experiencing it either. I am going to suggest that no one else updates until we have at least a temporary work around for this. Do you guys have any more info on your end?

  • rudyrudy

    Team Member

    @ZachWorkman,

    if you want to generate a DR and send it to support + roo @ 1password.com we can certainly see if its that issue or not. The issue under mojave lasted from developer beta 2 until beta 5 where the secd issue in reading our entitlements was fixed.

  • Also having the same problem. Unlocking 1password always requires my master password, even though I also allowed to unlock through touch id. It was working before upgrading to Mojave.

  • On a macbook pro 2016 with OS 10.13.6, TouchID is set up and working to unlock the desktop. 1password 7.1.2 is installed and the option to enable touchid is on. The 1password lock screen does not show the fingerprint icon and does not respond to touchbar.

    Disabling and re-enabling touchid has no effect.


    1Password Version: 7.1.2
    Extension Version: 4.7.3.90
    OS Version: macOS High Sierra 10.13.6
    Sync Type: Not Provided
    Referrer: forum-search:touchid mac 10.13.6 and 7.1.2

  • Same here. I had the problem with High Sierra, then it was solved by Agilebits. Now after the Mojave Upgrade Touch Id stopped working again.

  • same here

    1Password 7.2.1 (70201002) with macos mojave

  • LarsLars Junior Member

    Team Member

    Sorry for the troubles, folks. If you're experiencing this issue and a restart of your Mac doesn't affect it any, you're welcome to create a diagnostics report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/96052/1password-7-and-macos-10-14-mojave-with-touch-id#latest
    • Your forum username.

    That way we can "connect the dots" when we see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so we can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Once we see the diagnostics we'll be able to better assist you. Thanks very much!

  • I am having the same problem with using TouchID. My ticket number is CHM-53997-293.

  • viniciusxpviniciusxp Junior Member

    Hi, I am facing the same issue. Please find my ticket number: #IRX-28413-272

  • I am having the same problem.

  • I'm also having this same issue. Just wanting to comment. Hoping for a solution soon.

  • edited October 2018

    Here's my support ID number. [#EDY-85326-547]

    Thanks!

  • I created the a report and received the following support ID: #YZV-59953-659

    Thanks for solving!

  • LarsLars Junior Member

    Team Member

    Welcome to the forum, @mdobson! I'm sorry for the trouble. Please restart your Mac and see if that helps any.

  • HI.
    Here's my support ticket number #RAJ-67931-829

  • Hi Lars,

    Thanks for your response. Restarting the Mac did not help, so I uninstalled and re-installed 1Password and the behavior is still the same. I can unlock the application with my master password, but there is no option to use TouchId, even though that is selected in Preferences --> Security.

    Thanks,
    Monte

  • LarsLars Junior Member

    Team Member

    @mdobson - before you do anything else, you should try turning Touch ID off and then back on again in System Preferences, and also in 1Password 7 for Mac itself. See if that helps at all; let us know.

  • Experiencing the same, diagnostics sent– support ID #BQC-29927-729

    Thanks for the help!
    Doug

  • brentybrenty

    Team Member

    Sorry for the confusion folks. This isn't something we can fix for you. If you've gotten your Keychain into a state where it is either missing the data for Secure Enclave which 1Password 7 uses for Touch ID security, most often caused by copying it from another Mac, you'll need to either reinstall the OS or have it recreate the Keychain so it has the correct data for 1Password to use. This Terminal command should work, but should only be done if you have a full disk backup, just in case:

    Open Terminal and enter this command: sudo mv ~/Library/Keychains ~/Desktop

    The OS should then recreate it after rebooting. If all is well, you can Trash the keychain that was copied to the Desktop. If you're not comfortable doing that or continue to have Touch ID issues, be sure to contact Apple for assistance.

  • Thanks, I will take a full disk backup, try the terminal command and let you know the results.

  • @brenty thanks.. the step you listed above worked for me. My touchid works!!

  • LarsLars Junior Member

    Team Member
    edited October 2018

    @Mykeey - glad to hear brenty's terminal command worked for you. For anyone else in this thread, this is literally the only solution of which we're aware -- and it may not work. This is not a problem with 1Password, it's a Touch ID issue that we can't resolve because all we can do is call the Touch ID process.

    ref: EDY-85326-547

  • It solved the problem for me.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file