1password 7 and MacOS 10.14 Mojave with Touch ID

13»

Comments

  • brentybrenty

    Team Member

    no I didn't copy anything over. But upon setup, I logged into my iCloud, which likely copied over my existing Keychain, no?

    @mcwinterr: Thanks for confirming. That's really odd. I don't believe it's even possible for Touch ID-related information to "sync" via iCloud. It's stored in the Login Keychain and is device-specific. As far as I know, we haven't had any other reports of Touch ID being broken on a brand new Mac.

    I did try the steps provided, to no avail. I ran the Terminal command, and rebooted. I re-setup my fingerprints in System Preferences and reselected the Touch ID option in 1Password. But unfortunately, there is still no option to use Touch ID to authenticate anywhere via 1Password.

    I'm sorry to hear that. Apart from reinstalling macOS (which others have found resolved Touch ID issues), the only other option would be to contact Apple. Neither we nor 1Password have control over Touch ID. The app just asks the OS if it's available and gets a yes or no in reply. :(

  • I also had this problem (1P7 V7.2.1, MacOS 10.14.1) and recreating the keychain worked to fix it. Here is another clue as to the cause: This happened after I ran into a problem logging in after a reboot, and used my FileVault recovery key to reset my password. Maybe that will help you guys figure out what causes this keychain corruption. Thanks!

  • brentybrenty

    Team Member

    That's very interesting. Thank you for sharing! Glad to hear you were able to get things working again too. :)

  • @Lars Hello, again. I've got a couple comments up above. Turns out TouchID has stopped working again and no amount of fixes seems to bring it back. It actually stopped working about two weeks after my last comment in this thread, but I just figured it is what it is, haha. Updated to 10.14.2 this morning hoping it would fix it and ran through all of the fixes again, no luck. Just putting it out there. Thanks!

  • LarsLars Junior Member

    Team Member

    @jandreoi - ugh. Did you try reinstalling macOS? Or still holding off on that step?

  • Nope, this is my production laptop, I can't re-install the OS. =(

  • LarsLars Junior Member

    Team Member

    @jandreoni - I'm sorry for the ongoing troubles. if you'd like to send in an additional diagnostics report, we'd be happy to take a look. I don't know how much help we'll be able to be if you aren't able (or willing) to re-install macOS, however, but it's possible we might find something there that we can help with.

  • I, too, have had problems getting Touch ID to open 1 Password. Running OS 14.2 on a 2108 MBP. I have had success by moving the keychain with the above mentioned sudo terminal command. Reset my fingerprint in System Preferences. I then opened 1 Password, deactivated the Touch ID option in preferences, quit 1 Password, rebooted, reopened 1 Password and activated Touch ID in preferences. Rebooted again. Touch ID will now open 1 Password. Not sure which of those steps actually worked (or was it the combo?) but you could try this sequence.
    Thanks to those who have shared their success stories.

  • LarsLars Junior Member

    Team Member

    :) :+1:

  • Brand new Macbook Pro with 10.4.5 installed. NO migration. Installed 1password 7. Enabled Touch ID in with two different fingerprints in System preferences. Turned on Touch ID a couple of weeks ago in Security panel of 1P7.

    This week: 1P7 starts failing to accept fingerprint. Eventually Touch ID option is gone, only Master Password field is offered. Thankfully this at least still works.

    However, in 1P7 Preferences/Security TOUCH ID IS NOW GREYED OUT.

    "This is a suck." - Office Space

  • Am now updating to 10.4.6 and will relay what happens later.

  • BenBen AWS Team

    Team Member
    edited August 14

    Hi @mascotca

    Is Touch ID still working to unlock the Mac itself? 3rd party apps such as 1Password don't have access to your fingerprints directly. Instead all we can do is query the system for Touch ID and essentially it gives us back a yes or a no.

    Please do let us know if updating helps (I assume you mean 10.14.6?).

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file