It seems some web pages prevents to fill passwords automatically

Hi
It has been working for a long time, but after they make some changes in the wed page, it doesn't fill my password, just my username. I even can't copy/paste the password (or the username, but it fills the username automatically).
This is the webpage https://www.cmr.cl/home

1Password is working fine in all the others pages.

And my Safari Versión 12.0 (13606.2.11). I doesn't work on Chrome either.

Thanks


1Password Version: 1Password 7 Version 7.1.2 (70102000)
Extension Version: 4.7.3
OS Version: 10.13.6
Sync Type: Not Provided

Comments

  • Hi @ignacioj,

    Can you try the following for me please and see if it helps.

    1. Download this 1PIF (1Password Interchange Format) file.
    2. Drag the 1PIF file to the 1Password icon in the macOS dock to import into the active vault or default vault if All Vaults is active.
    3. Edit the imported Login item and replace the placeholder values for the username and password with your real details.
    4. Save.
    5. Test and see if filling works.

    I won't deny the site does a number of obnoxious things and I didn't even realise they disabled copy and paste. That said we did make substantial changes to the filling logic in 1Password 7.1 for Mac (7.2 for Windows) so that could also be a factor in why things broke. Still, disabling copy and paste and fake password fields never make my list of things I want to see on a sign-in page so I do wish those trends would hurry up and become a thing of the past.

    I hope this item helps, please do let me know as I looked at this page not long ago and it's changed already a bit since earlier in the month.

  • Hi Bob
    Great! It's working now. (I deleted the ".txt" extension that for some reason appear in the downloaded file name)
    Thanks for your super fast answer and solution.

    On May I had similar problems with the same site, and I wrote them (translated from Spanish):

    Another difficulty that I found in the new site, is that it doesn't allow the auto-filling of the password. Probably this was thought for security, but having auto-fill or -as in my case- using a program that fills in passwords (1Password; https://1password.com), you can use longer and harder to discover passwords (and also remember), so if I can not use these systems (autofill or programs that handle passwords), I must put a simpler and easier to remember password, which makes it more insecure.

    and the stupid robot-type answer was:

    Regarding the password, unfortunately it would not be possible since the password must be only and only 6 digits, besides allowing this type of programs could mean a security breach.

  • Hi @ignacioj,

    They restrict the password to 6 digits (I really wanted to use all upper case there on top of bold) and they're worried about a password manager being a security breach?

    I don't even know where to start with that, I'm not sure you can debate security with that kind of mentality.

    It will be of no comfort at all but not that long ago I learned a lot of Canadian banks use a 4 digit PIN. So you have two extra digits over the Canadian banks. Yeah, it wouldn't make me feel any safer either but you have to feel sorry for users of those banks.

  • ignaciojignacioj
    edited January 3

    Hi
    I'm having the same problem again with the same site
    Safari Versión 12.0.2 (14606.3.4)

    Thanks

  • littlebobbytableslittlebobbytables

    Team Member
    edited January 4

    Hello @ignacioj,

    You're right, changes we've made in 7.2.4 have resulted in 1Password failing to fill the text field with the password. I'll need to file a bug report because whilst I do realise this site makes some odd choices the Login item I created specifically stated that the field type was text and 1Password is ignoring that.

    There is a workaround but it isn't one I like. Still it will mean you can fill both fields whilst we work on this.

    1. Locate your CMR Falabella Login item in 1Password and enter edit mode.
    2. Click the View Saved Form Details button.
    3. Across from the field for your password you will see a silhouette of a key. Click on it to reveal a very small menu with three options.
    4. Select the empty option, so the one that isn't either the silhouette of the person or key.
    5. Save.

    What we've just done here is inform 1Password that this item does not have a field that we want to refer to as the password, it now only has a designated field for the username. When it comes time to try and fill 1Password will see that it can match two text fields in the item to two text fields on the page and will now fill them both because it isn't considering one of those to be your password. This is far from ideal and it also means the item looks like it doesn't have a password even though it is still stored in the saved form details. It will fill though which I feel is the primary goal. I am sorry about that, when we address this we'll need to add a test case to try and ensure future updates don't break things here again.

    ref: xplatform/filling-issues#281

  • Thanks! I will try later.

  • Please do let me know what you find. Hopefully your results mirror my own.

  • Great! Its working. And the solution (following your instructions) was very simple.
    Thanks.

  • I'm glad that helped but I am disappointed in 1Password forcing us to consider this adjustment. I originally filed a report based on the bad behaviour in 7.1, I've updated it to now include the fact that things have gotten worse rather than better.

    I can only hope this is more an outlier than the norm for the sites you use on a regular basis.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file