1Password extension not working any more after update on MacOS Mojave

I recently updated to the new MacOS and since then, the safari extension does nothing, if I click it. The menu item also does nothing, as long as the extension is activated in the preferences. If I deactivate the extension in safari, the menu item will work as intended again.

MacOS Mojave 10.14
Safari 12.0
1Password 7.2


1Password Version: 7.1
Extension Version: 7.2.1
OS Version: OS X 10.14
Sync Type: 1Password

Comments

  • brentybrenty

    Team Member

    @PickleRick: It sounds like you've got more than one version of 1Password installed, and the old one is causing a conflict with the new version of Safari. Please remove any installed 1Password extensions from Safari that you can, quit Safari, drag any copies of 1Password to the Trash, and restart your Mac. Install the latest version of 1Password and not any extensions:

    https://1password.com/downloads/

    The Safari App Extension is included in the 1Password app now. Let me know how it turns out.

  • edited September 2018

    I thought I wrote this before, but the symptom went away with a complete system reboot. Should have tried this before posting here.

  • brentybrenty

    Team Member

    Ah excellent. And no worries! Just glad to hear that all is well again. Thank you for the update, and enjoy your weekend! :chuffed:

  • I had the same problem. The solution was to remove the extension from Firefox and install it again.

  • brentybrenty

    Team Member

    Definitely a different problem, as Firefox cannot use the Safari App Extension. But glad to hear you were able to get it sorted. :)

  • I have 1Password6, and after move'n to Mojave, my Chrome extension stopped working. Still works in both safari and Firefox, any ideas. I reinstalled 1Password as well as the extensions, but still not working. I don't feel I need to pay monthly for something that I paid for and has been working perfectly for a while.

  • brentybrenty

    Team Member

    @Rodaddy: I don't understand your comment about paying, but there really isn't much I can do to help without any details. What are the OS, 1Password, browser, and extension versions you're using? What are the exact steps you're taking, and what is (or is not) happening as you expect? It "stopped working" is incredibly vague, but I'm sure we can find a solution with the right information. :)

  • NeedleFactoryNeedleFactory Junior Member

    I, too, have a problem with 1Password6 on Chrome with Mojave: In the past, command-backSlash would activate the extension. Now, with Mojave's new security features, after ty0ihg command-backSlashm, I get a window saying " '1Password mini' is trying to Unlock 1Password. Touch ID or enter your password to allow this." Is there a way I can bypass this extra step, some way to tell Mojave that the 1Password6 extension is trusted?

  • brentybrenty

    Team Member

    @NeedleFactory: I'm not sure since 1Password 6 was created years before Mojave's new security features, but you could try allowing 1Password in System Preferences > Security. But I may also be misunderstanding what you're referring to. Could you please clarify what you're seeing? If it's simpler, take a screenshot of this. To include it in your reply, simply click the document button in the top of the comment field, and select the file you wish to share:

    Just be sure not to post anything sensitive, as this is a public forum. Thanks in advance!

  • Just upgraded to a new MacBook running Mojave 10.14.2, but Im still using 1Password6 and 1Password mini. Mini doesn't work in Safari 12.0.2 the way it once did under High Sierra on my MacBook Pro. I upgraded by migrating apps and data from Time Machine backup. Once when I went to a website for which I had a PW, when i opened the mini the password account would be there, and with one click the username, password would fill and the site open. Also, when i manually enter a new username and password into a new site, 1Password mini "wheel" icon doesn't contain the option to create a new account.Not now. But it seems to work the old way in Firefox

  • brentybrenty

    Team Member

    @Mhodges5: Which version of 1Password are you using, and where is it installed exactly?

  • edited January 17

    It used to be the case that I could place my cursor on an input field, press the famous "CMD \" and as long as I was logged in, 1Password would just fill in the details and hey presto. Magic. This was when I was using 1Password 6 on High Sierra.

    Now, if I'm in a field and I press CMD \, then I get 1Password open up, and I have to type what login I'm looking for, OR, press CMD+shift+x and login again.

    I'm using 1Password7 version 7.2.4
    On Mac OS 10.14.2
    Chrome Version 71.0.3578.98
    1Password manager Chrome 1.13.2

    Is there something I'm missing, or is this just the way it is now?

  • brentybrenty

    Team Member

    @markos84uk: If you're using 1Password X, that runs entirely on its own in the browser. It has no connection to the native app; it's been explicitly designed to be independent, for those who cannot install an app. The ⌘ \ keyboard isn't available to browser extensions. But you can use that with the desktop app if you install its companion extension:

    https://support.1password.com/1password-extension/

    Does that help?

  • @brenty That is perfect! Thank you.

    I made the mistake of thinking 1Password X was the extension.
    ⌘ \ is now back in use on my Mac!!! 🎉

    Thank you for the speedy reply.

  • Hi @markos84uk,

    I'm glad Brenty was able to help, if you have any other questions please let us know :smile:

  • "I recently updated to the new MacOS and since then, the safari extension does nothing, if I click it. The menu item also does nothing, as long as the extension is activated in the preferences. If I deactivate the extension in safari, the menu item will work as intended again."

    Sorry for picking this up but I may have additional information about this.

    I have the 1password app installed from the App Store.

    When there's a new version, I'll get a popup stating that "1password can't be opened during the upgrade" over and over again. Closing Safari does not make it go away. Closing the app doesn't make it go away. However, I forgot to go to the menu icon and select the settings icon, and "leave 1password completely" (don't know the original English translation)

    What I've been doing is to go to the App Store app, and click on "update" for 1password, which does update without complaining, and the popups will go away.

    But this probably keeps two versions running on the system. I'm not sure why though. On Applications, I have only one app. I've killed all processes named "1pass". I've restarted safari. I've disabled and reenabled the extension. (the extension can't be removed and reinstalled). But somehow, there really seems to be something running the previous process, and conflicting with the new updated version.

    This causes what was originally reported - safari won't autofill. Clicking on 1pass on safari does nothing. Clicking on 1pass on the menu bar when safari is on the foreground does nothing.

    Last time I had to restart my machine to recover from this. Probably logging out and back in would help, though.

    This time I noticed the process of going to the menu icon and "leave 1pass completely", and then relaunching 1pass. This solves the issue. Safari is working again.

    So, short version, indeed if two processes are running at the same time, 1pass will fail. The added information is that the update via the App Store is broken.

    (Note: it's the App Store that is broken. The same happens with many other apps. App Store tries to update the apps in the background and complains the apps can't be running. Manually updating the app by clicking on the update button will correctly close the app, upgrade, and relaunch it, e.g. Evernote. However, for 1pass, maybe it doesn't really know what needs to be closed and relaunched)

  • brentybrenty

    Team Member

    @davipt: Thanks for getting in touch. This is really interesting:

    When there's a new version, I'll get a popup stating that "1password can't be opened during the upgrade" over and over again.

    Can you attach a screenshot of this? To include it in your reply, simply click the document button in the top of the comment field, and select the file you wish to share:


     
    Just be sure not to post anything sensitive, as this is a public forum. Thanks in advance!

    What I've been doing is to go to the App Store app, and click on "update" for 1password, which does update without complaining, and the popups will go away.

    It sounds like you may have multiple copies of 1Password on drives counted to your Mac. What do you find in a Spotlight search for "1password"?

  • There’s only one app, under Applications.

    To get the screenshot I’ll need to wait until a new version is released.

    On Unix systems, a file is not deleted until all references are deleted, including the reference from the system when the app is running. When the App Store app updates 1Password, there are two binaries available, one still on memory, but no longer on disk, and the new one.

    I’m not reporting an issue on my environmental. I’m trying to show that the act of having a new version on App Store is enough to cause this, and that 1Password is not the only case where the process fails (I’ve also reports a bug on Apple).

  • brentybrenty

    Team Member

    @davipt: Totally. Just a few things you said gave me the impression that there may be something else involved -- especially since we haven't received reports like this for a long time. Maybe just coincidence though. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file