CSV import pastes all entries in title of the login entry

ZectzozdaZectzozda
edited October 2018 in Windows

I obtained a list of passwords in an MS word document, and I manually typed the logins into a comma-delimited CSV file to import into 1Password. When I imported them, all login values (title, URL, username, password, extra fields, etc) were all pasted into the title of the login record, leaving their respective fields blank. How do I create the CSV file from scratch to be 1Password compliant?

My CSV file is using the following format (from your Create CSV Files document:
Login Title No Quotation Marks,URL,Username,Password,Custom Field 1, Custom Field 2


1Password Version: 7.2.581
Extension Version: 1.11.0
OS Version: Windows 10 Business
Sync Type: Not Provided
Referrer: forum-search:csv

Comments

  • MrCMrC Community Moderator
    edited October 2018

    @Zectzozda ,

    CSV has some specific requirements, which unless you know the rules, can trip up manual creation of the proper format.

    Open your CSV file in a spreadsheet, and be sure all the data appears in each cell. If your data is all appearing in a single cell on a row, this indicates your CSV file isn't correctly formatted.

    It's best to use a spreadsheet program to create CSV. All spreadsheets have the ability to export as CSV data. You'll want to export it with commas as separators, quoted (if that option exists), and encoded as UTF-8.

    https://support.1password.com/create-csv-files/

    Note: technically, the CSV in the examples on that link is improperly formatted - some cells are not quoted, but they should be.

  • @MrC,

    Ahh, my CSV file contains each value in a single cell. So, the format should be:
    | Title | URL | username | password | etc.

    I'll reformat and try again. Thanks for the quick response!

  • MrCMrC Community Moderator

    @Zectzozda ,

    Good work.

    The rows of your CSV Login data would be:

    Notes and the columns after that (the custom fields) are optional.

  • Hi MrC,

    Apologies for the belated response. I didn't have any email notifications enabled. Thanks for your response!

    This topic can be resolved :)

  • MrCMrC Community Moderator

    @Zectzozda

    Your thread, your time frame!

    Enjoy 1Password.

  • brentybrenty

    Team Member

    Indeed. But we're here if you have any questions about 1Password. Cheers! :) :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file