Safari 12 not allowing extensions

Dear AgileBits,
You have caused quite a nightmare for me. I've been using 1Password for four or five years with no problems. All of a sudden the extension disappeared. When I went to 1Password 6, I was advised to upgrade to 1Password 7. I did. But I kept getting error messages saying I had to upgrade Safari in order to use the 1Password extension, which is what I was trying to do in the first place. So I upgraded Safari to Safari 12. Extensions are disabled; in theory they can be enabled in the Develop menu, but in reality Safari won't allow me to uncheck the box. So now I have none of the several extensions on which I depend, including 1Password. I looked around, and apparently this is a general problem. WHAT NOW??


1Password Version: 7
Extension Version: none
OS Version: OS 10.13.6
Sync Type: Dropbox

Comments

  • dancodanco Senior Member Community Moderator

    With Safari 12, Apple started moving to anew approach to extensions, and AgileBits have been responding to this.

    You should update 1PW to 7.2.1. I believe that this is only slowly being made available in Check for Updates, but it can be downloaded directly from AgileBits. And 7.2.1 contains within it the new extension, but you may have to enable it in Preferences > Extensions.

    If you had stayed on Safari 11 you will have found that the Safari extension is no longer available from AgileBits but can be downloaded from https://safari-extensions.apple.com/details/?id=com.agilebits.onepassword4-safari-2BUA8C4S2C because of Apple's changes.

    Are you on a subscription or a licence? If on a sub, the upgrade from 1PW6 to 1PW7 is free, but if you have a licence it is a paid upgrade. And mostly there is no reason to use Dropbox sync if you are on a sub, as it is then all done behind the scenes through 1password.com

  • LarsLars Junior Member

    Team Member

    Welcome to the forum, @historydoll! I'm sorry for the trouble. As I see @danco has already mentioned, Safari 12 brought a couple of big changes with it. The main one is that in Safari 12, older .safariextz-style extensions (like we and other developers were using in previous versions) have been deprecated in favor of the new Safari App Extensions. Upgrading to 1Password 7 for Mac would have removed the older extension you had and replaced it with a new one compatible with Safari 12. Or at least it should have. But you say you're not able to enable extensions in Safari at all? Is that still the case?

  • Sorry for the hijack, but I am having this exact same issue. MacBook Pro 2016 10.14.1 - I did a fresh install yesterday and installed 1Password as a direct download from your site. Enabled the extension and everything working normally. Today, I got a notification to enable the 1Password extension and when opening Safari preferences get the message that I need to enable extensions from the develop menu - I had not disabled them. I'm running 1Password 7.2.2. I suspect the extol has been quarantined?

  • Just to update, I am unable to untick "Disable Extensions" from the develop menu unless I first allow unsigned extensions from the same menu...1Password is the only extension I have installed...

  • BenBen AWS Team

    Team Member

    @MED1975

    Which version of the 1Password extension do you have installed in Safari 12?

    Ben

  • Since updating to 7.2.2 my extension has disappeared in Safari as well. Extension version is 7.2.1 so I guess that's why, I have automatically update extensions ticked but seems to have got out of step. How do I get them back in line? Thanks.

  • rudyrudy

    Team Member

    @pob17,

    Have you quit and relaunched Safari?

    Do you have multiple copies of 1Password 7 installed on connected drives?

  • Restarting safari didn't sort it, but restarting my mac has done - thank you.

  • I’ve rebooted etc. Just to explain, the extension has not disappeared from safari but extensions themselves have been disabled. The only way to enable the extension is through the dev menu. In there is the option to disable extensions. This is not possible to disable (ie to enable extensions) unless I allow unsigned extensions. This makes me think that there is an issue with the 1Password extension that I have installed. It is the only extension I currently have on a fresh Mojave install.

  • And now weirdly it’s okay? Very strange behaviour.

  • BenBen AWS Team

    Team Member

    Thanks for the update. If we can be of further assistance, please don't hesitate to contact us.

    Ben

  • edited February 11

    I am having the same problem that is reported in this string for the first time today. My Safari 1Password extension disappeared. It was there yesterday. I googled the problem, learned how to show "Develop" in Safari Menu, and I too see now that somehow "Disable Extensions" is clicked. But I can't un-click it. MacOS 10.14.3, Safari 12.0.3, 1Password 7.2.4 installed on my 2016 MacBookPro.
    Don't know what version of 1Password Safari Extension I was running because I can't access it. Safari>Preferences>Extensions just gives me this line "Extensions can be enabled in the Develop menu." No they can't because I can't de-click "Disable Extensions". Thoughts?

  • edited February 11

    I should add that my 1Password extension is working in Chrome and Firefox. It's just that Safari is the browser I use most.

  • LarsLars Junior Member

    Team Member

    @dorringtonsteve - this is an issue with Safari, not 1Password. In some cases, a restart of your Mac (note: NOT just 1Password or Safari, your Mac) has resolved the issue. We lack the ability to troubleshoot it since it involves Safari and affects us, rather than being something caused by or in 1Password. I'd try a restart, and if that doesn't work, you may need to get in contact with Apple to address the issue.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file