Using the browser extension on chrome canary not working anymore

Hi,
I run 1password on Mac and yesterday got updates for the Mac OS for Mojave and the 1password updated to 7
I run both regular chrome and canary - regular one works fine but canary isn't working
the extensions tries to find the app but can't. I had to fix it before for canary when it the missing folder issue but not sure if I should look for that again or what else might have changes


1Password Version: 7.2.1
Extension Version: 4.7.3.90
OS Version: Mac OS Mojave
Sync Type: Not Provided

Comments

  • Hi @talile,

    It's likely the JSON file you previously copied over needs updating. To avoid needing to do this again at some point in the future I recommend the following steps.

    1. In Finder use the menu option Go > Go to Folder...
    2. Copy and paste the following path and click the Go button. The path to use is ~/Library/Application Support/Google/Chrome Canary/NativeMessagingHosts/
    3. Move the file titled 2bua8c4s2c.com.agilebits.1password.json to the Trash.
    4. Open a Terminal window.
    5. Copy and paste the following command into the Terminal window. The command is (all one line) ln -s ~/Library/Application\ Support/Google/Chrome/NativeMessagingHosts/2bua8c4s2c.com.agilebits.1password.json ~/Library/Application\ Support/Google/Chrome\ Canary/NativeMessagingHosts/
    6. Restart Chrome Canary.

    You should find the extension now works again and because we're creating a symlink this time you shouldn't need to bother with this dance again in the future, Chrome Canary will always see the latest JSON file written to the Chrome folder. If you don't see normal extension functionality in Chrome please let me know.

  • It took a few tries with computer restarts but it did work. Thank you very much!

  • Glad to hear things are working again. You shouldn't have any trouble in the future now we've set up a symlink.

  • Perfect ... worked for me as well first shot!

  • brentybrenty

    Team Member

    Glad it helped. Happy holidays! :chuffed:

  • Yeh, this does not work for me I'm afraid.
    1Password 7
    Version 7.2.4 (70204000)
    AgileBits Store

    Google Chrome is up to date
    Version 73.0.3673.0 (Official Build) canary (64-bit)

  • Hi @spaceshipdev,

    If it isn't If you see “1Password can’t save or fill” when you open your browser (just the For all browsers section) and you performed the steps in my previous post then we'll probably need to review a diagnostic report. Can you create one please and send it in. This link will guide you through the steps and has sections for the various supported versions of 1Password.

    How to send a 1Password diagnostics report

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    Once you've sent the report you should received an automated response from us with a ticket ID. If you can post that ticket ID here it will help us locate your diagnostic report and we'll see what it reveals.

  • Trying the latest ver of Google Canary - (Version 74.0.3711.0 (Official Build) canary (64-bit) but 1 Password extension not working. It opens a tab and says "looking for 1Password App"? Anything I can do?

  • brentybrenty

    Team Member

    @KMWAZ: I'm not sure it will work there. If you use Chrome 72, does that work as expected?

  • @brenty - Ye sit works fine on ver 72, non Canary. Apologies I thought this thread was about using it with Canary.

  • Hello @KMWAZ,

    Have you tried the steps from my earlier post in this thread, the first reply to the original message?

    Compatibility with Chrome Canary isn't as seamless as Chrome but 1Password will connect to Chrome Canary. It sounds like the native messaging file the extension needs isn't in place and those steps should help resolve the issue if that's the case.

  • Hi @littlebobbytables - I did read that and tried it. I just re-read it and it looks like I missed the final step "restart" Canary. I just did and it works. I guess I was in too big of a hurry. There goes my infallibility ;-) Thanks for the input.

  • brentybrenty

    Team Member

    Aha. That always gets me too, because I hate restarting. Glad to hear that helped in your case. :)

  • This does work, thanks. But I have to do it every day. Any ideas?

  • Hi @Gavin_Cooper,

    If you follow the steps I detailed in my first reply then no, you should only ever need to do this once unless you start deleting entire folders related to Chrome or Chrome Canary. My steps will mean that any change made by 1Password to the support file for Chrome will be mirrored for Chrome Canary thanks to the symlink.

  • Hi, @littlebobbytables

    Thanks for the reply. I'd actually removed Chrome completely. Have now reinstalled and re-followed your steps. Let's see if that sorts it!

  • Hi @Gavin_Cooper,

    If you only want to keep Chrome Canary on disk you can get rid of the Chrome application bundle. The support folder is all we need and as that's independent of the actual application you can delete Chrome and things will still work.

    Basically ~/Library/Application Support/Google/ is the parent folder for both Chrome and Chrome Canary but they maintain completely separate support folders. My suggested steps will ensure the two are linked in terms of our file and all you need to do is not delete the ~/Library/Application\ Support/Google/Chrome/NativeMessagingHosts/ folder to keep things working.

  • @littlebobbytables This still works perfectly, thanks a lot!!!!!

  • brentybrenty

    Team Member

    Glad that helped! Information for Canary and similar issues with other browser can also be found on our support site:

    If you see “couldn’t connect to 1Password” in your browser

    Cheers! :)

  • Hi, I only installed Chrome Canary but not Chrome, can I still make it work?

  • ag_anaag_ana

    Team Member

    @alazyrabbit:

    You only need to install Chrome to get the necessary folder. Once you have it, you can remove Chrome and keep Chrome Canary only.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file