1Password X does not fill username on signal.co

SystemSystem

Team Member
edited November 20 in 1Password X
This discussion was created from comments split from: Fill inside input field not working for a specific site.

Comments

  • Hey folks. I think 1PW is a fantastic product and I think the way this community has been set up is just great.

    I have an issue with auto fill lately. Yes, I know 1PW does not autofill like some browsers do and that's not what I mean. I mean the autofill upon my command to fill the info. I have cases where consistently one of the fields is not autofilled. I have tried to change the field name in my 1PW entry with the field/id name of the element on the website but still it seems to fail. How can this happen? Am I missing out on something here / doing something wrong? Or could it be that some website prevent certain fields from autofilling?

  • Greetings @mark24332,

    I hope you don't mind but I've split your query away from the other conversation. Where possible we like to keep issues with different sites as separate conversations because what might help with one may not help with another, not unless the issue ends up being something quite generic.

    In order to better understand what might be going wrong I'd like to learn what extension and version of the extension you're using i.e. is it 1Password X or is it the companion extension that connects to the 1Password application and I'd also love to learn the URL of the site in question, that is if you don't mind reporting it here in our public support forum. Armed with these details I can test and see what I learn. It may be there is something we can suggest to help while we file an issue and work on making 1Password more reliable out of the box.

  • Sure, no problem. I have had this issue with 1PW X Chrome extension version 1.12.3 for the website https://hub.signal.co/login. It autofills the password but the email fields is not autofilled. I have had it autofill in the past but at some point it stopped working. Really would like to understand why it does not autofill and if there is a custom way to make it autofill (tried doing this by naming the field in 1PWX the same as in the website but that does not do it). Let me know if you think more information is required.

  • littlebobbytableslittlebobbytables

    Team Member
    edited November 20

    Hi @mark24332,

    Armed with the URL I've tested and found exactly as you have, it refuses to fill the username field. Now the page seems very clean and simple so at first I was surprised. Then when I looked at the fields I see the site has set the autocomplete attribute for both and it's designated both as being for a new password. Not even the current password, a new password as if the form was for a changing a password. I don't know if it's intentional to try and mess with filling that uses the autocomplete attribute or if it's just a mistake but my suspicion is this is throwing 1Password off. Regardless of whether it's by mistake or intentional though, really the site is in the wrong here but if we can come up with sensible guards to protect against this that would make 1Password better. Ideally though we would be able to trust a site when it supplies the autocomplete designations.

    ref: xplatform/brain#43

  • Ah already figured this would probably be at play. Interestingly it did work at some point in the past so I guess they changed something. Too bad it is the website and there is nothing we can do about it. Thanks for looking into this.

    More in general is my assumption correct that i can change the field name in 1PWX to Make sure it looks at the correct field in the website. If true, how come this website https://welcome.coremetrics.com/analyticswebapp/jsp/login.jsp consistently fills another client id than the one in 1PWX. I just Really want to understand How this technically works. :)

  • Hi @mark24332,

    While matching a label to a field ID is one approach, it's just one of many factors 1Password may use to try and determine what to fill and where. Certain factors carry more weight than others and I confess I'm a little behind in knowing all the things we look at. It's very possible changes in 1Password X are why it worked before and doesn't now, I just wonder if the wrong autocomplete attribute means the newer code is struggling.

    I took a look at the page you linked us to. What I found is after saving a Login item that it seemed to fill all three fields correctly. I wonder if you could try saving an entirely new Login item just to compare.

  • Awesome, saving a new login works. Will give that a try first if I run into similar issues. Thanks for your help. Cheers!

  • Hi @mark24332,

    It's definitely one of the things I try if I'm trying to figure an odd filling puzzle out :smile: Of course we'll always be here as well if you find other unusual sites and as we saw with signal.co, sometimes it does mean we need to file reports because things just aren't working.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file