1Password X no longer providing current passwords after turning on 2FA

I've been using 1Password for many years now, and am using both 1Password 7.2.581 on Windows 10 and 1Password X 1.12.3 in Chrome 70.0.3538.110 on Windows 10. Recently I turned on 2FA for 1Password, and all of my 1Password clients (Windows 10 as well as Android) asked me for the new 2FA code the next time I used them. But 1Password X didn't. And ever since that change, any newly updated password in 1Password Windows doesn't sync to 1Password X anymore, so my browser logins are out-of-date and try to enter outdated passwords?!


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • Hello @afalk42,

    I believe we identified a couple of regressions this week that would likely be the cause of what you're experiencing. While we work on getting these fixes out I believe if you remove the 1Password X extension and reinstall it this somewhat blunt approach will help force things to correct themselves. Not great but the first goal is to try and get things working again while we ensure you don't have to face this again.

  • Hi @littlebobbytables
    Unfortunately the problems have continued. Whenever I sign into the 1Password X Chrome extension, it now opens a new tab and takes me to 1Password.com and asks me to sign in there. Even if I do that, there is still no synchronization of my data with 1Password X.
    I have needed to take the step now to disable 2FA again from my account, because 1Password X become unworkable.
    Once you've figured out a solution that works for 2FA with 1Password X, please let me know, and I'll try it again....

  • ag_sebastianag_sebastian 1Password Alumni

    Hi there @afalk42,

    I've tried reproducing the behavior you're seeing, but it seems to work properly for me. Therefore, I'd like to ask you to try the following:

    1. Turn on 2FA
    2. Create a new Chrome profile
    3. In that profile, sign into your account on 1Password.com
    4. Add 1Password X and sign into your account by confirming the Master Password
    5. Try using 1Password X and see if it syncs properly.

    Let me know how it goes. On an unrelated note, happy New Year! :)

  • Hi @ag_sebastian
    Not a practical suggestion, I'm afraid. The problem is precisely that I have a Chrome profile that is synchronized between multiple machines. If I go to one machine to uninstall 1Password X and then install it again, on that one machine it asks me for the 2FA once. But then Chrome synchronizes my profile with all my other machines, and 1Password X gets installed on all of those other machines, too. And there it does NOT ask for 2FA anymore, and instead gives me outdated information.

  • brentybrenty

    Team Member

    @afalk42: It's really pretty easy to create a new profile to test it, and that could help narrow down the problem. That's why Sebastian suggested it.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file