OTP not working for team members

johnclayjohnclay
edited December 2018 in Business and Teams

I've setup TOTP for a few logins (mostly O365 to start), and unfortunately while the 1P entry generates a TOTP code on their device (iOS, and macOS apps), it's invalid.

If I use the code generated by my devices, it does work.

Any idea as to what's going on?


1Password Version: 7.2.2
Extension Version: Not Provided
OS Version: 10.14.2
Sync Type: Teams

Comments

  • brentybrenty

    Team Member

    @johnclay: Can you clarify? These statements seem contradictory:

    while the 1P entry generates a TOTP code on their device (iOS, and macOS apps), it's invalid.

    and

    If I use the code generated by my devices, it does work.

    So I'm guessing there's something I'm missing.

    Ultimately 1Password is doing the exact same thing across all platforms: taking the static TOTP secret and doing the calculation based on the current time/date/zone setting to generate the code, so unless you've enetered the wrong TOTP secret, it's specific to your device since otherwise everyone else would be experiencing the same issue. The code will not be the same and/or valid if the date/time/zone settings are off, so set them manually if you have to. That can help since none of us have quartz crystals for timekeeping in this stuff, and time synchronization issues are not at all uncommon over Wi-Fi. Let me know what you find!

  • @brenty

    I figured it would be something silly like that; the clock on the computer was off by about 30 seconds. Not enough to be obvious, but enough to cause the problem.

    Thanks!

  • brentybrenty

    Team Member

    Thanks so much for the update! Indeed, 30 seconds will often do it, as one-time passwords usually expire around that mark. Glad that did the trick for you. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file