1Password seems to work great on everything except my Citibank (Costco) log in. What's up?

I can log in by typing the same information by hand or from the saved Safari password, but it will not accept the same information from 1Password. I even deleted the previous log in on 1Password and had it save the working password as new. I signed out and attempted to sign in again via 1Password and it was still rejected. Tried same on Firefox. Same result.


1Password Version: 7.1.2
Extension Version: Safari
OS Version: OS X 10.12.6
Sync Type: Not Provided
Referrer: forum-search:1Password will not work with Citibank card (Costco)

Comments

  • brentybrenty

    Team Member

    @dataminn: Thanks for getting in touch! I can't say for certain since I don't have a Costco credit card and am not sure if there's any difference in the process with that, but I have other accounts with Citi that I log into with 1Password, so I think there's a good chance there's a solution.

    First and foremost, you'll get the best experience by updating 1Password and your browser (and, let's be honest, your OS). You should be running at least Safari 12 and 1Password 7.2.2, so check the App Store for updates (and 1Password, if you've installed it from our website -- otherwise you'd update through the App Store as well).

    Next, can you give me the specifics about the URL where you're having trouble signing in, and the specific issue you're seeing? I'll be happy to test it and see if there's a way to get it working. Thanks in advance! :)

  • Hi Bretty,

    Thanks for the response. I know my OS is probably on its last legs. We have been talking about retiring the Mac, but it continues to give good service. In regards to the other suggestions, I am running Safari 12.0.2. When I check for 1Password updates, I am told my software is current at 7.0.2. Is this the case because of my OS or is there another explanation?

  • Additional, my wife's laptop is OS 10.14.1, 1Password 7.2.2, and Firefox 64.0, so all is current. It has the same issue with logging into Citi (Costco). We are properly taken to the site, the user name and password fill and it is then rejected. I enter exactly the same information by hand and it is accepted.

  • brentybrenty

    Team Member

    @dataminn: Thank you! On your own Mac, make sure you install the latest version of 1Password. It's needed in order to work with Safari 12:

    https://1password.com/downloads/

    It sounds like your wife already has it though. :)

    I don't think that's your problem with Citi though. When you go to that page, enter your "User ID", and then select the "Password" field, you'll notice that they change your email address from something like "[email protected]" to "my****************om". I don't know why they do that, so don't ask me! :lol:

    Anyway, as a result, you have probably saved the messed up contents of the "User ID" field in 1Password. Please edit the item to make sure it has your actual User ID, not the mangling the website did to it. I suspect that will work better for you. :)

  • LewLew Junior Member

    My issue with logging in to Citi was it not accepting my ID and password the first time it was entered. It would always require a second attempt.

    I learned just today that signing in using the following url works the first time every time: https://online.citi.com/US/login.do

  • brentybrenty

    Team Member

    That's my go-to as well. Just as long as you've got your full username and password in the login item, you should be all set. Cheers! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file