1Password 7 upgrade

Hello, having been on 1Password 4 on Windows having not wanted to go to subscription, I finally saw today you offer standalone licenses.

I've now downloaded 1P 7 for Windows, uninstalled 1P 4, but I'm having issues.

I was never asked whether I had an account/existing vaults on first load. The first load wouldn't let me do anything. I rebooted my PC (not mentioned in the upgrade help pages, it just said uninstall 1P 4), and it did load up. However, it's now telling me I can't do something with Dropbox from within the app. I can't tell you what because I have to close the prompt to do anything, but the gist of it is that I can't do whatever it is asking of me without a Secret Key (which I do not possess, as I do not have a 1Password account).

I've also managed to convert my old agilekeychain to an opvault. This does seem to be syncing with Dropbox fine, and is working on my iOS app. However, I can't remove the agilekeychain from my iOS app and it's still set to Primary, with seemingly no way of changing this. I think I've managed to workaround this and disable it from syncing and only show the opvault, but surely I should be able to remove it so there's no way of confusion.

Finally, the question I have that means I've picked this forum: I want to purchase a standalone license. If I click "1Password > License" it shows me a box saying I have a 1Password Membership and gives me no option to purchase. How do I give you my money and buy a license?

1Password Version: 7.2.617
Extension Version: Not Provided
OS Version: Win10
Sync Type: Not Provided


  • hawkiihawkii
    edited December 2018

    Okay an update, I installed on my laptop today. It prompted me for a reboot when I uninstalled 1P 4 (which it definitely didn't yesterday). I received the expected "Have you used this before" etc messages and managed to actually buy a license!

    Unfortunately I've now discovered the license is a file, and the download "link" in the receipt e-mail isn't a link at all and I now have no way of accessing my license. What was wrong with using numbers like past versions?

    Any ideas on how to access my license since the e-mail doesn't work?


    Okay the fifth e-mail client I tried (iOS default of all things) finally worked, the link refused to work on any of the three different webmail software my provider offers, nor did it work in Outlook 365 desktop client.

    I've now re-installed it on my first PC - same trouble again after the first reinstall and reboot, i deleted all 1Password stuff in AppData and it worked the second time.

    I think I'm now finally upgraded and working! Hardly a pain free process...

    I still have the issue in the iOS client refusing to "remove" the old agilekeychain vault, any ideas?

  • BenBen AWS Team

    Team Member

    Hi @hawkii

    I'm sorry to hear you had trouble, but I'm glad to hear it sounds like you're on the right track. For the issue on iOS I'd recommend uninstalling and reinstalling the iOS app. From the welcome screen scroll down and select the option to sync with Dropbox.

    I hope that helps!


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file